diff options
author | Alex Kiernan <alex.kiernan@gmail.com> | 2022-12-31 18:06:45 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-12-31 10:41:12 -0800 |
commit | e941f2f79dba49fc7637db35c6dc2be64e78a9af (patch) | |
tree | 16778b797f461bad3e8b5d809e1b7ecfd61b8e34 /meta-oe | |
parent | 517593abb608930ed2d71baf402e2497fbb7f294 (diff) | |
download | meta-openembedded-e941f2f79dba49fc7637db35c6dc2be64e78a9af.tar.gz |
ostree: Upgrade 2022.5 -> 2022.7
Convert to tarballs which are now being published. Drop backported
fixes, drop s390 bash patch (done differently upstream), drop glibc 2.36
sys/mount fix (done differently upstream), add patch for musl and
ALLPERMS.
v2022.7
(Some of these commits are actually only for the Rust bindings;
will try to enhance the release flow to more clearly filter
those out)
On the feature front, there's new APIs for idempotent delete operations on
kernel arguments, and for handling unshare() to
manipulate (otherwise) read-only sysroot.
A few very small memory leak fixes.
Many people will be happy that we now retry HTTP requests after
receiving HTTP 500 errors.
There's a notable bugfix avoiding rebuilding SELinux policy
when creating a first deployment.
Thanks to all contributors!
Colin Walters (18):
Remove readdir-rand
deploy: Don't rebuild selinux policy on first deployment
ci: Bump memory for ISO testing flow
rust: Update to cap-std 1.0
rust: Drop `openat` dependency
ci: Fix case where cosa != buildroot
rust: Update to gio 0.16
repo: Avoid potential double unwind when writing panic value
Allow missing docs on two `glib::wrapper` functions
sysroot: Add an API to initialize with mountns
rust: Regenerate with latest gir and C sources
tests/inst: Update to latest ostree-ext
tests/inst: Drop nix dependency
tests/inst: Update cap-std-ext to 1.0
tests/inst: Update sh-inline
tests: Require OSTREE_TEST_SUDO to be set to use `sudo`
ci: Add a flow that combines C build and Rust integration tests
Release 2022.7
Jonathan Lebon (4):
ci: Bump memory request, use fcosKolaTestIso
ci: Drop unnecessary outer stage
ci: Use new names for custom kola steps
ci: bump cosaPod memory requirement to 5Gi
Luca BRUNO (20):
configure: post-release version bump
lib/repo-checkout: fix typo in error message
lib/bootloader-zipl: check for errors when opening initrd
lib/static-delta: document and check parameters format
rust/tests: fix static delta generation testcase
lib/sign-ed25519: convert invariant checks to assertions
rust: regenerate bindings after latest release (2022.6)
ostree: manually patch generated files
rust: update manual helpers
ci/rust: bump linting toolchain to latest stable (1.64)
lib/repo-refs: properly return an error value
rust: update pinned gir tool to 0.15
rust/ostree-sys: regenerate for gtk-rs 0.15
rust/ostree: regenerate for gtk-rs 0.15
ci/rust: test from git using latest feature
cargo: prepare ostree 0.16.0 and ostree-sys 0.11.0
copr: only use libostree tags
ci: adjust git tags filtering
cargo: bump minimum Rust version to 1.63
ostree: manually patch generated files
Manuel Stühn (1):
Add test for generating static delta to file
Philip Withnall (4):
ot-builtin-commit: Fix a typo in a command line help string
ot-builtin-commit: Don’t mention a C function name in a help string
lib/pull: Fix a small leak when a variable is reused
ot-builtin-pull: Fix a minor leak with progress reporting
Rafael Garcia Ruiz (2):
ostree_kernel_args_contains for OstreeKernelArgs
Idempotent delete operation for OstreeKernelArgs
Ricardo Noriega (2):
Enabling retry for HTTP 500 internal server error
Add tests for cases under random 500s
Simon McVittie (2):
readdir-rand: Copy full size of struct dirent
Replace calls to g_memdup() with g_memdup2()
dependabot[bot] (2):
build(deps): bump libglnx from `26375b5` to `e701578`
build(deps): bump libglnx from `e701578` to `4e44fd9`
2022.6
This release contains a collection of bugfixes and enhancements. Notable
fixes concern finalize-staged, which should now better support
automounted partitions and skip waiting for termination signal.
A file descriptor leak has been fixed in the commit logic. The codebase
has also been fixed to avoid conflicting declarations when building with
latest glibc (>= 2.36). Thanks @GeorgesStavracas for both fixes!
On the feature side, there is now basic support for handling overlayfs
whiteouts on checkout through a new --process-passthrough-whiteouts
flag. This is useful for users that need to carry container storage
embedded into ostree commits. Thanks @mangelajo for that!
The ostree rev-parse command gained a new --single flag to better
support repositories containing exactly one commit. Overall, the s390x
Secure Execution (SE) logic has been reworked to stop relying on glue
scripts.
Thanks to all contributors!
Andrea Perotti (1):
Fix recursive git archive reference
Colin Walters (12):
configure: post-release version bump
rust-bindings: Fix `cargo fmt`
deny.toml: Add `Unicode-DFS-2016`
Remove unused `linux/fs.h` includes
Move FIFREEZE/FITHAW ioctl invocations into linuxfsutil.c
cli/rev-parse: Port to new code style
cli/rev-parse: Add `--single` option
rust: Update to latest git
ci: Also drop seccomp on debian testing
rust: Bind `ostree_repo_list_commits_starting_with`
finalize-staged: Don't listen to `SIGTERM`, just let kernel exit us
README.md: Link otto
Dan Nicholson (3):
main: Factor out sysroot loading
finalize-staged: Ensure /boot automount doesn't expire
lib/pull: Fix max-metadata-size documentation
Georges Basile Stavracas Neto (1):
lib/commit: Unref repo on success
Huijing Hei (1):
Fix `ostree admin kargs edit-in-place` assertion when deployments are pending
Jon Oster (1):
docs: Add aktualizr and TorizonCore to related projects
Jonathan Lebon (3):
lib/commit: Directly use FICLONE for payload link
tests/kolainst/staged-deploy: parse `rpm-ostree status --json` instead
docs: Add section about staged deployments
Luca BRUNO (7):
libostree: fix a typo in annotation
lib/bootloader: assert invariants
lib/mtree: drop redundant name checks
otutil: add error handling to variant builders
lib/sign: convert invariant checks to assertions
lib/repo: properly initialize boolean variable
lib/sysroot-deploy: explicitly handle `g_variant_lookup` results
Lukas Kalbertodt (1):
Update to `libtest-mimic` 0.5.0
Miguel Angel Ajo (1):
Support overlayfs whiteouts on checkout
Nikita Dubrovskii (3):
s390x: ensure both 'root' and 'boot' luks keys exist
s390x: simplify 's390x-se-luks-gencpio' script
s390x: use 'libarchive' to modify initrd in SE case
Sam James (1):
buildutil/glibtests.m4: fix bashism
dependabot[bot] (1):
build(deps): bump libglnx from `c59eb27` to `26375b5`
git-bruh (1):
ostree-fetcher-curl: check for HTTP2 support before trying to use it
Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-extended/ostree/ostree/0001-Remove-unused-linux-fs.h-includes.patch | 42 | ||||
-rw-r--r-- | meta-oe/recipes-extended/ostree/ostree/0001-deploy-Don-t-rebuild-selinux-policy-on-first-deploym.patch | 44 | ||||
-rw-r--r-- | meta-oe/recipes-extended/ostree/ostree/0001-lib-repo-checkout-Add-ALLPERMS-for-musl.patch | 32 | ||||
-rw-r--r-- | meta-oe/recipes-extended/ostree/ostree/0001-libostree-Remove-including-sys-mount.h.patch | 29 | ||||
-rw-r--r-- | meta-oe/recipes-extended/ostree/ostree/0001-s390x-se-luks-gencpio-There-is-no-bashism.patch | 25 | ||||
-rw-r--r-- | meta-oe/recipes-extended/ostree/ostree_2022.7.bb (renamed from meta-oe/recipes-extended/ostree/ostree_2022.5.bb) | 11 |
6 files changed, 36 insertions, 147 deletions
diff --git a/meta-oe/recipes-extended/ostree/ostree/0001-Remove-unused-linux-fs.h-includes.patch b/meta-oe/recipes-extended/ostree/ostree/0001-Remove-unused-linux-fs.h-includes.patch deleted file mode 100644 index 2659e4696..000000000 --- a/meta-oe/recipes-extended/ostree/ostree/0001-Remove-unused-linux-fs.h-includes.patch +++ /dev/null | |||
@@ -1,42 +0,0 @@ | |||
1 | From 7d32c352f628747cfadabf9fe7fcc13608e5dfe6 Mon Sep 17 00:00:00 2001 | ||
2 | From: Colin Walters <walters@verbum.org> | ||
3 | Date: Wed, 3 Aug 2022 10:37:40 -0400 | ||
4 | Subject: [PATCH] Remove unused `linux/fs.h` includes | ||
5 | |||
6 | Prep for fixing conflicts introduced by newer glibc. | ||
7 | cc https://github.com/ostreedev/ostree/issues/2685 | ||
8 | |||
9 | Upstream-Status: Backport [https://github.com/ostreedev/ostree/commit/edba4b33be10c05253bfa94895dfbc8477e44d76] | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | src/libostree/ostree-repo-commit.c | 1 - | ||
13 | src/ostree/ot-main.c | 1 - | ||
14 | 2 files changed, 2 deletions(-) | ||
15 | |||
16 | diff --git a/src/libostree/ostree-repo-commit.c b/src/libostree/ostree-repo-commit.c | ||
17 | index afab3fdf..35b16c71 100644 | ||
18 | --- a/src/libostree/ostree-repo-commit.c | ||
19 | +++ b/src/libostree/ostree-repo-commit.c | ||
20 | @@ -30,7 +30,6 @@ | ||
21 | #include <sys/xattr.h> | ||
22 | #include <glib/gprintf.h> | ||
23 | #include <sys/ioctl.h> | ||
24 | -#include <linux/fs.h> | ||
25 | #include <ext2fs/ext2_fs.h> | ||
26 | |||
27 | #include "otutil.h" | ||
28 | diff --git a/src/ostree/ot-main.c b/src/ostree/ot-main.c | ||
29 | index b7b50d67..7a4405a5 100644 | ||
30 | --- a/src/ostree/ot-main.c | ||
31 | +++ b/src/ostree/ot-main.c | ||
32 | @@ -28,7 +28,6 @@ | ||
33 | #include <string.h> | ||
34 | #include <sys/statvfs.h> | ||
35 | #include <sys/mount.h> | ||
36 | -#include <linux/fs.h> | ||
37 | |||
38 | #include "ot-main.h" | ||
39 | #include "ostree.h" | ||
40 | -- | ||
41 | 2.37.1 | ||
42 | |||
diff --git a/meta-oe/recipes-extended/ostree/ostree/0001-deploy-Don-t-rebuild-selinux-policy-on-first-deploym.patch b/meta-oe/recipes-extended/ostree/ostree/0001-deploy-Don-t-rebuild-selinux-policy-on-first-deploym.patch deleted file mode 100644 index 248dcf49b..000000000 --- a/meta-oe/recipes-extended/ostree/ostree/0001-deploy-Don-t-rebuild-selinux-policy-on-first-deploym.patch +++ /dev/null | |||
@@ -1,44 +0,0 @@ | |||
1 | From bd325061dc9585886f7e60e58d9fc0c8b37e71db Mon Sep 17 00:00:00 2001 | ||
2 | From: Colin Walters <walters@verbum.org> | ||
3 | Date: Wed, 9 Nov 2022 11:18:36 -0500 | ||
4 | Subject: [PATCH] deploy: Don't rebuild selinux policy on first deployment | ||
5 | |||
6 | Basically, it should not be necessary - the policy should be | ||
7 | up-to-date. We don't want to force on continual policy rebuilds. | ||
8 | |||
9 | Even trying to run bwrap when we're *not* in a booted | ||
10 | root can cause failures in nested containerization scenarios. | ||
11 | |||
12 | Closes: https://github.com/ostreedev/ostree/issues/2758 | ||
13 | |||
14 | Upstream-Status: Backport | ||
15 | [https://github.com/ostreedev/ostree/commit/bd325061dc9585886f7e60e58d9fc0c8b37e71db] | ||
16 | |||
17 | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | ||
18 | --- | ||
19 | src/libostree/ostree-sysroot-deploy.c | 6 +++--- | ||
20 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
21 | |||
22 | diff --git a/src/libostree/ostree-sysroot-deploy.c b/src/libostree/ostree-sysroot-deploy.c | ||
23 | index f27ae0e1..26b07080 100644 | ||
24 | --- a/src/libostree/ostree-sysroot-deploy.c | ||
25 | +++ b/src/libostree/ostree-sysroot-deploy.c | ||
26 | @@ -2987,12 +2987,12 @@ sysroot_finalize_deployment (OstreeSysroot *self, | ||
27 | if (!merge_configuration_from (self, merge_deployment, deployment, deployment_dfd, | ||
28 | cancellable, error)) | ||
29 | return FALSE; | ||
30 | - } | ||
31 | |||
32 | #ifdef HAVE_SELINUX | ||
33 | - if (!sysroot_finalize_selinux_policy(deployment_dfd, error)) | ||
34 | - return FALSE; | ||
35 | + if (!sysroot_finalize_selinux_policy (deployment_dfd, error)) | ||
36 | + return FALSE; | ||
37 | #endif /* HAVE_SELINUX */ | ||
38 | + } | ||
39 | |||
40 | const char *osdeploypath = glnx_strjoina ("ostree/deploy/", ostree_deployment_get_osname (deployment)); | ||
41 | glnx_autofd int os_deploy_dfd = -1; | ||
42 | -- | ||
43 | 2.25.1 | ||
44 | |||
diff --git a/meta-oe/recipes-extended/ostree/ostree/0001-lib-repo-checkout-Add-ALLPERMS-for-musl.patch b/meta-oe/recipes-extended/ostree/ostree/0001-lib-repo-checkout-Add-ALLPERMS-for-musl.patch new file mode 100644 index 000000000..1502f1d4f --- /dev/null +++ b/meta-oe/recipes-extended/ostree/ostree/0001-lib-repo-checkout-Add-ALLPERMS-for-musl.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 6aef666a2911c15b31efeed08d89fe9997d89e04 Mon Sep 17 00:00:00 2001 | ||
2 | From: Alex Kiernan <alex.kiernan@gmail.com> | ||
3 | Date: Sat, 31 Dec 2022 11:11:14 +0000 | ||
4 | Subject: [PATCH] lib/repo-checkout: Add ALLPERMS for musl | ||
5 | |||
6 | ALLPERMS is glibc specific, add a definition for musl. | ||
7 | |||
8 | Upstream-Status: Submitted [https://github.com/ostreedev/ostree/pull/2797] | ||
9 | Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> | ||
10 | --- | ||
11 | src/libostree/ostree-core-private.h | 5 +++++ | ||
12 | 1 file changed, 5 insertions(+) | ||
13 | |||
14 | diff --git a/src/libostree/ostree-core-private.h b/src/libostree/ostree-core-private.h | ||
15 | index 2bd2f9848718..48b2b8ab307f 100644 | ||
16 | --- a/src/libostree/ostree-core-private.h | ||
17 | +++ b/src/libostree/ostree-core-private.h | ||
18 | @@ -34,6 +34,11 @@ G_BEGIN_DECLS | ||
19 | #define DEFAULT_DIRECTORY_MODE 0775 | ||
20 | #define DEFAULT_REGFILE_MODE 0660 | ||
21 | |||
22 | +/* This exists in glibc's sys/stat.h, but not on musl */ | ||
23 | +#ifndef ALLPERMS | ||
24 | +#define ALLPERMS (S_ISUID|S_ISGID|S_ISVTX|S_IRWXU|S_IRWXG|S_IRWXO) | ||
25 | +#endif | ||
26 | + | ||
27 | /* This file contains private implementation data format definitions | ||
28 | * read by multiple implementation .c files. | ||
29 | */ | ||
30 | -- | ||
31 | 2.39.0 | ||
32 | |||
diff --git a/meta-oe/recipes-extended/ostree/ostree/0001-libostree-Remove-including-sys-mount.h.patch b/meta-oe/recipes-extended/ostree/ostree/0001-libostree-Remove-including-sys-mount.h.patch deleted file mode 100644 index 5c2792cf8..000000000 --- a/meta-oe/recipes-extended/ostree/ostree/0001-libostree-Remove-including-sys-mount.h.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | From 7ff956e4088e0bdc6bfd429f99124a8a9256c181 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 6 Aug 2022 21:44:11 -0700 | ||
4 | Subject: [PATCH] libostree: Remove including sys/mount.h | ||
5 | |||
6 | This conflicts with linux/mount.h which is included by linux/fs.h | ||
7 | with glibc 2.36+ | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | src/libostree/ostree-sysroot-deploy.c | 1 - | ||
13 | 1 file changed, 1 deletion(-) | ||
14 | |||
15 | diff --git a/src/libostree/ostree-sysroot-deploy.c b/src/libostree/ostree-sysroot-deploy.c | ||
16 | index 2dc9f58b..61b19e42 100644 | ||
17 | --- a/src/libostree/ostree-sysroot-deploy.c | ||
18 | +++ b/src/libostree/ostree-sysroot-deploy.c | ||
19 | @@ -23,7 +23,6 @@ | ||
20 | #include <gio/gunixoutputstream.h> | ||
21 | #include <glib-unix.h> | ||
22 | #include <stdint.h> | ||
23 | -#include <sys/mount.h> | ||
24 | #include <sys/statvfs.h> | ||
25 | #include <sys/socket.h> | ||
26 | #include <sys/ioctl.h> | ||
27 | -- | ||
28 | 2.37.1 | ||
29 | |||
diff --git a/meta-oe/recipes-extended/ostree/ostree/0001-s390x-se-luks-gencpio-There-is-no-bashism.patch b/meta-oe/recipes-extended/ostree/ostree/0001-s390x-se-luks-gencpio-There-is-no-bashism.patch deleted file mode 100644 index 5cf5784f1..000000000 --- a/meta-oe/recipes-extended/ostree/ostree/0001-s390x-se-luks-gencpio-There-is-no-bashism.patch +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | From dd55633e49aa43dede3c8e1770ae8761487f050e Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 6 Aug 2022 21:52:31 -0700 | ||
4 | Subject: [PATCH] s390x-se-luks-gencpio: There is no bashism | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | src/libostree/s390x-se-luks-gencpio | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/src/libostree/s390x-se-luks-gencpio b/src/libostree/s390x-se-luks-gencpio | ||
14 | index e821e2fe..96c1d123 100755 | ||
15 | --- a/src/libostree/s390x-se-luks-gencpio | ||
16 | +++ b/src/libostree/s390x-se-luks-gencpio | ||
17 | @@ -1,4 +1,4 @@ | ||
18 | -#!/bin/bash | ||
19 | +#!/bin/sh | ||
20 | # This script creates new initramdisk with LUKS config within | ||
21 | set -euo pipefail | ||
22 | |||
23 | -- | ||
24 | 2.37.1 | ||
25 | |||
diff --git a/meta-oe/recipes-extended/ostree/ostree_2022.5.bb b/meta-oe/recipes-extended/ostree/ostree_2022.7.bb index c6ac7cbea..771b17b34 100644 --- a/meta-oe/recipes-extended/ostree/ostree_2022.5.bb +++ b/meta-oe/recipes-extended/ostree/ostree_2022.7.bb | |||
@@ -18,18 +18,15 @@ DEPENDS = " \ | |||
18 | " | 18 | " |
19 | 19 | ||
20 | SRC_URI = " \ | 20 | SRC_URI = " \ |
21 | gitsm://github.com/ostreedev/ostree;branch=main;protocol=https \ | 21 | https://github.com/ostreedev/ostree/releases/download/v${PV}/libostree-${PV}.tar.xz \ |
22 | file://0001-Remove-unused-linux-fs.h-includes.patch \ | 22 | file://0001-lib-repo-checkout-Add-ALLPERMS-for-musl.patch \ |
23 | file://0001-libostree-Remove-including-sys-mount.h.patch \ | ||
24 | file://0001-s390x-se-luks-gencpio-There-is-no-bashism.patch \ | ||
25 | file://0001-deploy-Don-t-rebuild-selinux-policy-on-first-deploym.patch \ | ||
26 | file://run-ptest \ | 23 | file://run-ptest \ |
27 | " | 24 | " |
28 | SRCREV = "15740d042c9c5258a1c082b5e228cf6f115edbb0" | 25 | SRC_URI[sha256sum] = "8be2a9261c94e8b9ec4113380ffc480f8598245fb321a009bad4fae4b822411f" |
29 | 26 | ||
30 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+\.\d+)" | 27 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+\.\d+)" |
31 | 28 | ||
32 | S = "${WORKDIR}/git" | 29 | S = "${WORKDIR}/libostree-${PV}" |
33 | 30 | ||
34 | inherit autotools bash-completion gobject-introspection gtk-doc manpages pkgconfig ptest-gnome systemd | 31 | inherit autotools bash-completion gobject-introspection gtk-doc manpages pkgconfig ptest-gnome systemd |
35 | 32 | ||