diff options
author | André Draszik <andre.draszik@jci.com> | 2019-01-13 10:55:51 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-01-13 10:28:01 -0800 |
commit | e219649594742a200c1dd5d28e8bf2f5eda2504e (patch) | |
tree | a83798cb84c1fcbe44cd2035aaaaba840966090b /meta-oe | |
parent | 24af1f974cc95c50dfa56ad15b113279c3993c5d (diff) | |
download | meta-openembedded-e219649594742a200c1dd5d28e8bf2f5eda2504e.tar.gz |
meta-oe: remove True option to getVar calls (again)
A couple have still been missed in the past despite multiple
attempts at doing so (or simply have re-appeared?).
Search & replace made using the following command:
sed -e 's|\(d\.getVar \?\)( \?\([^,()]*\), \?True)|\1(\2)|g' \
-i $(git grep -E 'getVar ?\( ?([^,()]*), ?True\)' \
| cut -d':' -f1 \
| sort -u)
Signed-off-by: André Draszik <andre.draszik@jci.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/classes/scancode.bbclass | 10 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/luajit/luajit_2.0.5.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/php/php.inc | 2 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/bpftool/bpftool.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/cpupower/cpupower.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-support/opencv/opencv_3.4.3.bb | 4 |
7 files changed, 12 insertions, 12 deletions
diff --git a/meta-oe/classes/scancode.bbclass b/meta-oe/classes/scancode.bbclass index 701660f57..e0f0dbca4 100644 --- a/meta-oe/classes/scancode.bbclass +++ b/meta-oe/classes/scancode.bbclass | |||
@@ -3,18 +3,18 @@ | |||
3 | # For more informaiton https://github.com/nexB/scancode-toolkit | 3 | # For more informaiton https://github.com/nexB/scancode-toolkit |
4 | 4 | ||
5 | SCANCODE_FORMAT ?= "html-app" | 5 | SCANCODE_FORMAT ?= "html-app" |
6 | EXT = "${@'html' if d.getVar('SCANCODE_FORMAT', True) == 'html-app' else 'json'}" | 6 | EXT = "${@'html' if d.getVar('SCANCODE_FORMAT') == 'html-app' else 'json'}" |
7 | SCANCODE_TOOLKIT = "${@get_scancode_toolkit(d)}" | 7 | SCANCODE_TOOLKIT = "${@get_scancode_toolkit(d)}" |
8 | SCANCODE_TAG = "v2.2.1" | 8 | SCANCODE_TAG = "v2.2.1" |
9 | SCANCODE_GIT_LOCATION ?= "https://github.com/nexB/scancode-toolkit.git" | 9 | SCANCODE_GIT_LOCATION ?= "https://github.com/nexB/scancode-toolkit.git" |
10 | SCANCODE_SRC_LOCATION ?= "${DL_DIR}/scancode" | 10 | SCANCODE_SRC_LOCATION ?= "${DL_DIR}/scancode" |
11 | 11 | ||
12 | def get_scancode_toolkit(d): | 12 | def get_scancode_toolkit(d): |
13 | lf = bb.utils.lockfile(d.getVar('SCANCODE_SRC_LOCATION', True) + ".lock") | 13 | lf = bb.utils.lockfile(d.getVar('SCANCODE_SRC_LOCATION') + ".lock") |
14 | if (not os.path.exists(d.getVar('SCANCODE_SRC_LOCATION', True))): | 14 | if (not os.path.exists(d.getVar('SCANCODE_SRC_LOCATION'))): |
15 | os.system("git clone %s %s -b %s" % (d.getVar('SCANCODE_GIT_LOCATION', True), d.getVar('SCANCODE_SRC_LOCATION', True), d.getVar('SCANCODE_TAG', True))) | 15 | os.system("git clone %s %s -b %s" % (d.getVar('SCANCODE_GIT_LOCATION'), d.getVar('SCANCODE_SRC_LOCATION'), d.getVar('SCANCODE_TAG'))) |
16 | bb.utils.unlockfile(lf) | 16 | bb.utils.unlockfile(lf) |
17 | return (d.getVar('SCANCODE_SRC_LOCATION', True)) | 17 | return (d.getVar('SCANCODE_SRC_LOCATION')) |
18 | 18 | ||
19 | do_scancode() { | 19 | do_scancode() { |
20 | mkdir -p ${DEPLOY_DIR_IMAGE}/scancode | 20 | mkdir -p ${DEPLOY_DIR_IMAGE}/scancode |
diff --git a/meta-oe/recipes-devtools/luajit/luajit_2.0.5.bb b/meta-oe/recipes-devtools/luajit/luajit_2.0.5.bb index f3a0f70ee..c2d2180ba 100644 --- a/meta-oe/recipes-devtools/luajit/luajit_2.0.5.bb +++ b/meta-oe/recipes-devtools/luajit/luajit_2.0.5.bb | |||
@@ -22,7 +22,7 @@ BBCLASSEXTEND = "native" | |||
22 | # you need to install the multilib development package (e.g. | 22 | # you need to install the multilib development package (e.g. |
23 | # libc6-dev-i386 on Debian/Ubuntu) and build a 32 bit host part | 23 | # libc6-dev-i386 on Debian/Ubuntu) and build a 32 bit host part |
24 | # (HOST_CC="gcc -m32"). | 24 | # (HOST_CC="gcc -m32"). |
25 | BUILD_CC_ARCH_append = " ${@['-m32',''][d.getVar('SITEINFO_BITS', True) != '32']}" | 25 | BUILD_CC_ARCH_append = " ${@['-m32',''][d.getVar('SITEINFO_BITS') != '32']}" |
26 | 26 | ||
27 | # The lua makefiles expect the TARGET_SYS to be from uname -s | 27 | # The lua makefiles expect the TARGET_SYS to be from uname -s |
28 | # Values: Windows, Linux, Darwin, iOS, SunOS, PS3, GNU/kFreeBSD | 28 | # Values: Windows, Linux, Darwin, iOS, SunOS, PS3, GNU/kFreeBSD |
diff --git a/meta-oe/recipes-devtools/php/php.inc b/meta-oe/recipes-devtools/php/php.inc index bfd0ddfb8..ca7bd91b2 100644 --- a/meta-oe/recipes-devtools/php/php.inc +++ b/meta-oe/recipes-devtools/php/php.inc | |||
@@ -8,7 +8,7 @@ BBCLASSEXTEND = "native" | |||
8 | DEPENDS = "zlib bzip2 libxml2 virtual/libiconv php-native lemon-native" | 8 | DEPENDS = "zlib bzip2 libxml2 virtual/libiconv php-native lemon-native" |
9 | DEPENDS_class-native = "zlib-native libxml2-native" | 9 | DEPENDS_class-native = "zlib-native libxml2-native" |
10 | 10 | ||
11 | PHP_MAJOR_VERSION = "${@d.getVar('PV', True).split('.')[0]}" | 11 | PHP_MAJOR_VERSION = "${@d.getVar('PV').split('.')[0]}" |
12 | 12 | ||
13 | SRC_URI = "http://php.net/distributions/php-${PV}.tar.bz2 \ | 13 | SRC_URI = "http://php.net/distributions/php-${PV}.tar.bz2 \ |
14 | file://0001-php-don-t-use-broken-wrapper-for-mkdir.patch \ | 14 | file://0001-php-don-t-use-broken-wrapper-for-mkdir.patch \ |
diff --git a/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb b/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb index ca38e6aa2..30c850365 100644 --- a/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb +++ b/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb | |||
@@ -21,7 +21,7 @@ LDFLAGS_append_libc-musl = " -largp" | |||
21 | 21 | ||
22 | def set_target_arch(d): | 22 | def set_target_arch(d): |
23 | import re | 23 | import re |
24 | arch = d.getVar('TARGET_ARCH', True) | 24 | arch = d.getVar('TARGET_ARCH') |
25 | if re.match(r'i.86', arch, re.I): | 25 | if re.match(r'i.86', arch, re.I): |
26 | return 'i386' | 26 | return 'i386' |
27 | else: | 27 | else: |
diff --git a/meta-oe/recipes-kernel/bpftool/bpftool.bb b/meta-oe/recipes-kernel/bpftool/bpftool.bb index dd7eaa2aa..f75ac6f81 100644 --- a/meta-oe/recipes-kernel/bpftool/bpftool.bb +++ b/meta-oe/recipes-kernel/bpftool/bpftool.bb | |||
@@ -27,7 +27,7 @@ do_install() { | |||
27 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 27 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
28 | 28 | ||
29 | python do_package_prepend() { | 29 | python do_package_prepend() { |
30 | d.setVar('PKGV', d.getVar("KERNEL_VERSION", True).split("-")[0]) | 30 | d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0]) |
31 | } | 31 | } |
32 | 32 | ||
33 | B = "${WORKDIR}/${BPN}-${PV}" | 33 | B = "${WORKDIR}/${BPN}-${PV}" |
diff --git a/meta-oe/recipes-kernel/cpupower/cpupower.bb b/meta-oe/recipes-kernel/cpupower/cpupower.bb index 4544f5b2e..928973871 100644 --- a/meta-oe/recipes-kernel/cpupower/cpupower.bb +++ b/meta-oe/recipes-kernel/cpupower/cpupower.bb | |||
@@ -30,7 +30,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}" | |||
30 | RDEPENDS_${PN} = "bash" | 30 | RDEPENDS_${PN} = "bash" |
31 | 31 | ||
32 | python do_package_prepend() { | 32 | python do_package_prepend() { |
33 | d.setVar('PKGV', d.getVar("KERNEL_VERSION", True).split("-")[0]) | 33 | d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0]) |
34 | } | 34 | } |
35 | 35 | ||
36 | B = "${WORKDIR}/${BPN}-${PV}" | 36 | B = "${WORKDIR}/${BPN}-${PV}" |
diff --git a/meta-oe/recipes-support/opencv/opencv_3.4.3.bb b/meta-oe/recipes-support/opencv/opencv_3.4.3.bb index 0a99700b4..2b25e39dc 100644 --- a/meta-oe/recipes-support/opencv/opencv_3.4.3.bb +++ b/meta-oe/recipes-support/opencv/opencv_3.4.3.bb | |||
@@ -20,7 +20,7 @@ SRC_URI[tinydnn.sha256sum] = "e2c61ce8c5debaa644121179e9dbdcf83f497f39de853f8dd5 | |||
20 | 20 | ||
21 | def ipp_filename(d): | 21 | def ipp_filename(d): |
22 | import re | 22 | import re |
23 | arch = d.getVar('TARGET_ARCH', True) | 23 | arch = d.getVar('TARGET_ARCH') |
24 | if re.match("i.86$", arch): | 24 | if re.match("i.86$", arch): |
25 | return "ippicv_2017u3_lnx_ia32_general_20180518.tgz" | 25 | return "ippicv_2017u3_lnx_ia32_general_20180518.tgz" |
26 | else: | 26 | else: |
@@ -28,7 +28,7 @@ def ipp_filename(d): | |||
28 | 28 | ||
29 | def ipp_md5sum(d): | 29 | def ipp_md5sum(d): |
30 | import re | 30 | import re |
31 | arch = d.getVar('TARGET_ARCH', True) | 31 | arch = d.getVar('TARGET_ARCH') |
32 | if re.match("i.86$", arch): | 32 | if re.match("i.86$", arch): |
33 | return "ea72de74dae3c604eb6348395366e78e" | 33 | return "ea72de74dae3c604eb6348395366e78e" |
34 | else: | 34 | else: |