diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2016-02-25 17:37:00 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-03-04 09:06:22 +0100 |
commit | df7242fddb9048738c0cdfaf0c3c227bf78f3da7 (patch) | |
tree | 93d90103179618fe595aa26a7bfab1a0afd55418 /meta-oe | |
parent | 7396fc62068a41d2ad88cc03d0ca485279510d55 (diff) | |
download | meta-openembedded-df7242fddb9048738c0cdfaf0c3c227bf78f3da7.tar.gz |
recipes: Replace "cp -a" with "cp -R --no-dereference --preserve=mode,links"
* Using "cp -a" leaks UID of user running the builds, causing
many QA warnings.
* See this thread for details:
http://lists.openembedded.org/pipermail/openembedded-core/2015-November/112904.html
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-benchmark/fio/fio_2.2.6.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/lua/lua_5.3.2.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-extended/tipcutils/tipcutils_2.0.6.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-multimedia/live555/live555.inc | 10 | ||||
-rw-r--r-- | meta-oe/recipes-navigation/orrery/orrery_2.7.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb | 4 | ||||
-rw-r--r-- | meta-oe/recipes-support/tbb/tbb_4.1.bb | 2 |
7 files changed, 12 insertions, 12 deletions
diff --git a/meta-oe/recipes-benchmark/fio/fio_2.2.6.bb b/meta-oe/recipes-benchmark/fio/fio_2.2.6.bb index 5bf387c3a..db6717300 100644 --- a/meta-oe/recipes-benchmark/fio/fio_2.2.6.bb +++ b/meta-oe/recipes-benchmark/fio/fio_2.2.6.bb | |||
@@ -37,5 +37,5 @@ do_configure() { | |||
37 | do_install() { | 37 | do_install() { |
38 | oe_runmake install DESTDIR=${D} prefix=${prefix} mandir=${mandir} | 38 | oe_runmake install DESTDIR=${D} prefix=${prefix} mandir=${mandir} |
39 | install -d ${D}/${docdir}/${PN} | 39 | install -d ${D}/${docdir}/${PN} |
40 | cp -a ${S}/examples ${D}/${docdir}/${PN}/ | 40 | cp -R --no-dereference --preserve=mode,links -v ${S}/examples ${D}/${docdir}/${PN}/ |
41 | } | 41 | } |
diff --git a/meta-oe/recipes-devtools/lua/lua_5.3.2.bb b/meta-oe/recipes-devtools/lua/lua_5.3.2.bb index f97ed509f..07a1a433c 100644 --- a/meta-oe/recipes-devtools/lua/lua_5.3.2.bb +++ b/meta-oe/recipes-devtools/lua/lua_5.3.2.bb | |||
@@ -55,7 +55,7 @@ do_install () { | |||
55 | } | 55 | } |
56 | 56 | ||
57 | do_install_ptest () { | 57 | do_install_ptest () { |
58 | cp -a ${WORKDIR}/lua-${PV}-tests ${D}${PTEST_PATH}/test | 58 | cp -R --no-dereference --preserve=mode,links -v ${WORKDIR}/lua-${PV}-tests ${D}${PTEST_PATH}/test |
59 | } | 59 | } |
60 | 60 | ||
61 | BBCLASSEXTEND = "native" | 61 | BBCLASSEXTEND = "native" |
diff --git a/meta-oe/recipes-extended/tipcutils/tipcutils_2.0.6.bb b/meta-oe/recipes-extended/tipcutils/tipcutils_2.0.6.bb index 85035d9c8..0ac8fad29 100644 --- a/meta-oe/recipes-extended/tipcutils/tipcutils_2.0.6.bb +++ b/meta-oe/recipes-extended/tipcutils/tipcutils_2.0.6.bb | |||
@@ -33,7 +33,7 @@ do_install_append() { | |||
33 | install ${B}/ptts/tipcTC ${D}/opt/tipcutils/ptts/ | 33 | install ${B}/ptts/tipcTC ${D}/opt/tipcutils/ptts/ |
34 | 34 | ||
35 | install -d ${D}${sysconfdir} | 35 | install -d ${D}${sysconfdir} |
36 | cp -a ${S}/scripts/etc/* ${D}${sysconfdir}/ | 36 | cp -R --no-dereference --preserve=mode,links -v ${S}/scripts/etc/* ${D}${sysconfdir}/ |
37 | chown -R root:root ${D}${sysconfdir} | 37 | chown -R root:root ${D}${sysconfdir} |
38 | } | 38 | } |
39 | 39 | ||
diff --git a/meta-oe/recipes-multimedia/live555/live555.inc b/meta-oe/recipes-multimedia/live555/live555.inc index 0c8208a22..0d11de904 100644 --- a/meta-oe/recipes-multimedia/live555/live555.inc +++ b/meta-oe/recipes-multimedia/live555/live555.inc | |||
@@ -34,11 +34,11 @@ do_install() { | |||
34 | install -d ${D}${includedir}/liveMedia | 34 | install -d ${D}${includedir}/liveMedia |
35 | install -d ${D}${includedir}/UsageEnvironment | 35 | install -d ${D}${includedir}/UsageEnvironment |
36 | install -d ${D}${libdir} | 36 | install -d ${D}${libdir} |
37 | cp -a ${S}/BasicUsageEnvironment/include/*.hh ${D}${includedir}/BasicUsageEnvironment/ | 37 | cp -R --no-dereference --preserve=mode,links -v ${S}/BasicUsageEnvironment/include/*.hh ${D}${includedir}/BasicUsageEnvironment/ |
38 | cp -a ${S}/groupsock/include/*.h ${D}${includedir}/groupsock/ | 38 | cp -R --no-dereference --preserve=mode,links -v ${S}/groupsock/include/*.h ${D}${includedir}/groupsock/ |
39 | cp -a ${S}/groupsock/include/*.hh ${D}${includedir}/groupsock/ | 39 | cp -R --no-dereference --preserve=mode,links -v ${S}/groupsock/include/*.hh ${D}${includedir}/groupsock/ |
40 | cp -a ${S}/liveMedia/include/*.hh ${D}${includedir}/liveMedia/ | 40 | cp -R --no-dereference --preserve=mode,links -v ${S}/liveMedia/include/*.hh ${D}${includedir}/liveMedia/ |
41 | cp -a ${S}/UsageEnvironment/include/*.hh ${D}${includedir}/UsageEnvironment/ | 41 | cp -R --no-dereference --preserve=mode,links -v ${S}/UsageEnvironment/include/*.hh ${D}${includedir}/UsageEnvironment/ |
42 | # Find all the headers | 42 | # Find all the headers |
43 | for i in $(find . -name "*.hh") $(find . -name "*.h") ; do | 43 | for i in $(find . -name "*.hh") $(find . -name "*.h") ; do |
44 | install ${i} ${D}${includedir} | 44 | install ${i} ${D}${includedir} |
diff --git a/meta-oe/recipes-navigation/orrery/orrery_2.7.bb b/meta-oe/recipes-navigation/orrery/orrery_2.7.bb index 617afbc99..40a6df3c9 100644 --- a/meta-oe/recipes-navigation/orrery/orrery_2.7.bb +++ b/meta-oe/recipes-navigation/orrery/orrery_2.7.bb | |||
@@ -23,7 +23,7 @@ do_configure_prepend() { | |||
23 | } | 23 | } |
24 | do_install_append() { | 24 | do_install_append() { |
25 | install -d ${D}${datadir}/orrery | 25 | install -d ${D}${datadir}/orrery |
26 | cp -a ${S}/data/* ${D}${datadir}/orrery | 26 | cp -R --no-dereference --preserve=mode,links -v ${S}/data/* ${D}${datadir}/orrery |
27 | chown -R root:root ${D}${datadir}/orrery | 27 | chown -R root:root ${D}${datadir}/orrery |
28 | install -d ${D}${datadir}/icons | 28 | install -d ${D}${datadir}/icons |
29 | install -m 0755 ${WORKDIR}/orrery.png ${D}${datadir}/icons | 29 | install -m 0755 ${WORKDIR}/orrery.png ${D}${datadir}/icons |
diff --git a/meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb b/meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb index 18979d574..35c891e7a 100644 --- a/meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb +++ b/meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb | |||
@@ -19,10 +19,10 @@ EXTRA_OECONF = "--without-x \ | |||
19 | 19 | ||
20 | do_configure() { | 20 | do_configure() { |
21 | export topdir=${S} | 21 | export topdir=${S} |
22 | cp -a ${S}/autoconf/configure.in ${S} | 22 | cp -R --no-dereference --preserve=mode,links -v ${S}/autoconf/configure.in ${S} |
23 | 23 | ||
24 | if ! [ -d ${S}/platforms/${DISTRO} ] ; then | 24 | if ! [ -d ${S}/platforms/${DISTRO} ] ; then |
25 | cp -a ${S}/platforms/unknown ${S}/platforms/${DISTRO} | 25 | cp -R --no-dereference --preserve=mode,links -v ${S}/platforms/unknown ${S}/platforms/${DISTRO} |
26 | fi | 26 | fi |
27 | 27 | ||
28 | gnu-configize --force | 28 | gnu-configize --force |
diff --git a/meta-oe/recipes-support/tbb/tbb_4.1.bb b/meta-oe/recipes-support/tbb/tbb_4.1.bb index 55212dc6c..09ed6ec52 100644 --- a/meta-oe/recipes-support/tbb/tbb_4.1.bb +++ b/meta-oe/recipes-support/tbb/tbb_4.1.bb | |||
@@ -26,7 +26,7 @@ do_compile() { | |||
26 | do_install() { | 26 | do_install() { |
27 | install -d ${D}${includedir} ${D}${libdir}/pkgconfig | 27 | install -d ${D}${includedir} ${D}${libdir}/pkgconfig |
28 | rm ${S}/include/tbb/index.html -f | 28 | rm ${S}/include/tbb/index.html -f |
29 | cp -a ${S}/include/tbb ${D}${includedir} | 29 | cp -R --no-dereference --preserve=mode,links -v ${S}/include/tbb ${D}${includedir} |
30 | install -m 0755 ${B}/build/linux_*_release/lib*.so* ${D}${libdir} | 30 | install -m 0755 ${B}/build/linux_*_release/lib*.so* ${D}${libdir} |
31 | install -m 0644 ${WORKDIR}/tbb.pc ${D}${libdir}/pkgconfig | 31 | install -m 0644 ${WORKDIR}/tbb.pc ${D}${libdir}/pkgconfig |
32 | } | 32 | } |