diff options
author | Changqing Li <changqing.li@windriver.com> | 2023-01-05 08:52:17 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-01-06 11:38:16 -0800 |
commit | d869383b0f9848a07ab3d7fbb5b7f687dce7744a (patch) | |
tree | a37dd0b1fc686b868518447e80b9d00868d0435d /meta-oe | |
parent | 097b1a7e7c8a13ec71a240a78483e6157c3038ce (diff) | |
download | meta-openembedded-d869383b0f9848a07ab3d7fbb5b7f687dce7744a.tar.gz |
redis: 7.0.5 -> 7.0.7
This upgrade include fix for CVE-2022-3647
Signed-off-by: Changqing Li <changqing.li@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-extended/redis/redis-7/0006-Define-correct-gregs-for-RISCV32.patch | 20 | ||||
-rw-r--r-- | meta-oe/recipes-extended/redis/redis_7.0.7.bb (renamed from meta-oe/recipes-extended/redis/redis_7.0.5.bb) | 2 |
2 files changed, 12 insertions, 10 deletions
diff --git a/meta-oe/recipes-extended/redis/redis-7/0006-Define-correct-gregs-for-RISCV32.patch b/meta-oe/recipes-extended/redis/redis-7/0006-Define-correct-gregs-for-RISCV32.patch index 01f842181..385b0aeed 100644 --- a/meta-oe/recipes-extended/redis/redis-7/0006-Define-correct-gregs-for-RISCV32.patch +++ b/meta-oe/recipes-extended/redis/redis-7/0006-Define-correct-gregs-for-RISCV32.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From f26a978c638bcbc621669dce0ab89e43af42af98 Mon Sep 17 00:00:00 2001 | 1 | From b6b2c652abfa98093401b232baca8719c50cadf4 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Mon, 26 Oct 2020 21:32:22 -0700 | 3 | Date: Mon, 26 Oct 2020 21:32:22 -0700 |
4 | Subject: [PATCH] Define correct gregs for RISCV32 | 4 | Subject: [PATCH] Define correct gregs for RISCV32 |
@@ -6,18 +6,17 @@ Subject: [PATCH] Define correct gregs for RISCV32 | |||
6 | Upstream-Status: Pending | 6 | Upstream-Status: Pending |
7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
8 | 8 | ||
9 | Updated patch for 6.2.1 | 9 | Updated patch for 6.2.8 |
10 | Signed-off-by: Yi Fan Yu <yifan.yu@windriver.com> | 10 | Signed-off-by: Changqing Li <changqing.li@windriver.com> |
11 | |||
12 | --- | 11 | --- |
13 | src/debug.c | 26 ++++++++++++++++++++++++-- | 12 | src/debug.c | 26 ++++++++++++++++++++++++-- |
14 | 1 file changed, 24 insertions(+), 2 deletions(-) | 13 | 1 file changed, 24 insertions(+), 2 deletions(-) |
15 | 14 | ||
16 | diff --git a/src/debug.c b/src/debug.c | 15 | diff --git a/src/debug.c b/src/debug.c |
17 | index 2da2c5d..1d778fa 100644 | 16 | index ebda858..90bc450 100644 |
18 | --- a/src/debug.c | 17 | --- a/src/debug.c |
19 | +++ b/src/debug.c | 18 | +++ b/src/debug.c |
20 | @@ -1116,7 +1116,9 @@ static void *getMcontextEip(ucontext_t *uc) { | 19 | @@ -1168,7 +1168,9 @@ static void* getAndSetMcontextEip(ucontext_t *uc, void *eip) { |
21 | #endif | 20 | #endif |
22 | #elif defined(__linux__) | 21 | #elif defined(__linux__) |
23 | /* Linux */ | 22 | /* Linux */ |
@@ -25,10 +24,10 @@ index 2da2c5d..1d778fa 100644 | |||
25 | + #if defined(__riscv) && __riscv_xlen == 32 | 24 | + #if defined(__riscv) && __riscv_xlen == 32 |
26 | + return (void*) uc->uc_mcontext.__gregs[REG_PC]; | 25 | + return (void*) uc->uc_mcontext.__gregs[REG_PC]; |
27 | + #elif defined(__i386__) || ((defined(__X86_64__) || defined(__x86_64__)) && defined(__ILP32__)) | 26 | + #elif defined(__i386__) || ((defined(__X86_64__) || defined(__x86_64__)) && defined(__ILP32__)) |
28 | return (void*) uc->uc_mcontext.gregs[14]; /* Linux 32 */ | 27 | GET_SET_RETURN(uc->uc_mcontext.gregs[14], eip); |
29 | #elif defined(__X86_64__) || defined(__x86_64__) | 28 | #elif defined(__X86_64__) || defined(__x86_64__) |
30 | return (void*) uc->uc_mcontext.gregs[16]; /* Linux 64 */ | 29 | GET_SET_RETURN(uc->uc_mcontext.gregs[16], eip); |
31 | @@ -1298,8 +1300,28 @@ void logRegisters(ucontext_t *uc) { | 30 | @@ -1350,8 +1352,28 @@ void logRegisters(ucontext_t *uc) { |
32 | #endif | 31 | #endif |
33 | /* Linux */ | 32 | /* Linux */ |
34 | #elif defined(__linux__) | 33 | #elif defined(__linux__) |
@@ -58,3 +57,6 @@ index 2da2c5d..1d778fa 100644 | |||
58 | serverLog(LL_WARNING, | 57 | serverLog(LL_WARNING, |
59 | "\n" | 58 | "\n" |
60 | "EAX:%08lx EBX:%08lx ECX:%08lx EDX:%08lx\n" | 59 | "EAX:%08lx EBX:%08lx ECX:%08lx EDX:%08lx\n" |
60 | -- | ||
61 | 2.25.1 | ||
62 | |||
diff --git a/meta-oe/recipes-extended/redis/redis_7.0.5.bb b/meta-oe/recipes-extended/redis/redis_7.0.7.bb index 7ed151922..58055166c 100644 --- a/meta-oe/recipes-extended/redis/redis_7.0.5.bb +++ b/meta-oe/recipes-extended/redis/redis_7.0.7.bb | |||
@@ -19,7 +19,7 @@ SRC_URI = "http://download.redis.io/releases/${BP}.tar.gz \ | |||
19 | file://GNU_SOURCE-7.patch \ | 19 | file://GNU_SOURCE-7.patch \ |
20 | file://0006-Define-correct-gregs-for-RISCV32.patch \ | 20 | file://0006-Define-correct-gregs-for-RISCV32.patch \ |
21 | " | 21 | " |
22 | SRC_URI[sha256sum] = "67054cc37b58c125df93bd78000261ec0ef4436a26b40f38262c780e56315cc3" | 22 | SRC_URI[sha256sum] = "8d327d7e887d1bb308fc37aaf717a0bf79f58129e3739069aaeeae88955ac586" |
23 | 23 | ||
24 | inherit autotools-brokensep update-rc.d systemd useradd | 24 | inherit autotools-brokensep update-rc.d systemd useradd |
25 | 25 | ||