summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-12-28 18:30:19 -0800
committerKhem Raj <raj.khem@gmail.com>2022-12-28 18:31:24 -0800
commitd780dc588a201afbd1326adf245577280eda9cb1 (patch)
treeb24c08a55500955105af4e29cb0e8a7f3d168b42 /meta-oe
parent0193b6abb40fc323bcb40e5b9f0857260af076e7 (diff)
downloadmeta-openembedded-d780dc588a201afbd1326adf245577280eda9cb1.tar.gz
abseil-cpp: Replace off64_t with off_t
Fixes TOPDIR/build/tmp/work/cortexa15t2hf-neon-yoe-linux-musleabi/abseil-cpp/20221014.0-r0/git/absl/base/internal/direct_mmap.h:71:25: error: unknown type name 'off64_t'; did you mean 'off_t'? off64_t offset) noexcept { ^~~~~~~ off_t Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0001-direct_mmap-Use-off_t-on-linux.patch42
-rw-r--r--meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb1
2 files changed, 43 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0001-direct_mmap-Use-off_t-on-linux.patch b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0001-direct_mmap-Use-off_t-on-linux.patch
new file mode 100644
index 000000000..49df528d7
--- /dev/null
+++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0001-direct_mmap-Use-off_t-on-linux.patch
@@ -0,0 +1,42 @@
1From 45fdade6c0415ec5af3f9312e6311a4ccc682a7b Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 28 Dec 2022 18:24:21 -0800
4Subject: [PATCH] direct_mmap: Use off_t on linux
5
6off64_t is not provided without defining _LARGEFILE64_SOURCE on musl
7this define is not defined automatically like glibc where it gets
8defined when _GNU_SOURCE is defined. Using off_t makes it portable
9across musl/glibc and for using 64bit off_t on glibc 32bit systems
10-D_FILE_OFFSET_BITS=64 can be defined during build via CXXFLAGS
11
12Upstream-Status: Submitted [https://github.com/abseil/abseil-cpp/pull/1349]
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 absl/base/internal/direct_mmap.h | 4 ++--
16 1 file changed, 2 insertions(+), 2 deletions(-)
17
18diff --git a/absl/base/internal/direct_mmap.h b/absl/base/internal/direct_mmap.h
19index 815b8d23..fdf88f0b 100644
20--- a/absl/base/internal/direct_mmap.h
21+++ b/absl/base/internal/direct_mmap.h
22@@ -72,7 +72,7 @@ namespace base_internal {
23 // Platform specific logic extracted from
24 // https://chromium.googlesource.com/linux-syscall-support/+/master/linux_syscall_support.h
25 inline void* DirectMmap(void* start, size_t length, int prot, int flags, int fd,
26- off64_t offset) noexcept {
27+ off_t offset) noexcept {
28 #if defined(__i386__) || defined(__ARM_ARCH_3__) || defined(__ARM_EABI__) || \
29 defined(__m68k__) || defined(__sh__) || \
30 (defined(__hppa__) && !defined(__LP64__)) || \
31@@ -102,7 +102,7 @@ inline void* DirectMmap(void* start, size_t length, int prot, int flags, int fd,
32 #else
33 return reinterpret_cast<void*>(
34 syscall(SYS_mmap2, start, length, prot, flags, fd,
35- static_cast<off_t>(offset / pagesize)));
36+ offset / pagesize));
37 #endif
38 #elif defined(__s390x__)
39 // On s390x, mmap() arguments are passed in memory.
40--
412.39.0
42
diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
index 9f8c48cfa..f7f8fc848 100644
--- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
+++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
@@ -15,6 +15,7 @@ SRC_URI = "git://github.com/abseil/abseil-cpp;branch=${BRANCH};protocol=https \
15 file://0002-Remove-maes-option-from-cross-compilation.patch \ 15 file://0002-Remove-maes-option-from-cross-compilation.patch \
16 file://abseil-ppc-fixes.patch \ 16 file://abseil-ppc-fixes.patch \
17 file://0003-Remove-neon-option-from-cross-compilation.patch \ 17 file://0003-Remove-neon-option-from-cross-compilation.patch \
18 file://0001-direct_mmap-Use-off_t-on-linux.patch \
18 " 19 "
19 20
20S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"