diff options
author | Andreas Oberritter <obi@opendreambox.org> | 2015-03-27 23:21:00 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-04-13 12:55:49 +0200 |
commit | d1f5abc3e6b0b0737dc7d7fadc95e6600f122d36 (patch) | |
tree | 5ec9ac265165e8d1ef9640cca3124fbcbde0f1cc /meta-oe | |
parent | 9e754c3e23247609e24d6bf268dba05b6266c167 (diff) | |
download | meta-openembedded-d1f5abc3e6b0b0737dc7d7fadc95e6600f122d36.tar.gz |
gateone: move to meta-python
Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
6 files changed, 0 insertions, 198 deletions
diff --git a/meta-oe/recipes-connectivity/gateone/gateone/0001-configuration.py-Hack-around-broken-gethostname-thin.patch b/meta-oe/recipes-connectivity/gateone/gateone/0001-configuration.py-Hack-around-broken-gethostname-thin.patch deleted file mode 100644 index 5f5fa9117..000000000 --- a/meta-oe/recipes-connectivity/gateone/gateone/0001-configuration.py-Hack-around-broken-gethostname-thin.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | From d811d3bdf06d78c93c48bef762c19c392c879077 Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Tue, 26 Nov 2013 15:54:10 +0100 | ||
4 | Subject: [PATCH] configuration.py: Hack around broken gethostname thingy | ||
5 | |||
6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
7 | --- | ||
8 | gateone/core/configuration.py | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/gateone/core/configuration.py b/gateone/core/configuration.py | ||
12 | index da41cbd..d1c8222 100644 | ||
13 | --- a/gateone/core/configuration.py | ||
14 | +++ b/gateone/core/configuration.py | ||
15 | @@ -162,7 +162,7 @@ def define_options(installed=True): | ||
16 | ] | ||
17 | # Used both http and https above to demonstrate that both are acceptable | ||
18 | try: | ||
19 | - additional_origins = socket.gethostbyname_ex(socket.gethostname()) | ||
20 | + additional_origins = [] # additional_origins = socket.gethostbyname_ex(socket.gethostname()) | ||
21 | except socket.gaierror: | ||
22 | # Couldn't get any IPs from the hostname | ||
23 | additional_origins = [] | ||
24 | -- | ||
25 | 1.8.4.2 | ||
26 | |||
diff --git a/meta-oe/recipes-connectivity/gateone/gateone/80oe.conf b/meta-oe/recipes-connectivity/gateone/gateone/80oe.conf deleted file mode 100644 index cde98bc10..000000000 --- a/meta-oe/recipes-connectivity/gateone/gateone/80oe.conf +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | // Some custom Gate One settings for OpenEmbedded | ||
2 | { | ||
3 | "*": { | ||
4 | "gateone": { // These settings apply to all of Gate One | ||
5 | "log_file_max_size": 5242880, // 5 megabyte logs for OE by default (default would normally be 100Mb) | ||
6 | "log_file_num_backups": 2, // Default is normally 10 | ||
7 | "origins": ["*"], // Every device has a unique origin | ||
8 | "logging": "info", | ||
9 | "pid_file": "/var/run/gateone.pid", | ||
10 | "session_dir": "/tmp/gateone", | ||
11 | "user_dir": "/var/lib/gateone/users" | ||
12 | }, | ||
13 | "terminal": { | ||
14 | // Disabling session logging for embedded devices is a good idea (limited/slow storage) | ||
15 | "session_logging": false, | ||
16 | "syslog_session_logging": false | ||
17 | // "commands": { | ||
18 | // // For some reason this doesn't work (never asks for the password) | ||
19 | // "login": "setsid /bin/login" // Normally this would emulate logging into the host console | ||
20 | // } | ||
21 | } | ||
22 | } | ||
23 | } | ||
diff --git a/meta-oe/recipes-connectivity/gateone/gateone/gateone-avahi.service b/meta-oe/recipes-connectivity/gateone/gateone/gateone-avahi.service deleted file mode 100644 index 0f613d18e..000000000 --- a/meta-oe/recipes-connectivity/gateone/gateone/gateone-avahi.service +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | <?xml version="1.0" standalone='no'?><!--*-nxml-*--> | ||
2 | <!DOCTYPE service-group SYSTEM "avahi-service.dtd"> | ||
3 | |||
4 | <service-group> | ||
5 | <name replace-wildcards="yes">GateOne on %h</name> | ||
6 | <service> | ||
7 | <type>_https._tcp</type> | ||
8 | <port>443</port> | ||
9 | </service> | ||
10 | </service-group> | ||
diff --git a/meta-oe/recipes-connectivity/gateone/gateone/gateone-init b/meta-oe/recipes-connectivity/gateone/gateone/gateone-init deleted file mode 100644 index a1cf5ce7e..000000000 --- a/meta-oe/recipes-connectivity/gateone/gateone/gateone-init +++ /dev/null | |||
@@ -1,47 +0,0 @@ | |||
1 | #!/bin/sh -e | ||
2 | ### BEGIN INIT INFO | ||
3 | # Provides: gateone | ||
4 | # Required-Start: networking | ||
5 | # Default-Start: 2 3 4 5 | ||
6 | # Default-Stop: 0 1 6 | ||
7 | # Short-Description: Gateone HTML5 ssh client | ||
8 | # Description: Gateone HTML5 terminal emulator and SSH client. | ||
9 | ### END INIT INFO | ||
10 | |||
11 | . /etc/init.d/functions | ||
12 | |||
13 | NAME=gateone | ||
14 | DAEMON=/var/lib/gateone/gateone.py | ||
15 | PIDFILE=/var/run/gateone.pid | ||
16 | WORKDIR=/var/lib/gateone | ||
17 | |||
18 | do_start() { | ||
19 | cd $WORKDIR | ||
20 | /usr/bin/python $DAEMON > /dev/null 2>&1 & | ||
21 | cd $OLDPWD | ||
22 | } | ||
23 | |||
24 | do_stop() { | ||
25 | kill -TERM `cat $PIDFILE` | ||
26 | } | ||
27 | |||
28 | case "$1" in | ||
29 | start) | ||
30 | echo "Starting gateone" | ||
31 | do_start | ||
32 | ;; | ||
33 | stop) | ||
34 | echo "Stopping gateone" | ||
35 | do_stop | ||
36 | ;; | ||
37 | restart|force-reload) | ||
38 | echo "Restart gateone" | ||
39 | do_stop | ||
40 | sleep 1 | ||
41 | do_start | ||
42 | ;; | ||
43 | *) | ||
44 | echo "Usage: $0 {start|stop|restart|force-reload}" >&2 | ||
45 | exit 1 | ||
46 | ;; | ||
47 | esac | ||
diff --git a/meta-oe/recipes-connectivity/gateone/gateone/gateone.service b/meta-oe/recipes-connectivity/gateone/gateone/gateone.service deleted file mode 100644 index 7b14d3e6d..000000000 --- a/meta-oe/recipes-connectivity/gateone/gateone/gateone.service +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | [Unit] | ||
2 | Description=GateOne daemon | ||
3 | ConditionPathExists=|/var/lib/gateone | ||
4 | |||
5 | [Service] | ||
6 | WorkingDirectory=/var/lib/gateone | ||
7 | ExecStart=/usr/bin/python /usr/bin/gateone | ||
8 | |||
9 | [Install] | ||
10 | WantedBy=multi-user.target | ||
diff --git a/meta-oe/recipes-connectivity/gateone/gateone_git.bb b/meta-oe/recipes-connectivity/gateone/gateone_git.bb deleted file mode 100644 index edc997721..000000000 --- a/meta-oe/recipes-connectivity/gateone/gateone_git.bb +++ /dev/null | |||
@@ -1,82 +0,0 @@ | |||
1 | SUMMARY = "HTML5 (plugin-free) web-based terminal emulator and SSH client" | ||
2 | LICENSE = "AGPL-3.0" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=834cbc6995db88433db17cdf8953a428" | ||
4 | HOMEPAGE = "http://liftoffsoftware.com/Products/GateOne" | ||
5 | |||
6 | PV = "1.2" | ||
7 | SRCREV = "1528d324088fc1c180b7fdf50f5b5c1af057eef6" | ||
8 | SRC_URI = "git://github.com/liftoff/GateOne.git \ | ||
9 | file://0001-configuration.py-Hack-around-broken-gethostname-thin.patch \ | ||
10 | file://gateone-avahi.service \ | ||
11 | file://80oe.conf \ | ||
12 | file://gateone.service \ | ||
13 | file://gateone-init \ | ||
14 | " | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | inherit distutils python-dir systemd update-rc.d | ||
19 | export prefix = "${localstatedir}" | ||
20 | |||
21 | DISTUTILS_INSTALL_ARGS = "--root=${D} \ | ||
22 | --prefix=${prefix} \ | ||
23 | --install-lib=${PYTHON_SITEPACKAGES_DIR} \ | ||
24 | --install-data=${PYTHON_SITEPACKAGES_DIR} \ | ||
25 | --install-scripts=${bindir} \ | ||
26 | --skip_init_scripts" | ||
27 | |||
28 | do_install_append() { | ||
29 | |||
30 | # fix up hardcoded paths | ||
31 | sed -i -e s:/usr/bin:${bindir}:g ${WORKDIR}/gateone.service | ||
32 | |||
33 | install -d ${D}${systemd_unitdir}/system | ||
34 | install -m 0644 ${WORKDIR}/gateone.service ${D}${systemd_unitdir}/system | ||
35 | |||
36 | install -d ${D}${sysconfdir}/init.d | ||
37 | install -m 0755 ${WORKDIR}/gateone-init ${D}${sysconfdir}/init.d/gateone | ||
38 | |||
39 | install -m 0755 -d ${D}${sysconfdir}/avahi/services/ | ||
40 | install -m 0644 ${WORKDIR}/gateone-avahi.service ${D}${sysconfdir}/avahi/services/ | ||
41 | |||
42 | install -m 0755 -d ${D}${sysconfdir}/gateone/conf.d/ | ||
43 | install -m 0644 ${WORKDIR}/80oe.conf ${D}${sysconfdir}/gateone/conf.d/80oe.conf | ||
44 | |||
45 | install -d ${D}${localstatedir}/lib/gateone | ||
46 | } | ||
47 | |||
48 | FILES_${PN} = "${localstatedir}/lib ${bindir} ${base_libdir} ${sysconfdir} ${PYTHON_SITEPACKAGES_DIR}" | ||
49 | RDEPENDS_${PN} = "mime-support \ | ||
50 | openssh-ssh \ | ||
51 | python-compression \ | ||
52 | python-crypt \ | ||
53 | python-datetime \ | ||
54 | python-email \ | ||
55 | python-fcntl \ | ||
56 | python-futures \ | ||
57 | python-html \ | ||
58 | python-imaging \ | ||
59 | python-io \ | ||
60 | python-json \ | ||
61 | python-logging \ | ||
62 | python-misc \ | ||
63 | python-multiprocessing \ | ||
64 | python-netclient \ | ||
65 | python-pkgutil \ | ||
66 | python-pyopenssl \ | ||
67 | python-re \ | ||
68 | python-readline \ | ||
69 | python-setuptools \ | ||
70 | python-shell \ | ||
71 | python-simplejson \ | ||
72 | python-subprocess \ | ||
73 | python-syslog \ | ||
74 | python-terminal \ | ||
75 | python-textutils \ | ||
76 | python-tornado \ | ||
77 | python-unixadmin \ | ||
78 | python-xml \ | ||
79 | " | ||
80 | |||
81 | SYSTEMD_SERVICE_${PN} = "gateone.service" | ||
82 | INITSCRIPT_NAME = "gateone" | ||