diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-06-25 22:34:43 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-07-01 09:59:25 +0200 |
commit | bd66426dc33b66d9b551c48a8091b939126ce8b4 (patch) | |
tree | e8d92253eb1c696957cae11be4e97b6e374970b4 /meta-oe | |
parent | 01d70f84b1f53247b911c50506e5f1a3238d3732 (diff) | |
download | meta-openembedded-bd66426dc33b66d9b551c48a8091b939126ce8b4.tar.gz |
gpm: Use sigemptyset() API for glibc as well
glibc has removed __sigemptyset
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-support/gpm/gpm/0001-Use-sigemptyset-API-instead-of-__sigemptyset.patch | 34 | ||||
-rw-r--r-- | meta-oe/recipes-support/gpm/gpm_git.bb | 4 |
2 files changed, 37 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/gpm/gpm/0001-Use-sigemptyset-API-instead-of-__sigemptyset.patch b/meta-oe/recipes-support/gpm/gpm/0001-Use-sigemptyset-API-instead-of-__sigemptyset.patch new file mode 100644 index 000000000..a9198166a --- /dev/null +++ b/meta-oe/recipes-support/gpm/gpm/0001-Use-sigemptyset-API-instead-of-__sigemptyset.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From 52e6cf052b1f938fcca1bc24d578fe0bfd972988 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sun, 25 Jun 2017 07:25:33 -0700 | ||
4 | Subject: [PATCH] Use sigemptyset API instead of __sigemptyset | ||
5 | |||
6 | __sigemptyset has been removed from glibc public | ||
7 | API headers in upcoming (2.26) release onwards | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | Upstream-Status: Submitted | ||
12 | |||
13 | src/prog/gpm-root.y | 4 ---- | ||
14 | 1 file changed, 4 deletions(-) | ||
15 | |||
16 | diff --git a/src/prog/gpm-root.y b/src/prog/gpm-root.y | ||
17 | index 5126c65..76c896c 100644 | ||
18 | --- a/src/prog/gpm-root.y | ||
19 | +++ b/src/prog/gpm-root.y | ||
20 | @@ -1196,11 +1196,7 @@ int main(int argc, char **argv) | ||
21 | LOG_DAEMON : LOG_USER); | ||
22 | /* reap your zombies */ | ||
23 | childaction.sa_handler=reap_children; | ||
24 | -#if defined(__GLIBC__) | ||
25 | - __sigemptyset(&childaction.sa_mask); | ||
26 | -#else /* __GLIBC__ */ | ||
27 | sigemptyset(&childaction.sa_mask); | ||
28 | -#endif /* __GLIBC__ */ | ||
29 | childaction.sa_flags=0; | ||
30 | sigaction(SIGCHLD,&childaction,NULL); | ||
31 | |||
32 | -- | ||
33 | 2.13.1 | ||
34 | |||
diff --git a/meta-oe/recipes-support/gpm/gpm_git.bb b/meta-oe/recipes-support/gpm/gpm_git.bb index 69f12d9b8..51c4dd639 100644 --- a/meta-oe/recipes-support/gpm/gpm_git.bb +++ b/meta-oe/recipes-support/gpm/gpm_git.bb | |||
@@ -12,10 +12,12 @@ SRCREV = "1fd19417b8a4dd9945347e98dfa97e4cfd798d77" | |||
12 | DEPENDS = "ncurses" | 12 | DEPENDS = "ncurses" |
13 | 13 | ||
14 | SRC_URI = "git://github.com/telmich/gpm;protocol=git \ | 14 | SRC_URI = "git://github.com/telmich/gpm;protocol=git \ |
15 | file://init \ | ||
15 | file://no-docs.patch \ | 16 | file://no-docs.patch \ |
16 | file://processcreds.patch \ | 17 | file://processcreds.patch \ |
17 | file://gpm.service.in \ | 18 | file://gpm.service.in \ |
18 | file://init" | 19 | file://0001-Use-sigemptyset-API-instead-of-__sigemptyset.patch \ |
20 | " | ||
19 | 21 | ||
20 | S = "${WORKDIR}/git" | 22 | S = "${WORKDIR}/git" |
21 | 23 | ||