diff options
author | Amarnath Valluri <amarnath.valluri@intel.com> | 2016-10-21 14:43:35 +0300 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-10-26 10:28:40 +0200 |
commit | b09611969a2a2ab9efbbade402b44241b448918e (patch) | |
tree | 60b3886728cdf9ec62388fdac92cb5e0a1c3fc57 /meta-oe | |
parent | 3587696e114fb650d5c7303b1cb355516c7bb864 (diff) | |
download | meta-openembedded-b09611969a2a2ab9efbbade402b44241b448918e.tar.gz |
glmark2: Enabling c++ 11 features
When build with gcc5, Failed with below errors:
| ../src/image-reader.cpp: In member function 'bool PNGReader::init(const
string&)':
| ../src/image-reader.cpp:123:16: error: 'unique_ptr' in namespace 'std' does
not name a template type
This change explicitly enables c++11 features, as code using them.
Signed-off-by: Amarnath Valluri <amarnath.valluri@intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-benchmark/glmark2/glmark2_git.bb | 3 |
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb index 396ae7094..a2558a72a 100644 --- a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb +++ b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb | |||
@@ -28,6 +28,9 @@ PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'x11-gl | |||
28 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland opengl', 'wayland-gl wayland-gles2', '', d)} \ | 28 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland opengl', 'wayland-gl wayland-gles2', '', d)} \ |
29 | drm-gl drm-gles2" | 29 | drm-gl drm-gles2" |
30 | 30 | ||
31 | # Enable C++11 features | ||
32 | CXXFLAGS += "-std=c++11" | ||
33 | |||
31 | PACKAGECONFIG[x11-gl] = ",,virtual/libgl virtual/libx11" | 34 | PACKAGECONFIG[x11-gl] = ",,virtual/libgl virtual/libx11" |
32 | PACKAGECONFIG[x11-gles2] = ",,virtual/libgles2 virtual/libx11" | 35 | PACKAGECONFIG[x11-gles2] = ",,virtual/libgles2 virtual/libx11" |
33 | PACKAGECONFIG[drm-gl] = ",,virtual/libgl libdrm" | 36 | PACKAGECONFIG[drm-gl] = ",,virtual/libgl libdrm" |