diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-05-22 18:38:19 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-05-23 15:04:38 -0700 |
commit | a1d047bae79fb2a747b204b941aa5af5ada28d6e (patch) | |
tree | a4eecc837bca15fd057e917547f2aa64bf27145a /meta-oe | |
parent | 790b4f56ff8edc36c4f36c6c5cb2d782c17539f2 (diff) | |
download | meta-openembedded-a1d047bae79fb2a747b204b941aa5af5ada28d6e.tar.gz |
uml-utilities: Fix references to TMPDIR
Pass CFLAGS from environment
Fixes
WARNING: uml-utilities-20040406-r1 do_package_qa: QA Issue: File /usr/lib/uml/.debug/port-helper in package uml-utilities-dbg contains reference to TMPDIR
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
3 files changed, 158 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/0001-cow.c-Replace-stat64-with-stat.patch b/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/0001-cow.c-Replace-stat64-with-stat.patch new file mode 100644 index 000000000..348d7ce10 --- /dev/null +++ b/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/0001-cow.c-Replace-stat64-with-stat.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From c4f85268da6c30b0aec3d9a0e951b2088887cff4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 22 May 2023 18:35:37 -0700 | ||
4 | Subject: [PATCH] cow.c: Replace stat64 with stat | ||
5 | |||
6 | LFS64 is deprecated in latest musl and this fails to build | ||
7 | therefore switch to using stat API which is same as stat64 these days | ||
8 | |||
9 | Upstream-Status: Inappropriate [No upstream] | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | moo/cow.c | 4 ++-- | ||
13 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
14 | |||
15 | --- a/moo/cow.c | ||
16 | +++ b/moo/cow.c | ||
17 | @@ -161,7 +161,7 @@ int write_cow_header(char *cow_file, int | ||
18 | int sectorsize, int alignment, long long *size) | ||
19 | { | ||
20 | struct cow_header_v3 *header; | ||
21 | - struct stat64 buf; | ||
22 | + struct stat buf; | ||
23 | int err; | ||
24 | |||
25 | err = cow_seek_file(fd, 0); | ||
26 | @@ -192,7 +192,7 @@ int write_cow_header(char *cow_file, int | ||
27 | backing_file)) | ||
28 | goto out_free; | ||
29 | |||
30 | - err = stat64(header->backing_file, &buf); | ||
31 | + err = stat(header->backing_file, &buf); | ||
32 | if(err < 0){ | ||
33 | cow_printf("Stat of backing file '%s' failed, errno = %d\n", | ||
34 | header->backing_file, errno); | ||
diff --git a/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/0001-makefiles-Append-to-CFLAGS-instead-of-re-assign.patch b/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/0001-makefiles-Append-to-CFLAGS-instead-of-re-assign.patch new file mode 100644 index 000000000..1962e84c7 --- /dev/null +++ b/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/0001-makefiles-Append-to-CFLAGS-instead-of-re-assign.patch | |||
@@ -0,0 +1,122 @@ | |||
1 | From ac72fffe639d564f59ec1e1eafde83980acef1b5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 23 May 2023 14:40:31 -0700 | ||
4 | Subject: [PATCH] makefiles: Append to CFLAGS instead of re-assign | ||
5 | |||
6 | This helps in inserting yocto provided CFLAGS from build environment | ||
7 | |||
8 | Upstream-Status: Inappropriate [No upstream] | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | jailtest/Makefile | 2 +- | ||
12 | mconsole/Makefile | 2 +- | ||
13 | moo/Makefile | 2 +- | ||
14 | port-helper/Makefile | 2 +- | ||
15 | tunctl/Makefile | 2 +- | ||
16 | uml_net/Makefile | 2 +- | ||
17 | uml_router/Makefile | 2 +- | ||
18 | watchdog/Makefile | 2 +- | ||
19 | 8 files changed, 8 insertions(+), 8 deletions(-) | ||
20 | |||
21 | diff --git a/jailtest/Makefile b/jailtest/Makefile | ||
22 | index 610ca1a..025fca9 100644 | ||
23 | --- a/jailtest/Makefile | ||
24 | +++ b/jailtest/Makefile | ||
25 | @@ -1,6 +1,6 @@ | ||
26 | OBJS = jailtest.o | ||
27 | BIN = jailtest | ||
28 | -CFLAGS = -g -Wall | ||
29 | +CFLAGS += -g -Wall | ||
30 | |||
31 | BIN_DIR ?= /usr/bin | ||
32 | |||
33 | diff --git a/mconsole/Makefile b/mconsole/Makefile | ||
34 | index 9818d8a..74a2560 100644 | ||
35 | --- a/mconsole/Makefile | ||
36 | +++ b/mconsole/Makefile | ||
37 | @@ -1,6 +1,6 @@ | ||
38 | BIN = uml_mconsole | ||
39 | OBJS = $(BIN).o | ||
40 | -CFLAGS = -g -Wall | ||
41 | +CFLAGS += -g -Wall | ||
42 | |||
43 | BIN_DIR ?= /usr/bin | ||
44 | |||
45 | diff --git a/moo/Makefile b/moo/Makefile | ||
46 | index 6cdb591..60d300d 100644 | ||
47 | --- a/moo/Makefile | ||
48 | +++ b/moo/Makefile | ||
49 | @@ -3,7 +3,7 @@ BIN = uml_moo uml_mkcow | ||
50 | uml_moo_OBJS = uml_moo.o cow.o | ||
51 | uml_mkcow_OBJS = uml_mkcow.o cow.o | ||
52 | |||
53 | -CFLAGS = -g -Wall -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE | ||
54 | +CFLAGS += -g -Wall -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE | ||
55 | |||
56 | BIN_DIR ?= /usr/bin | ||
57 | |||
58 | diff --git a/port-helper/Makefile b/port-helper/Makefile | ||
59 | index 8e33bdf..8b695f3 100644 | ||
60 | --- a/port-helper/Makefile | ||
61 | +++ b/port-helper/Makefile | ||
62 | @@ -1,6 +1,6 @@ | ||
63 | OBJS = port-helper.o | ||
64 | BIN = port-helper | ||
65 | -CFLAGS = -g -Wall | ||
66 | +CFLAGS += -g -Wall | ||
67 | |||
68 | LIB_DIR ?= /usr/lib/uml | ||
69 | |||
70 | diff --git a/tunctl/Makefile b/tunctl/Makefile | ||
71 | index 743bfea..a39ad2b 100644 | ||
72 | --- a/tunctl/Makefile | ||
73 | +++ b/tunctl/Makefile | ||
74 | @@ -1,6 +1,6 @@ | ||
75 | OBJS = tunctl.o | ||
76 | BIN = tunctl | ||
77 | -CFLAGS = -g -Wall | ||
78 | +CFLAGS += -g -Wall | ||
79 | |||
80 | BIN_DIR ?= /usr/bin | ||
81 | |||
82 | diff --git a/uml_net/Makefile b/uml_net/Makefile | ||
83 | index 36efec6..2e1ad0e 100644 | ||
84 | --- a/uml_net/Makefile | ||
85 | +++ b/uml_net/Makefile | ||
86 | @@ -1,7 +1,7 @@ | ||
87 | TUNTAP = $(shell [ -e /usr/include/linux/if_tun.h ] && echo -DTUNTAP) | ||
88 | |||
89 | BIN = uml_net | ||
90 | -CFLAGS = -g -Wall $(TUNTAP) | ||
91 | +CFLAGS += -g -Wall $(TUNTAP) | ||
92 | |||
93 | BIN_DIR ?= /usr/bin | ||
94 | |||
95 | diff --git a/uml_router/Makefile b/uml_router/Makefile | ||
96 | index b7b5401..e399ea5 100644 | ||
97 | --- a/uml_router/Makefile | ||
98 | +++ b/uml_router/Makefile | ||
99 | @@ -2,7 +2,7 @@ TUNTAP = $(shell [ -e /usr/include/linux/if_tun.h ] && echo -DTUNTAP) | ||
100 | |||
101 | OBJS = hash.o port.o uml_switch.o | ||
102 | BIN = uml_switch | ||
103 | -CFLAGS = -g -Wall $(TUNTAP) | ||
104 | +CFLAGS += -g -Wall $(TUNTAP) | ||
105 | |||
106 | BIN_DIR ?= /usr/bin | ||
107 | |||
108 | diff --git a/watchdog/Makefile b/watchdog/Makefile | ||
109 | index c26fd9f..5178cc6 100644 | ||
110 | --- a/watchdog/Makefile | ||
111 | +++ b/watchdog/Makefile | ||
112 | @@ -1,6 +1,6 @@ | ||
113 | BIN = uml_watchdog | ||
114 | OBJS = $(BIN).o | ||
115 | -CFLAGS = -g -Wall | ||
116 | +CFLAGS += -g -Wall | ||
117 | |||
118 | BIN_DIR ?= /usr/bin | ||
119 | |||
120 | -- | ||
121 | 2.40.1 | ||
122 | |||
diff --git a/meta-oe/recipes-extended/uml-utilities/uml-utilities_20040406.bb b/meta-oe/recipes-extended/uml-utilities/uml-utilities_20040406.bb index 35ae5f777..54bc1b21f 100644 --- a/meta-oe/recipes-extended/uml-utilities/uml-utilities_20040406.bb +++ b/meta-oe/recipes-extended/uml-utilities/uml-utilities_20040406.bb | |||
@@ -8,6 +8,8 @@ SRC_URI = "http://downloads.sourceforge.net/project/user-mode-linux/tools/1/uml_ | |||
8 | file://unstrip.patch \ | 8 | file://unstrip.patch \ |
9 | file://0001-include-required-system-header-files-for-fd_set-and-.patch \ | 9 | file://0001-include-required-system-header-files-for-fd_set-and-.patch \ |
10 | file://0001-Add-missing-standard-headers-for-str-and-exit-APIs.patch \ | 10 | file://0001-Add-missing-standard-headers-for-str-and-exit-APIs.patch \ |
11 | file://0001-cow.c-Replace-stat64-with-stat.patch \ | ||
12 | file://0001-makefiles-Append-to-CFLAGS-instead-of-re-assign.patch \ | ||
11 | " | 13 | " |
12 | SRC_URI[md5sum] = "2c1ccd9efacbfb39e42d482b89b2550a" | 14 | SRC_URI[md5sum] = "2c1ccd9efacbfb39e42d482b89b2550a" |
13 | SRC_URI[sha256sum] = "4f179b1db021ef15ac7e9b2eed57c525db127a754c574f591c367460cded9f41" | 15 | SRC_URI[sha256sum] = "4f179b1db021ef15ac7e9b2eed57c525db127a754c574f591c367460cded9f41" |