summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorRandy MacLeod <randy.macleod@windriver.com>2016-09-07 22:25:34 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-15 10:22:47 +0200
commita0fdd7f1cae62241946e31099540afe9da321cbd (patch)
treefe25b78941673ae14855a4aef0c4fdc14bbbd50b /meta-oe
parentee23e9d9792a0a923294144a5f5b54a67b74eb84 (diff)
downloadmeta-openembedded-a0fdd7f1cae62241946e31099540afe9da321cbd.tar.gz
zile: uprev from 2.4.9 to 2.4.11 and add acl support
Add support for the acl DISTRO_FEATURE using PACKAGECONFIG Inherit pkgconfig since zile-2.4.11 uses that to find bdwgc (aka libgc). Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/zile/zile_2.4.11.bb20
-rw-r--r--meta-oe/recipes-support/zile/zile_2.4.9.bb15
2 files changed, 20 insertions, 15 deletions
diff --git a/meta-oe/recipes-support/zile/zile_2.4.11.bb b/meta-oe/recipes-support/zile/zile_2.4.11.bb
new file mode 100644
index 000000000..b3f191861
--- /dev/null
+++ b/meta-oe/recipes-support/zile/zile_2.4.11.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Zile is lossy Emacs"
2HOMEPAGE = "http://zile.sourceforge.net/"
3DEPENDS = "ncurses bdwgc"
4
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7
8SRC_URI = "http://ftp.gnu.org/gnu/zile/${BP}.tar.gz \
9 file://remove-help2man.patch \
10"
11
12SRC_URI[md5sum] = "7a460ccec64e3bec2835697b2eae533c"
13SRC_URI[sha256sum] = "1fd27bbddc61491b1fbb29a345d0d344734aa9e80cfa07b02892eedf831fa9cc"
14
15inherit autotools pkgconfig
16
17PACKAGECONFIG ??= ""
18PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"
19
20PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
diff --git a/meta-oe/recipes-support/zile/zile_2.4.9.bb b/meta-oe/recipes-support/zile/zile_2.4.9.bb
deleted file mode 100644
index 2551a80e9..000000000
--- a/meta-oe/recipes-support/zile/zile_2.4.9.bb
+++ /dev/null
@@ -1,15 +0,0 @@
1SUMMARY = "Zile is lossy Emacs"
2HOMEPAGE = "http://zile.sourceforge.net/"
3DEPENDS = "ncurses bdwgc"
4
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7
8SRC_URI = "http://ftp.gnu.org/gnu/zile/${BP}.tar.gz \
9 file://remove-help2man.patch \
10"
11
12SRC_URI[md5sum] = "84a0af58fb4fbe3af16bde2ef2b8f5ae"
13SRC_URI[sha256sum] = "c71959c7aca02ac66be526ecccbc7954fb0ea7591ed3c13311a95e8f040b0049"
14
15inherit autotools