diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-11-11 21:11:39 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-11-13 07:15:16 -0800 |
commit | 88fe09f7530ce6a372dba2306181b56e59a9017f (patch) | |
tree | b7d7b11625bab9e0f3c29fd684e93b3c888d2c6a /meta-oe | |
parent | 13830393555adbb70ccec18bea177131ff405edc (diff) | |
download | meta-openembedded-88fe09f7530ce6a372dba2306181b56e59a9017f.tar.gz |
pidgin-sipe: Fix build when time_t is 64bit
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-support/pidgin/pidgin-sipe/0001-sipe-consider-64bit-time_t-when-printing.patch | 31 | ||||
-rw-r--r-- | meta-oe/recipes-support/pidgin/pidgin-sipe_1.25.0.bb | 1 |
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/pidgin/pidgin-sipe/0001-sipe-consider-64bit-time_t-when-printing.patch b/meta-oe/recipes-support/pidgin/pidgin-sipe/0001-sipe-consider-64bit-time_t-when-printing.patch new file mode 100644 index 000000000..e7a72953d --- /dev/null +++ b/meta-oe/recipes-support/pidgin/pidgin-sipe/0001-sipe-consider-64bit-time_t-when-printing.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From ae6fa551907006c612cca98b87f339d4d6f45e25 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 11 Nov 2019 21:08:11 -0800 | ||
4 | Subject: [PATCH] sipe: consider 64bit time_t when printing | ||
5 | |||
6 | This helps printing 64bit time_t on 32bit architectures | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | src/core/sipe-utils.c | 4 ++-- | ||
12 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/src/core/sipe-utils.c b/src/core/sipe-utils.c | ||
15 | index 12ff8d6..d3d4071 100644 | ||
16 | --- a/src/core/sipe-utils.c | ||
17 | +++ b/src/core/sipe-utils.c | ||
18 | @@ -414,8 +414,8 @@ sipe_utils_time_to_str(time_t timestamp) | ||
19 | if (result) | ||
20 | return(result); | ||
21 | |||
22 | - SIPE_DEBUG_ERROR("sipe_utils_time_to_str: failed to convert %lu to ISO8601 string", | ||
23 | - timestamp); | ||
24 | + SIPE_DEBUG_ERROR("sipe_utils_time_to_str: failed to convert %lld to ISO8601 string", | ||
25 | + (long long int)timestamp); | ||
26 | return(g_strdup("")); | ||
27 | } | ||
28 | |||
29 | -- | ||
30 | 2.24.0 | ||
31 | |||
diff --git a/meta-oe/recipes-support/pidgin/pidgin-sipe_1.25.0.bb b/meta-oe/recipes-support/pidgin/pidgin-sipe_1.25.0.bb index 1d739874b..7dc63164e 100644 --- a/meta-oe/recipes-support/pidgin/pidgin-sipe_1.25.0.bb +++ b/meta-oe/recipes-support/pidgin/pidgin-sipe_1.25.0.bb | |||
@@ -8,6 +8,7 @@ DEPENDS = "pidgin gmime intltool-native glib-2.0-native" | |||
8 | inherit autotools gettext pkgconfig | 8 | inherit autotools gettext pkgconfig |
9 | 9 | ||
10 | SRC_URI = "${SOURCEFORGE_MIRROR}/sipe/pidgin-sipe-${PV}.tar.xz \ | 10 | SRC_URI = "${SOURCEFORGE_MIRROR}/sipe/pidgin-sipe-${PV}.tar.xz \ |
11 | file://0001-sipe-consider-64bit-time_t-when-printing.patch \ | ||
11 | " | 12 | " |
12 | 13 | ||
13 | SRC_URI[md5sum] = "0e742f021dc8c3f17435aea05c3e0314" | 14 | SRC_URI[md5sum] = "0e742f021dc8c3f17435aea05c3e0314" |