diff options
author | mcrapet <Matthieu.Crapet@ingenico.com> | 2015-06-03 11:12:36 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-06-08 14:15:24 +0200 |
commit | 7db802aa7f1440e78c179984cf621bdeea7d6264 (patch) | |
tree | 00b33d66841ab9f1c888e4926ceb70af39255414 /meta-oe | |
parent | 4bcddcaccb5950ec0208e2a25eb05c7016e25db4 (diff) | |
download | meta-openembedded-7db802aa7f1440e78c179984cf621bdeea7d6264.tar.gz |
cgdb: update to 0.6.8
Changes:
- add missing build dependency to flex-native
- GDB is a runtime dependency, set it so
- use CACHED_CONFIGUREVARS to drop patch
- use ${BP}
- add missing DESCRIPTION
- no help2man build dependency (cgdb.1 man page is not generated)
Cc: Ben Shelton <ben.shelton@ni.com>
Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-devtools/cgdb/cgdb/configfix.patch | 40 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/cgdb/cgdb/remove-help2man.patch | 47 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/cgdb/cgdb_0.6.7.bb | 16 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/cgdb/cgdb_0.6.8.bb | 21 |
4 files changed, 68 insertions, 56 deletions
diff --git a/meta-oe/recipes-devtools/cgdb/cgdb/configfix.patch b/meta-oe/recipes-devtools/cgdb/cgdb/configfix.patch deleted file mode 100644 index 25b13862b..000000000 --- a/meta-oe/recipes-devtools/cgdb/cgdb/configfix.patch +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | diff -rupN cgdb-0.6.7-OLD/configure.in cgdb-0.6.7/configure.in | ||
2 | --- cgdb-0.6.7-OLD/configure.in 2013-01-14 05:31:53.000000000 -0600 | ||
3 | +++ cgdb-0.6.7/configure.in 2014-05-08 13:18:13.864632180 -0500 | ||
4 | @@ -65,8 +65,9 @@ AC_CHECK_HEADERS([getopt.h], | ||
5 | [AC_DEFINE(HAVE_GETOPT_H, 1, have getopt_long)]) | ||
6 | |||
7 | dnl determine if /dev/ptmx is available for pseudo terminals | ||
8 | -AC_CHECK_FILE([/dev/ptmx], | ||
9 | - [AC_DEFINE(HAVE_DEV_PTMX, 1, have /dev/ptmx)]) | ||
10 | +dnl AC_CHECK_FILE([/dev/ptmx], | ||
11 | +dnl [AC_DEFINE(HAVE_DEV_PTMX, 1, have /dev/ptmx)]) | ||
12 | +AC_DEFINE(HAVE_DEV_PTMX, 1, have /dev/ptmx) | ||
13 | |||
14 | dnl Checks for typedefs, structures, and compiler characteristics. | ||
15 | AC_C_CONST | ||
16 | @@ -167,15 +168,15 @@ fi | ||
17 | |||
18 | dnl Make sure there is a version of readline that CGDB supports. | ||
19 | dnl Simply putting 5.1* -> 5.9* just to take into accout future versions. | ||
20 | -RL_LIB_READLINE_VERSION | ||
21 | -case "$ac_cv_rl_version" in | ||
22 | -5.1*|5.2*|5.3*|5.4*|5.5*|5.6*|5.7*|5.8*|5.9*|6*|7*|8*|9*) ;; | ||
23 | -*) AC_MSG_ERROR([CGDB requires GNU readline 5.1 or greater to link. | ||
24 | - If you used --with-readline instead of using the system readline library, | ||
25 | - make sure to set the correct readline library on the linker search path | ||
26 | - via LD_LIBRARY_PATH or some other facility.]) | ||
27 | - ;; | ||
28 | -esac | ||
29 | +dnl RL_LIB_READLINE_VERSION | ||
30 | +dnl case "$ac_cv_rl_version" in | ||
31 | +dnl 5.1*|5.2*|5.3*|5.4*|5.5*|5.6*|5.7*|5.8*|5.9*|6*|7*|8*|9*) ;; | ||
32 | +dnl *) AC_MSG_ERROR([CGDB requires GNU readline 5.1 or greater to link. | ||
33 | +dnl If you used --with-readline instead of using the system readline library, | ||
34 | +dnl make sure to set the correct readline library on the linker search path | ||
35 | +dnl via LD_LIBRARY_PATH or some other facility.]) | ||
36 | +dnl ;; | ||
37 | +dnl esac | ||
38 | |||
39 | dnl This will DEFINE the readline headers. | ||
40 | RL_LIB_READLINE_INCLUDES | ||
diff --git a/meta-oe/recipes-devtools/cgdb/cgdb/remove-help2man.patch b/meta-oe/recipes-devtools/cgdb/cgdb/remove-help2man.patch new file mode 100644 index 000000000..4358629b7 --- /dev/null +++ b/meta-oe/recipes-devtools/cgdb/cgdb/remove-help2man.patch | |||
@@ -0,0 +1,47 @@ | |||
1 | Disable building manpages so that make install doesn't fail due to lack of help2man | ||
2 | |||
3 | Upstream-Status: Inappropriate [config] | ||
4 | |||
5 | Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com> | ||
6 | --- | ||
7 | configure.ac | 3 --- | ||
8 | doc/Makefile.am | 5 ----- | ||
9 | 2 files changed, 8 deletions(-) | ||
10 | |||
11 | diff --git a/configure.ac b/configure.ac | ||
12 | index ee7eca0..1f0d924 100644 | ||
13 | --- a/configure.ac | ||
14 | +++ b/configure.ac | ||
15 | @@ -134,9 +134,6 @@ dnl check that the required tools are available to generate documentation | ||
16 | if test "$HAS_MAKEINFO" != "yes" ; then | ||
17 | AC_MSG_ERROR([Please install makeinfo before installing]) | ||
18 | fi | ||
19 | -if test "$HAS_HELP2MAN" != "yes" ; then | ||
20 | - AC_MSG_ERROR([Please install help2man]) | ||
21 | -fi | ||
22 | |||
23 | dnl Checking for log10 function in math - I would like to remove this | ||
24 | AC_CHECK_LIB(m, log10) | ||
25 | diff --git a/doc/Makefile.am b/doc/Makefile.am | ||
26 | index 60662f6..0ae0013 100644 | ||
27 | --- a/doc/Makefile.am | ||
28 | +++ b/doc/Makefile.am | ||
29 | @@ -1,15 +1,10 @@ | ||
30 | info_TEXINFOS = cgdb.texi | ||
31 | cgdb_TEXINFOS = gpl.texi | ||
32 | |||
33 | -dist_man_MANS = cgdb.1 | ||
34 | EXTRA_DIST = cgdb.txt | ||
35 | |||
36 | dist_pkgdata_DATA = cgdb.txt | ||
37 | |||
38 | -# generate the man page using help2man. | ||
39 | -cgdb.1: | ||
40 | - help2man --output=$(top_srcdir)/doc/cgdb.1 $(top_builddir)/cgdb/cgdb$(EXEEXT) | ||
41 | - | ||
42 | cgdb.txt: cgdb.texi $(srcdir)/version.texi $(cgdb_TEXINFOS) | ||
43 | TEXTS = cgdb.txt | ||
44 | text-am: $(TEXTS) | ||
45 | -- | ||
46 | 1.9.1 | ||
47 | |||
diff --git a/meta-oe/recipes-devtools/cgdb/cgdb_0.6.7.bb b/meta-oe/recipes-devtools/cgdb/cgdb_0.6.7.bb deleted file mode 100644 index 26b2782f0..000000000 --- a/meta-oe/recipes-devtools/cgdb/cgdb_0.6.7.bb +++ /dev/null | |||
@@ -1,16 +0,0 @@ | |||
1 | SUMMARY = "curses-based interface to gdb" | ||
2 | HOMEPAGE = "http://cgdb.github.io/" | ||
3 | SECTION = "devel" | ||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | ||
6 | DEPENDS = "readline ncurses gdb" | ||
7 | |||
8 | SRC_URI = "http://cgdb.me/files/cgdb-${PV}.tar.gz \ | ||
9 | file://configfix.patch" | ||
10 | SRC_URI[md5sum] = "e2d9a973d2683faf8130a82703bf6a31" | ||
11 | SRC_URI[sha256sum] = "074ed31d1e827a04574add8c27d391447d75313e85ff938005d8ec939499fda9" | ||
12 | |||
13 | EXTRA_OECONF = "--with-readline=${STAGING_LIBDIR} --with-ncurses=${STAGING_LIBDIR}" | ||
14 | |||
15 | inherit autotools | ||
16 | |||
diff --git a/meta-oe/recipes-devtools/cgdb/cgdb_0.6.8.bb b/meta-oe/recipes-devtools/cgdb/cgdb_0.6.8.bb new file mode 100644 index 000000000..74019fb62 --- /dev/null +++ b/meta-oe/recipes-devtools/cgdb/cgdb_0.6.8.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | SUMMARY = "curses-based interface to GDB" | ||
2 | DESCRIPTION = "cgdb is a lightweight curses (terminal-based) interface to the GNU Debugger (GDB)." | ||
3 | HOMEPAGE = "http://cgdb.github.io/" | ||
4 | SECTION = "devel" | ||
5 | LICENSE = "GPLv2" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | ||
7 | |||
8 | DEPENDS = "flex-native readline ncurses" | ||
9 | |||
10 | inherit autotools | ||
11 | |||
12 | SRC_URI = "http://cgdb.me/files/${BP}.tar.gz \ | ||
13 | file://remove-help2man.patch" | ||
14 | SRC_URI[md5sum] = "7bd38c79bf4d794d239928fef401fca3" | ||
15 | SRC_URI[sha256sum] = "be203e29be295097439ab67efe3dc8261f742c55ff3647718d67d52891f4cf41" | ||
16 | |||
17 | CACHED_CONFIGUREVARS = "ac_cv_file__dev_ptmx=yes ac_cv_rl_version=6.2" | ||
18 | EXTRA_OECONF = "--with-readline=${STAGING_LIBDIR} \ | ||
19 | --with-ncurses=${STAGING_LIBDIR}" | ||
20 | |||
21 | RDEPENDS_${PN} = "gdb" | ||