diff options
author | Khem Raj <raj.khem@gmail.com> | 2013-05-10 18:07:17 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-05-16 11:04:34 +0200 |
commit | 6edc36d790dd905cb74fa46d061e63a8c590bdb3 (patch) | |
tree | 0a450c4c01f7ed3a8f3e0868550d932b849a0776 /meta-oe | |
parent | a289eb906ee9d6c8c5a5abe87fe7095880449db3 (diff) | |
download | meta-openembedded-6edc36d790dd905cb74fa46d061e63a8c590bdb3.tar.gz |
LuaJIT: Upgrade 2.0.0 -> 2.0.1
Fix stripping related warnings
Drop foldarith_for_spe patch not neded anymore
QA Error about elocations in .text are still there like 2.0.0
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-devtools/luajit/luajit-2.0.0/disable_lj_vm_foldarith_for_spe.patch | 13 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/luajit/luajit/0001-Do-not-strip-automatically-this-leaves-the-stripping.patch | 33 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/luajit/luajit_2.0.1.bb (renamed from meta-oe/recipes-devtools/luajit/luajit_2.0.0.bb) | 13 |
3 files changed, 39 insertions, 20 deletions
diff --git a/meta-oe/recipes-devtools/luajit/luajit-2.0.0/disable_lj_vm_foldarith_for_spe.patch b/meta-oe/recipes-devtools/luajit/luajit-2.0.0/disable_lj_vm_foldarith_for_spe.patch deleted file mode 100644 index c96fc77c7..000000000 --- a/meta-oe/recipes-devtools/luajit/luajit-2.0.0/disable_lj_vm_foldarith_for_spe.patch +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | Index: LuaJIT-2.0.0/src/lj_vmmath.c | ||
2 | =================================================================== | ||
3 | --- LuaJIT-2.0.0.orig/src/lj_vmmath.c 2012-11-08 02:10:00.000000000 -0800 | ||
4 | +++ LuaJIT-2.0.0/src/lj_vmmath.c 2012-11-19 22:15:28.613527136 -0800 | ||
5 | @@ -22,7 +22,7 @@ | ||
6 | LJ_FUNCA double lj_vm_tanh(double x) { return tanh(x); } | ||
7 | #endif | ||
8 | |||
9 | -#if !LJ_TARGET_X86ORX64 | ||
10 | +#if !(LJ_TARGET_X86ORX64 || LJ_TARGET_PPCSPE) | ||
11 | double lj_vm_foldarith(double x, double y, int op) | ||
12 | { | ||
13 | switch (op) { | ||
diff --git a/meta-oe/recipes-devtools/luajit/luajit/0001-Do-not-strip-automatically-this-leaves-the-stripping.patch b/meta-oe/recipes-devtools/luajit/luajit/0001-Do-not-strip-automatically-this-leaves-the-stripping.patch new file mode 100644 index 000000000..f123b3f55 --- /dev/null +++ b/meta-oe/recipes-devtools/luajit/luajit/0001-Do-not-strip-automatically-this-leaves-the-stripping.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From 528009f5ca0685c95ef27f6c8957160499c0576a Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 10 May 2013 10:42:45 -0700 | ||
4 | Subject: [PATCH] Do not strip automatically, this leaves the stripping | ||
5 | busines to OE | ||
6 | |||
7 | Upstream-Status: Inappropriate [OE-Specific] | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | src/Makefile | 2 -- | ||
12 | 1 file changed, 2 deletions(-) | ||
13 | |||
14 | diff --git a/src/Makefile b/src/Makefile | ||
15 | index 278324a..5ecd6d5 100644 | ||
16 | --- a/src/Makefile | ||
17 | +++ b/src/Makefile | ||
18 | @@ -665,12 +665,10 @@ $(LUAJIT_A): $(LJVMCORE_O) | ||
19 | $(LUAJIT_SO): $(LJVMCORE_O) | ||
20 | $(E) "DYNLINK $@" | ||
21 | $(Q)$(TARGET_LD) $(TARGET_ASHLDFLAGS) -o $@ $(LJVMCORE_DYNO) $(TARGET_ALIBS) | ||
22 | - $(Q)$(TARGET_STRIP) $@ | ||
23 | |||
24 | $(LUAJIT_T): $(TARGET_O) $(LUAJIT_O) $(TARGET_DEP) | ||
25 | $(E) "LINK $@" | ||
26 | $(Q)$(TARGET_LD) $(TARGET_ALDFLAGS) -o $@ $(LUAJIT_O) $(TARGET_O) $(TARGET_ALIBS) | ||
27 | - $(Q)$(TARGET_STRIP) $@ | ||
28 | $(E) "OK Successfully built LuaJIT" | ||
29 | |||
30 | ############################################################################## | ||
31 | -- | ||
32 | 1.7.9.5 | ||
33 | |||
diff --git a/meta-oe/recipes-devtools/luajit/luajit_2.0.0.bb b/meta-oe/recipes-devtools/luajit/luajit_2.0.1.bb index 38783869c..99a2ca6fb 100644 --- a/meta-oe/recipes-devtools/luajit/luajit_2.0.0.bb +++ b/meta-oe/recipes-devtools/luajit/luajit_2.0.1.bb | |||
@@ -1,15 +1,14 @@ | |||
1 | DESCRIPTION = " a Just-In-Time Compiler for Lua" | 1 | DESCRIPTION = " a Just-In-Time Compiler for Lua" |
2 | LICENSE = "MIT" | 2 | LICENSE = "MIT" |
3 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=9511885992e4900014e3b13ca6372b7d" | 3 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=1793ef52a5d577794cd886a501a7f861" |
4 | HOMEPAGE = "http://luajit.org" | 4 | HOMEPAGE = "http://luajit.org" |
5 | 5 | ||
6 | DEPENDS += "lua5.1" | 6 | DEPENDS += "lua5.1" |
7 | PR = "r2" | ||
8 | SRC_URI = "http://luajit.org/download/LuaJIT-${PV}.tar.gz \ | 7 | SRC_URI = "http://luajit.org/download/LuaJIT-${PV}.tar.gz \ |
9 | file://disable_lj_vm_foldarith_for_spe.patch \ | 8 | file://0001-Do-not-strip-automatically-this-leaves-the-stripping.patch \ |
10 | " | 9 | " |
11 | SRC_URI[md5sum] = "97a2b87cc0490784f54b64cfb3b8f5ad" | 10 | SRC_URI[md5sum] = "85e406e8829602988eb1233a82e29f1f" |
12 | SRC_URI[sha256sum] = "deaed645c4a093c5fb250c30c9933c9131ee05c94b13262d58f6e0b60b338c15" | 11 | SRC_URI[sha256sum] = "2371cceb53453d8a7b36451e6a0ccdb66236924545d6042ddd4c34e9668990c0" |
13 | 12 | ||
14 | S = "${WORKDIR}/LuaJIT-${PV}" | 13 | S = "${WORKDIR}/LuaJIT-${PV}" |
15 | 14 | ||
@@ -43,7 +42,7 @@ do_install () { | |||
43 | PACKAGES += 'luajit-common' | 42 | PACKAGES += 'luajit-common' |
44 | 43 | ||
45 | FILES_${PN} += "${libdir}/libluajit-5.1.so.2 \ | 44 | FILES_${PN} += "${libdir}/libluajit-5.1.so.2 \ |
46 | ${libdir}/libluajit-5.1.so.2.0.0 \ | 45 | ${libdir}/libluajit-5.1.so.${PV} \ |
47 | " | 46 | " |
48 | FILES_${PN}-dev += "${libdir}/libluajit-5.1.a \ | 47 | FILES_${PN}-dev += "${libdir}/libluajit-5.1.a \ |
49 | ${libdir}/libluajit-5.1.so \ | 48 | ${libdir}/libluajit-5.1.so \ |