summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorZheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>2020-05-19 23:27:11 +0800
committerKhem Raj <raj.khem@gmail.com>2020-05-19 07:37:22 -0700
commit5a825b5ce781aef64f347a6c9a76307406a4f295 (patch)
tree9b94663d5a3603c9eff77477f4d58613f0280c43 /meta-oe
parentc8d1042a9892c38cefab8c6f4a9cce6dcad19db4 (diff)
downloadmeta-openembedded-5a825b5ce781aef64f347a6c9a76307406a4f295.tar.gz
dstat: Fix runtime error that depend python.
Make dstat to depend python3. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/dstat/dstat/0001-change-dstat-to-python3.patch89
-rw-r--r--meta-oe/recipes-support/dstat/dstat_0.7.4.bb4
2 files changed, 92 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/dstat/dstat/0001-change-dstat-to-python3.patch b/meta-oe/recipes-support/dstat/dstat/0001-change-dstat-to-python3.patch
new file mode 100644
index 000000000..06a8498f3
--- /dev/null
+++ b/meta-oe/recipes-support/dstat/dstat/0001-change-dstat-to-python3.patch
@@ -0,0 +1,89 @@
1From ce0528cb48666843fed2ad10ece5ecb0ac0b8cf8 Mon Sep 17 00:00:00 2001
2From: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
3Date: Fri, 15 May 2020 12:38:49 +0900
4Subject: [PATCH] change dstat to python3.
5
6Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
7---
8 dstat | 2 +-
9 examples/curstest | 2 +-
10 examples/devtest.py | 2 +-
11 examples/mmpipe.py | 2 +-
12 examples/mstat.py | 2 +-
13 examples/read.py | 2 +-
14 examples/tdbtest | 2 +-
15 7 files changed, 7 insertions(+), 7 deletions(-)
16
17diff --git a/dstat b/dstat
18index 9359965..f250f06 100755
19--- a/dstat
20+++ b/dstat
21@@ -1,4 +1,4 @@
22-#!/usr/bin/env python
23+#!/usr/bin/env python3
24
25 ### This program is free software; you can redistribute it and/or
26 ### modify it under the terms of the GNU General Public License
27diff --git a/examples/curstest b/examples/curstest
28index afc4e70..d720cca 100755
29--- a/examples/curstest
30+++ b/examples/curstest
31@@ -1,4 +1,4 @@
32-#!/usr/bin/python
33+#!/usr/bin/python3
34 import curses, sys
35
36 #c = curses.wrapper(s)
37diff --git a/examples/devtest.py b/examples/devtest.py
38index 0e9e969..e53babd 100755
39--- a/examples/devtest.py
40+++ b/examples/devtest.py
41@@ -1,4 +1,4 @@
42-#!/usr/bin/python
43+#!/usr/bin/python3
44
45 import sys
46 sys.path.insert(0, '/usr/share/dstat/')
47diff --git a/examples/mmpipe.py b/examples/mmpipe.py
48index 5c93567..f91515f 100755
49--- a/examples/mmpipe.py
50+++ b/examples/mmpipe.py
51@@ -1,4 +1,4 @@
52-#!/usr/bin/python
53+#!/usr/bin/python3
54 import select, sys, os
55
56 def readpipe(file, tmout = 0.001):
57diff --git a/examples/mstat.py b/examples/mstat.py
58index abf4d07..ac157e4 100755
59--- a/examples/mstat.py
60+++ b/examples/mstat.py
61@@ -1,4 +1,4 @@
62-#!/usr/bin/python
63+#!/usr/bin/python3
64
65 ### Example2: simple sub-second monitor (ministat)
66
67diff --git a/examples/read.py b/examples/read.py
68index 556b7ae..a925109 100755
69--- a/examples/read.py
70+++ b/examples/read.py
71@@ -1,4 +1,4 @@
72-#!/usr/bin/python
73+#!/usr/bin/python3
74
75 ### Example 1: Direct accessing stats
76 ### This is a quick example showing how you can access dstat data
77diff --git a/examples/tdbtest b/examples/tdbtest
78index 528a8ea..ae7fef9 100755
79--- a/examples/tdbtest
80+++ b/examples/tdbtest
81@@ -1,4 +1,4 @@
82-#!/usr/bin/python
83+#!/usr/bin/python3
84 import sys, tdb
85
86 db = tdb.tdb('/var/cache/samba/connections.tdb')
87--
882.17.1
89
diff --git a/meta-oe/recipes-support/dstat/dstat_0.7.4.bb b/meta-oe/recipes-support/dstat/dstat_0.7.4.bb
index 2e37dd72e..74af54ca5 100644
--- a/meta-oe/recipes-support/dstat/dstat_0.7.4.bb
+++ b/meta-oe/recipes-support/dstat/dstat_0.7.4.bb
@@ -9,7 +9,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
9 9
10DEPENDS += "asciidoc-native xmlto-native" 10DEPENDS += "asciidoc-native xmlto-native"
11 11
12SRC_URI = "git://github.com/dagwieers/dstat.git" 12SRC_URI = "git://github.com/dagwieers/dstat.git \
13 file://0001-change-dstat-to-python3.patch \
14 "
13 15
14SRCREV = "6f5db0aed26bf8cf2700d4ffe90a9bd3436ac728" 16SRCREV = "6f5db0aed26bf8cf2700d4ffe90a9bd3436ac728"
15 17