diff options
author | Khem Raj <raj.khem@gmail.com> | 2013-06-13 03:57:55 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-06-20 12:30:06 +0200 |
commit | 475e25491c0265e813a332f8ba3d39dcc1e02b81 (patch) | |
tree | db9923cf832d31f8de89be1a804c9fccc4a33925 /meta-oe | |
parent | ff4e6575eac6fd9d508cb988e6cc675ebf555cbe (diff) | |
download | meta-openembedded-475e25491c0265e813a332f8ba3d39dcc1e02b81.tar.gz |
gypsy: Fix build with newer glib
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-navigation/gypsy/files/0001-g_type_init-is-deprecated-for-glib-2.35.0.patch | 114 | ||||
-rw-r--r-- | meta-oe/recipes-navigation/gypsy/gypsy_0.9.bb | 4 |
2 files changed, 117 insertions, 1 deletions
diff --git a/meta-oe/recipes-navigation/gypsy/files/0001-g_type_init-is-deprecated-for-glib-2.35.0.patch b/meta-oe/recipes-navigation/gypsy/files/0001-g_type_init-is-deprecated-for-glib-2.35.0.patch new file mode 100644 index 000000000..063bea618 --- /dev/null +++ b/meta-oe/recipes-navigation/gypsy/files/0001-g_type_init-is-deprecated-for-glib-2.35.0.patch | |||
@@ -0,0 +1,114 @@ | |||
1 | From 5b859b6e7c82f49d967c25398a8e75b61af9bcc0 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 12 Jun 2013 20:58:51 -0700 | ||
4 | Subject: [PATCH] g_type_init() is deprecated for glib >= 2.35.0 | ||
5 | |||
6 | Call it for old versions. | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | |||
10 | Upstream-Status: Pending | ||
11 | --- | ||
12 | examples/list-known-gps-devices.c | 4 ++-- | ||
13 | examples/simple-gps-dbus.c | 3 ++- | ||
14 | examples/simple-gps-gypsy.c | 4 ++-- | ||
15 | examples/simple-gps-satellites.c | 4 ++-- | ||
16 | gypsy/gypsy-marshal.c | 2 +- | ||
17 | src/main.c | 4 ++-- | ||
18 | 6 files changed, 11 insertions(+), 10 deletions(-) | ||
19 | |||
20 | diff --git a/examples/list-known-gps-devices.c b/examples/list-known-gps-devices.c | ||
21 | index c7c4059..0a8b04b 100644 | ||
22 | --- a/examples/list-known-gps-devices.c | ||
23 | +++ b/examples/list-known-gps-devices.c | ||
24 | @@ -20,9 +20,9 @@ main (int argc, | ||
25 | GError *error = NULL; | ||
26 | GPtrArray *known_devices; | ||
27 | int i; | ||
28 | - | ||
29 | +#if !GLIB_CHECK_VERSION(2,35,0) | ||
30 | g_type_init (); | ||
31 | - | ||
32 | +#endif | ||
33 | discovery = gypsy_discovery_new (); | ||
34 | known_devices = gypsy_discovery_list_devices (discovery, &error); | ||
35 | |||
36 | diff --git a/examples/simple-gps-dbus.c b/examples/simple-gps-dbus.c | ||
37 | index f7044e6..76b18aa 100644 | ||
38 | --- a/examples/simple-gps-dbus.c | ||
39 | +++ b/examples/simple-gps-dbus.c | ||
40 | @@ -121,8 +121,9 @@ main (int argc, | ||
41 | DBusConnection *conn; | ||
42 | DBusError error; | ||
43 | GMainLoop *mainloop; | ||
44 | - | ||
45 | +#if !GLIB_CHECK_VERSION(2,35,0) | ||
46 | g_type_init (); | ||
47 | +#endif | ||
48 | conn = get_connection (); | ||
49 | |||
50 | dbus_error_init (&error); | ||
51 | diff --git a/examples/simple-gps-gypsy.c b/examples/simple-gps-gypsy.c | ||
52 | index 0b6b7a6..86033d9 100644 | ||
53 | --- a/examples/simple-gps-gypsy.c | ||
54 | +++ b/examples/simple-gps-gypsy.c | ||
55 | @@ -67,9 +67,9 @@ main (int argc, | ||
56 | g_print ("Usage: %s device\n", argv[0]); | ||
57 | return 0; | ||
58 | } | ||
59 | - | ||
60 | +#if !GLIB_CHECK_VERSION(2,35,0) | ||
61 | g_type_init (); | ||
62 | - | ||
63 | +#endif | ||
64 | control = gypsy_control_get_default (); | ||
65 | path = gypsy_control_create (control, argv[1], &error); | ||
66 | if (path == NULL) { | ||
67 | diff --git a/examples/simple-gps-satellites.c b/examples/simple-gps-satellites.c | ||
68 | index 140c98f..9a3f95a 100644 | ||
69 | --- a/examples/simple-gps-satellites.c | ||
70 | +++ b/examples/simple-gps-satellites.c | ||
71 | @@ -42,9 +42,9 @@ main (int argc, | ||
72 | g_print ("Usage: %s device\n", argv[0]); | ||
73 | return 0; | ||
74 | } | ||
75 | - | ||
76 | +#if !GLIB_CHECK_VERSION(2,35,0) | ||
77 | g_type_init (); | ||
78 | - | ||
79 | +#endif | ||
80 | control = gypsy_control_get_default (); | ||
81 | path = gypsy_control_create (control, argv[1], &error); | ||
82 | if (path == NULL) { | ||
83 | diff --git a/gypsy/gypsy-marshal.c b/gypsy/gypsy-marshal.c | ||
84 | index 6964644..9ac0095 100644 | ||
85 | --- a/gypsy/gypsy-marshal.c | ||
86 | +++ b/gypsy/gypsy-marshal.c | ||
87 | @@ -5,7 +5,7 @@ | ||
88 | |||
89 | #ifdef G_ENABLE_DEBUG | ||
90 | #define g_marshal_value_peek_boolean(v) g_value_get_boolean (v) | ||
91 | -#define g_marshal_value_peek_char(v) g_value_get_char (v) | ||
92 | +#define g_marshal_value_peek_char(v) g_value_get_schar (v) | ||
93 | #define g_marshal_value_peek_uchar(v) g_value_get_uchar (v) | ||
94 | #define g_marshal_value_peek_int(v) g_value_get_int (v) | ||
95 | #define g_marshal_value_peek_uint(v) g_value_get_uint (v) | ||
96 | diff --git a/src/main.c b/src/main.c | ||
97 | index 3e8a794..ec980e5 100644 | ||
98 | --- a/src/main.c | ||
99 | +++ b/src/main.c | ||
100 | @@ -187,9 +187,9 @@ main (int argc, | ||
101 | g_option_context_free (context); | ||
102 | |||
103 | umask (022); | ||
104 | - | ||
105 | +#if !GLIB_CHECK_VERSION(2,35,0) | ||
106 | g_type_init (); | ||
107 | - | ||
108 | +#endif | ||
109 | mainloop = g_main_loop_new (NULL, FALSE); | ||
110 | |||
111 | conn = dbus_g_bus_get (DBUS_BUS_SYSTEM, &error); | ||
112 | -- | ||
113 | 1.7.9.5 | ||
114 | |||
diff --git a/meta-oe/recipes-navigation/gypsy/gypsy_0.9.bb b/meta-oe/recipes-navigation/gypsy/gypsy_0.9.bb index 51207c9a0..564d3d96f 100644 --- a/meta-oe/recipes-navigation/gypsy/gypsy_0.9.bb +++ b/meta-oe/recipes-navigation/gypsy/gypsy_0.9.bb | |||
@@ -13,7 +13,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \ | |||
13 | SECTION = "x11" | 13 | SECTION = "x11" |
14 | DEPENDS = "glib-2.0 dbus bluez4 dbus-glib libxslt" | 14 | DEPENDS = "glib-2.0 dbus bluez4 dbus-glib libxslt" |
15 | 15 | ||
16 | SRC_URI = "http://gypsy.freedesktop.org/releases/gypsy-${PV}.tar.gz" | 16 | SRC_URI = "http://gypsy.freedesktop.org/releases/gypsy-${PV}.tar.gz \ |
17 | file://0001-g_type_init-is-deprecated-for-glib-2.35.0.patch \ | ||
18 | " | ||
17 | PR = "r1" | 19 | PR = "r1" |
18 | 20 | ||
19 | inherit autotools pkgconfig | 21 | inherit autotools pkgconfig |