summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-08-17 16:32:38 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2011-08-19 18:11:02 +0200
commit3ee3add90dcc705c6afb28d5fa9e4d535a305c6e (patch)
tree68041d5e7ad9e5d22561fe67442bc150b635da62 /meta-oe
parentd9565d90d98a3a25533209393cb1f6ae8c89c9d1 (diff)
downloadmeta-openembedded-3ee3add90dcc705c6afb28d5fa9e4d535a305c6e.tar.gz
bluez4: remove from meta-oe, fixed version is now in oe-core
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-connectivity/bluez/bluez4/bluetooth.conf16
-rw-r--r--meta-oe/recipes-connectivity/bluez/bluez4/fix-dfutool-usb-declaration-mismatch.patch20
-rw-r--r--meta-oe/recipes-connectivity/bluez/bluez4_4.96.bb69
3 files changed, 0 insertions, 105 deletions
diff --git a/meta-oe/recipes-connectivity/bluez/bluez4/bluetooth.conf b/meta-oe/recipes-connectivity/bluez/bluez4/bluetooth.conf
deleted file mode 100644
index ca5e9e4f2..000000000
--- a/meta-oe/recipes-connectivity/bluez/bluez4/bluetooth.conf
+++ /dev/null
@@ -1,16 +0,0 @@
1<!-- This configuration file specifies the required security policies
2 for Bluetooth core daemon to work. -->
3
4<!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
5 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
6<busconfig>
7
8 <!-- ../system.conf have denied everything, so we just punch some holes -->
9
10 <policy context="default">
11 <allow own="org.bluez"/>
12 <allow send_destination="org.bluez"/>
13 <allow send_interface="org.bluez.Agent"/>
14 </policy>
15
16</busconfig>
diff --git a/meta-oe/recipes-connectivity/bluez/bluez4/fix-dfutool-usb-declaration-mismatch.patch b/meta-oe/recipes-connectivity/bluez/bluez4/fix-dfutool-usb-declaration-mismatch.patch
deleted file mode 100644
index 27dead092..000000000
--- a/meta-oe/recipes-connectivity/bluez/bluez4/fix-dfutool-usb-declaration-mismatch.patch
+++ /dev/null
@@ -1,20 +0,0 @@
1# bluez4: add compile patch fixing some usb declaration mismatch
2# Author: Michael 'Mickey' Lauer <mickey@vanille-media.de>
3# Date: Thu Jan 29 16:52:21 2009 +0000
4#
5# Acquired from OpenEmbedded
6Upstream-Status: Pending
7
8Index: bluez-4.27/tools/dfutool.c
9===================================================================
10--- bluez-4.27.orig/tools/dfutool.c
11+++ bluez-4.27/tools/dfutool.c
12@@ -59,7 +59,7 @@
13 #endif
14
15 #ifdef NEED_USB_GET_BUSSES
16-static inline struct usb_bus *usb_get_busses(void)
17+inline struct usb_bus *usb_get_busses(void)
18 {
19 return usb_busses;
20 }
diff --git a/meta-oe/recipes-connectivity/bluez/bluez4_4.96.bb b/meta-oe/recipes-connectivity/bluez/bluez4_4.96.bb
deleted file mode 100644
index 211e91065..000000000
--- a/meta-oe/recipes-connectivity/bluez/bluez4_4.96.bb
+++ /dev/null
@@ -1,69 +0,0 @@
1SUMMARY = "Linux Bluetooth Stack Userland V4"
2DESCRIPTION = "Linux Bluetooth stack V4 userland components. These include a system configurations, daemons, tools and system libraries."
3HOMEPAGE = "http://www.bluez.org"
4SECTION = "libs"
5LICENSE = "GPLv2+ & LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
7 file://COPYING.LIB;md5=fb504b67c50331fc78734fed90fb0e09 \
8 file://src/main.c;beginline=1;endline=24;md5=9bc54b93cd7e17bf03f52513f39f926e \
9 file://sbc/sbc.c;beginline=1;endline=25;md5=1a40781ed30d50d8639323a184aeb191"
10DEPENDS = "udev gst-plugins-base alsa-lib libusb dbus-glib usbpath"
11RDEPENDS_${PN}-dev = "bluez-hcidump"
12
13ASNEEDED = ""
14
15PR = "r0"
16
17SRC_URI = "\
18 ${KERNELORG_MIRROR}/linux/bluetooth/bluez-${PV}.tar.gz \
19 file://fix-dfutool-usb-declaration-mismatch.patch \
20 file://bluetooth.conf \
21"
22
23SRC_URI[md5sum] = "296111afac49e3f9035085ac14daf518"
24SRC_URI[sha256sum] = "c06fd50fd77909cad55e3181a42c6bce7cfcf7abb8cd87871c13d0d70f87fa99"
25
26S = "${WORKDIR}/bluez-${PV}"
27
28inherit autotools
29
30EXTRA_OECONF = "\
31 --enable-gstreamer \
32 --enable-alsa \
33 --enable-usb \
34 --enable-tools \
35 --enable-bccmd \
36 --enable-hid2hci \
37 --enable-dfutool \
38 --enable-hidd \
39 --enable-pand \
40 --enable-dund \
41 --disable-cups \
42 --enable-test \
43 --enable-configfiles \
44"
45
46do_install_append() {
47 install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
48 install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
49 install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
50 # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
51 install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
52}
53
54PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"
55
56FILES_gst-plugin-bluez = "${libdir}/gstreamer-0.10/lib*.so"
57FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so ${datadir}/alsa"
58FILES_${PN} += "${libdir}/bluetooth/plugins/*.so ${base_libdir}/udev/ ${base_libdir}/systemd/"
59FILES_${PN}-dev += "\
60 ${libdir}/bluetooth/plugins/*.la \
61 ${libdir}/alsa-lib/*.la \
62 ${libdir}/gstreamer-0.10/*.la \
63"
64
65FILES_${PN}-dbg += "\
66 ${libdir}/bluetooth/plugins/.debug \
67 ${libdir}/*/.debug \
68 ${base_libdir}/udev/.debug \
69"