diff options
author | Kai Kang <kai.kang@windriver.com> | 2016-11-09 15:58:52 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-11-23 15:24:43 +0100 |
commit | 3c5b7a841a8da7120d38b86881972d35ad7c5b5b (patch) | |
tree | c6cf7dab68899e606be252a88b4520632e5cb42c /meta-oe | |
parent | ce306bbec1da8ee45ff061c8f83d211c4d9334fd (diff) | |
download | meta-openembedded-3c5b7a841a8da7120d38b86881972d35ad7c5b5b.tar.gz |
libhugetlbfs: 1.19 -> 1.20
Upgrade libhugetlbfs from 1.19 to 1.20.
* Remove libhugetlbfs-avoid-using-restrict-as-var-name.patch which is
fixed in upstream.
Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-benchmark/libhugetlbfs/files/libhugetlbfs-avoid-using-restrict-as-var-name.patch | 34 | ||||
-rw-r--r-- | meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb | 5 |
2 files changed, 2 insertions, 37 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/libhugetlbfs-avoid-using-restrict-as-var-name.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/libhugetlbfs-avoid-using-restrict-as-var-name.patch deleted file mode 100644 index b77cfe10e..000000000 --- a/meta-oe/recipes-benchmark/libhugetlbfs/files/libhugetlbfs-avoid-using-restrict-as-var-name.patch +++ /dev/null | |||
@@ -1,34 +0,0 @@ | |||
1 | Avoid using keyword restrict as variable name which causes error with gcc 5.x: | ||
2 | |||
3 | | hugeutils.c: In function '__lh_hugetlbfs_setup_env': | ||
4 | | hugeutils.c:304:40: error: expected identifier or '(' before 'restrict' | ||
5 | | char *p, *tok, *exe, buf[MAX_EXE+1], restrict[MAX_EXE]; | ||
6 | | ^ | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | |||
10 | Signed-off-by: Kai Kang <kai.kang@windriver.com> | ||
11 | --- | ||
12 | diff --git a/hugeutils.c b/hugeutils.c | ||
13 | index 53a7fbd..b9d7001 100644 | ||
14 | --- a/hugeutils.c | ||
15 | +++ b/hugeutils.c | ||
16 | @@ -301,14 +301,14 @@ void hugetlbfs_setup_env() | ||
17 | |||
18 | env = getenv("HUGETLB_RESTRICT_EXE"); | ||
19 | if (env) { | ||
20 | - char *p, *tok, *exe, buf[MAX_EXE+1], restrict[MAX_EXE]; | ||
21 | + char *p, *tok, *exe, buf[MAX_EXE+1], restricted[MAX_EXE]; | ||
22 | int found = 0; | ||
23 | |||
24 | exe = get_exe_name(buf, sizeof buf); | ||
25 | DEBUG("Found HUGETLB_RESTRICT_EXE, this exe is \"%s\"\n", exe); | ||
26 | - strncpy(restrict, env, sizeof restrict); | ||
27 | - restrict[sizeof(restrict)-1] = 0; | ||
28 | - for (p = restrict; (tok = strtok(p, ":")) != NULL; p = NULL) { | ||
29 | + strncpy(restricted, env, sizeof restricted); | ||
30 | + restricted[sizeof(restricted)-1] = 0; | ||
31 | + for (p = restricted; (tok = strtok(p, ":")) != NULL; p = NULL) { | ||
32 | DEBUG(" ...check exe match for \"%s\"\n", tok); | ||
33 | if (strcmp(tok, exe) == 0) { | ||
34 | found = 1; | ||
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb index 301b5505d..72553cfd6 100644 --- a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb +++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb | |||
@@ -7,10 +7,10 @@ DEPENDS = "sysfsutils perl" | |||
7 | RDEPENDS_${PN} += "bash perl python python-io python-lang python-subprocess python-resource ${PN}-perl" | 7 | RDEPENDS_${PN} += "bash perl python python-io python-lang python-subprocess python-resource ${PN}-perl" |
8 | RDEPENDS_${PN}-tests += "bash" | 8 | RDEPENDS_${PN}-tests += "bash" |
9 | 9 | ||
10 | PV = "2.19" | 10 | PV = "2.20" |
11 | PE = "1" | 11 | PE = "1" |
12 | 12 | ||
13 | SRCREV = "426c22d65415fcb8927f68fbc5887e075a8dc40a" | 13 | SRCREV = "e44180072b796c0e28e53c4d01ef6279caaa2a99" |
14 | SRC_URI = " \ | 14 | SRC_URI = " \ |
15 | git://github.com/libhugetlbfs/libhugetlbfs.git;protocol=https \ | 15 | git://github.com/libhugetlbfs/libhugetlbfs.git;protocol=https \ |
16 | file://skip-checking-LIB32-and-LIB64-if-they-point-to-the-s.patch \ | 16 | file://skip-checking-LIB32-and-LIB64-if-they-point-to-the-s.patch \ |
@@ -18,7 +18,6 @@ SRC_URI = " \ | |||
18 | file://tests-Makefile-install-static-4G-edge-testcases.patch \ | 18 | file://tests-Makefile-install-static-4G-edge-testcases.patch \ |
19 | file://0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch \ | 19 | file://0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch \ |
20 | file://libhugetlbfs-elf_i386-avoid-search-host-library-path.patch \ | 20 | file://libhugetlbfs-elf_i386-avoid-search-host-library-path.patch \ |
21 | file://libhugetlbfs-avoid-using-restrict-as-var-name.patch \ | ||
22 | file://Force-text-segment-alignment-to-0x08000000-for-i386-.patch \ | 21 | file://Force-text-segment-alignment-to-0x08000000-for-i386-.patch \ |
23 | " | 22 | " |
24 | 23 | ||