diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-05-06 12:45:46 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-05-06 20:57:44 -0700 |
commit | 3c259f977e8647ac9c54097d0faab70719a5553e (patch) | |
tree | c9194f4bcff2dfc6ca7d4eb940e629fce70ba8af /meta-oe | |
parent | 5f3f16214532f489e46f1cb4f506727a26c0a359 (diff) | |
download | meta-openembedded-3c259f977e8647ac9c54097d0faab70719a5553e.tar.gz |
icewm: Upgrade to 2.3.3
Do not check for C++11, since it is a runtime check, wont work during
cross compile, in anycase our compilers do support C++11 and default to
c++ or newer std, so this check is redundant for OE toolchains
Add new required build time deps on fribidi and imlib2
Changes are [1]
[1] https://github.com/ice-wm/icewm/releases/tag/2.3.3
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-extended/icewm/icewm/0001-configure.ac-skip-running-test-program-when-cross-co.patch | 31 | ||||
-rw-r--r-- | meta-oe/recipes-extended/icewm/icewm_2.3.3.bb (renamed from meta-oe/recipes-extended/icewm/icewm_1.6.5.bb) | 4 |
2 files changed, 26 insertions, 9 deletions
diff --git a/meta-oe/recipes-extended/icewm/icewm/0001-configure.ac-skip-running-test-program-when-cross-co.patch b/meta-oe/recipes-extended/icewm/icewm/0001-configure.ac-skip-running-test-program-when-cross-co.patch index 794394855..c5e210afc 100644 --- a/meta-oe/recipes-extended/icewm/icewm/0001-configure.ac-skip-running-test-program-when-cross-co.patch +++ b/meta-oe/recipes-extended/icewm/icewm/0001-configure.ac-skip-running-test-program-when-cross-co.patch | |||
@@ -10,11 +10,9 @@ Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | |||
10 | configure.ac | 4 ++-- | 10 | configure.ac | 4 ++-- |
11 | 1 file changed, 2 insertions(+), 2 deletions(-) | 11 | 1 file changed, 2 insertions(+), 2 deletions(-) |
12 | 12 | ||
13 | diff --git a/configure.ac b/configure.ac | ||
14 | index c5e3ca03..4b89396a 100644 | ||
15 | --- a/configure.ac | 13 | --- a/configure.ac |
16 | +++ b/configure.ac | 14 | +++ b/configure.ac |
17 | @@ -140,7 +140,7 @@ AC_CHECK_FUNC([getloadavg],[AC_DEFINE([HAVE_GETLOADAVG2], 1, [getloadavg() is av | 15 | @@ -160,7 +160,7 @@ AC_CHECK_FUNCS([backtrace_symbols_fd mem |
18 | AC_FUNC_SELECT_ARGTYPES | 16 | AC_FUNC_SELECT_ARGTYPES |
19 | 17 | ||
20 | AC_MSG_CHECKING([for strlcpy]) | 18 | AC_MSG_CHECKING([for strlcpy]) |
@@ -23,7 +21,7 @@ index c5e3ca03..4b89396a 100644 | |||
23 | char a[2]; | 21 | char a[2]; |
24 | if (strlcpy(a, "yes", 2) != 3) | 22 | if (strlcpy(a, "yes", 2) != 3) |
25 | return 1;]])], | 23 | return 1;]])], |
26 | @@ -156,7 +156,7 @@ AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <string.h>]],[[ | 24 | @@ -176,7 +176,7 @@ AC_RUN_IFELSE([AC_LANG_PROGRAM([[#includ |
27 | ]) | 25 | ]) |
28 | 26 | ||
29 | AC_MSG_CHECKING([for strlcat]) | 27 | AC_MSG_CHECKING([for strlcat]) |
@@ -32,6 +30,25 @@ index c5e3ca03..4b89396a 100644 | |||
32 | char a[4] = "no"; | 30 | char a[4] = "no"; |
33 | if (strlcat(a, "yes", 4) != 5) | 31 | if (strlcat(a, "yes", 4) != 5) |
34 | return 1;]])], | 32 | return 1;]])], |
35 | -- | 33 | @@ -191,21 +191,6 @@ AC_RUN_IFELSE([AC_LANG_PROGRAM([[#includ |
36 | 2.17.1 | 34 | [Define to 1 if you have the strlcat function.]) |
37 | 35 | ]) | |
36 | |||
37 | -AC_MSG_CHECKING([for C++11 by default]) | ||
38 | -AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <regex>]],[[ | ||
39 | - if (__cplusplus < 201103L) return 1;]])], | ||
40 | - [AC_MSG_RESULT([yes])], | ||
41 | - [AC_MSG_RESULT([no]) | ||
42 | - AC_MSG_CHECKING([for C++11 when forced]) | ||
43 | - CXXFLAGS="$CXXFLAGS -std=c++11" | ||
44 | - AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <regex>]],[[ | ||
45 | - if (__cplusplus < 201103L) return 1;]])], | ||
46 | - [AC_MSG_RESULT([yes])], | ||
47 | - [AC_MSG_RESULT([no]) | ||
48 | - AC_MSG_ERROR([Need C++11. Please set CXXFLAGS.]) | ||
49 | - ]) | ||
50 | - ]) | ||
51 | - | ||
52 | PKG_CHECK_MODULES([CORE],[fontconfig xrender xcomposite xdamage xfixes xext x11]) | ||
53 | AC_SUBST([CORE_CFLAGS]) | ||
54 | AC_SUBST([CORE_LIBS]) | ||
diff --git a/meta-oe/recipes-extended/icewm/icewm_1.6.5.bb b/meta-oe/recipes-extended/icewm/icewm_2.3.3.bb index 241a2b30f..abc3e098c 100644 --- a/meta-oe/recipes-extended/icewm/icewm_1.6.5.bb +++ b/meta-oe/recipes-extended/icewm/icewm_2.3.3.bb | |||
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4a26952467ef79a7efca4a9cf52d417b" | |||
5 | SRC_URI = "https://github.com/ice-wm/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.lz \ | 5 | SRC_URI = "https://github.com/ice-wm/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.lz \ |
6 | file://0001-configure.ac-skip-running-test-program-when-cross-co.patch \ | 6 | file://0001-configure.ac-skip-running-test-program-when-cross-co.patch \ |
7 | " | 7 | " |
8 | SRC_URI[sha256sum] = "d41e6abf842ff3f8705a81d352be7c5b181c587549c183de0641c3820234a7b2" | 8 | SRC_URI[sha256sum] = "4162565cf7566d78d786e4ecf4b0639451b8464bcb24e761b1f08ef43e95e513" |
9 | 9 | ||
10 | UPSTREAM_CHECK_URI = "https://github.com/ice-wm/${BPN}/releases" | 10 | UPSTREAM_CHECK_URI = "https://github.com/ice-wm/${BPN}/releases" |
11 | 11 | ||
@@ -19,7 +19,7 @@ EXTRA_OECONF += "--with-libdir=${datadir}/icewm \ | |||
19 | --enable-xinerama \ | 19 | --enable-xinerama \ |
20 | --enable-shape" | 20 | --enable-shape" |
21 | 21 | ||
22 | DEPENDS = "asciidoc-native fontconfig gdk-pixbuf libxft libxpm libxrandr \ | 22 | DEPENDS = "asciidoc-native fontconfig fribidi gdk-pixbuf imlib2 libxft libxpm libxrandr \ |
23 | libxinerama libice libsm libx11 libxext libxrender libxcomposite libxdamage \ | 23 | libxinerama libice libsm libx11 libxext libxrender libxcomposite libxdamage \ |
24 | libxfixes" | 24 | libxfixes" |
25 | DEPENDS_append = " qemu-native" | 25 | DEPENDS_append = " qemu-native" |