summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-08-15 14:19:42 -0700
committerKhem Raj <raj.khem@gmail.com>2023-08-15 14:21:17 -0700
commit331fd95146b5517b1f35f972ee4cd7d91129d8ff (patch)
tree6f2bf9d2182023872df23f7e3a220f0be910bdc2 /meta-oe
parent4935eff3d1dd7da841dd01f60cd0d5b5d4fa0e17 (diff)
downloadmeta-openembedded-331fd95146b5517b1f35f972ee4cd7d91129d8ff.tar.gz
jemalloc: Unbolt clang workaroud
This works well with clang 15+ Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/jemalloc/files/0001-test-Disable-optimization-with-clang-for-aligned_all.patch33
-rw-r--r--meta-oe/recipes-devtools/jemalloc/jemalloc_5.3.0.bb4
2 files changed, 0 insertions, 37 deletions
diff --git a/meta-oe/recipes-devtools/jemalloc/files/0001-test-Disable-optimization-with-clang-for-aligned_all.patch b/meta-oe/recipes-devtools/jemalloc/files/0001-test-Disable-optimization-with-clang-for-aligned_all.patch
deleted file mode 100644
index 570202e80..000000000
--- a/meta-oe/recipes-devtools/jemalloc/files/0001-test-Disable-optimization-with-clang-for-aligned_all.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From 3fe67deb9fcf0ae3c2ff31a9eccb6a0a9af33b9c Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 14 Jan 2022 09:47:03 -0800
4Subject: [PATCH] test: Disable optimization with clang for aligned_alloc.c
5
6Clang crashes when using glibc 2.35, it works ok with older glibc or
7musl, so its very specific problem. Its reported here
8
9https://github.com/llvm/llvm-project/issues/52765
10
11Until it is fixed, workaround the build failure
12
13Upstream-Status: Inappropriate [Workaround]
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15---
16 test/integration/aligned_alloc.c | 2 ++
17 1 file changed, 2 insertions(+)
18
19diff --git a/test/integration/aligned_alloc.c b/test/integration/aligned_alloc.c
20index 4375b172..6513bdd9 100644
21--- a/test/integration/aligned_alloc.c
22+++ b/test/integration/aligned_alloc.c
23@@ -1,5 +1,7 @@
24 #include "test/jemalloc_test.h"
25
26+#pragma clang optimize off
27+
28 #define MAXALIGN (((size_t)1) << 23)
29
30 /*
31--
322.34.1
33
diff --git a/meta-oe/recipes-devtools/jemalloc/jemalloc_5.3.0.bb b/meta-oe/recipes-devtools/jemalloc/jemalloc_5.3.0.bb
index 9ad83261e..3d48bc012 100644
--- a/meta-oe/recipes-devtools/jemalloc/jemalloc_5.3.0.bb
+++ b/meta-oe/recipes-devtools/jemalloc/jemalloc_5.3.0.bb
@@ -16,10 +16,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=ea061f8731d5e6a5761dfad951ef5f5f"
16SRC_URI = "git://github.com/jemalloc/jemalloc.git;branch=master;protocol=https \ 16SRC_URI = "git://github.com/jemalloc/jemalloc.git;branch=master;protocol=https \
17 file://run-ptest \ 17 file://run-ptest \
18 " 18 "
19
20# Workaround for https://github.com/llvm/llvm-project/issues/52765
21SRC_URI:append:libc-glibc:toolchain-clang = " file://0001-test-Disable-optimization-with-clang-for-aligned_all.patch "
22
23SRCREV = "54eaed1d8b56b1aa528be3bdd1877e59c56fa90c" 19SRCREV = "54eaed1d8b56b1aa528be3bdd1877e59c56fa90c"
24 20
25S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"