diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-01-07 20:48:33 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-01-08 13:55:20 -0800 |
commit | 31bbb228f06228c40fd2fec2b988031c6b1222df (patch) | |
tree | 0c224afb1c33b96f6869aad4bc53b2d5a3f2e391 /meta-oe | |
parent | 82076b05635b79a8fa5c9642dd7bb82c378ed27e (diff) | |
download | meta-openembedded-31bbb228f06228c40fd2fec2b988031c6b1222df.tar.gz |
concurrencykit: Fix build on riscv32 and riscv64
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
2 files changed, 34 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/concurrencykit/concurrencykit/0001-build-Use-ilp32d-abi-on-riscv32-and-lp64d-on-rv64.patch b/meta-oe/recipes-devtools/concurrencykit/concurrencykit/0001-build-Use-ilp32d-abi-on-riscv32-and-lp64d-on-rv64.patch new file mode 100644 index 000000000..a8ff77298 --- /dev/null +++ b/meta-oe/recipes-devtools/concurrencykit/concurrencykit/0001-build-Use-ilp32d-abi-on-riscv32-and-lp64d-on-rv64.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 00f822ab79b6c06936147af4d832e439cecf0fc0 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 7 Jan 2023 19:31:58 -0800 | ||
4 | Subject: [PATCH] build: Use ilp32d abi on riscv32 and lp64d on rv64 | ||
5 | |||
6 | ilp32d is common ABI used for linux distributions therefore a better | ||
7 | default, similarily lp64d is common ABI for rv64 linux | ||
8 | |||
9 | Upstream-Status: Submitted [https://github.com/concurrencykit/ck/pull/204] | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | build/ck.build.riscv | 2 +- | ||
13 | build/ck.build.riscv64 | 2 +- | ||
14 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/build/ck.build.riscv b/build/ck.build.riscv | ||
17 | index 61e0033..11ac840 100644 | ||
18 | --- a/build/ck.build.riscv | ||
19 | +++ b/build/ck.build.riscv | ||
20 | @@ -1 +1 @@ | ||
21 | -CFLAGS+=-mabi=ilp32 | ||
22 | +CFLAGS+=-mabi=ilp32d | ||
23 | diff --git a/build/ck.build.riscv64 b/build/ck.build.riscv64 | ||
24 | index 9f89791..7639bd6 100644 | ||
25 | --- a/build/ck.build.riscv64 | ||
26 | +++ b/build/ck.build.riscv64 | ||
27 | @@ -1 +1 @@ | ||
28 | -CFLAGS+=-mabi=lp64 | ||
29 | +CFLAGS+=-mabi=lp64d | ||
30 | -- | ||
31 | 2.39.0 | ||
32 | |||
diff --git a/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb b/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb index fe2c1d201..277fac9f7 100644 --- a/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb +++ b/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb | |||
@@ -11,7 +11,8 @@ PV = "0.7.0+git${SRCPV}" | |||
11 | SRCREV = "6e8e5bec2e2f8cef2072a68579cbb07ababf3331" | 11 | SRCREV = "6e8e5bec2e2f8cef2072a68579cbb07ababf3331" |
12 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a0b24c1a8f9ad516a297d055b0294231" | 12 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a0b24c1a8f9ad516a297d055b0294231" |
13 | SRC_URI = "git://github.com/concurrencykit/ck.git;branch=master;protocol=https \ | 13 | SRC_URI = "git://github.com/concurrencykit/ck.git;branch=master;protocol=https \ |
14 | file://0001-configure-Fix-compoiler-detection-logic-for-cross-co.patch" | 14 | file://0001-configure-Fix-compoiler-detection-logic-for-cross-co.patch \ |
15 | file://0001-build-Use-ilp32d-abi-on-riscv32-and-lp64d-on-rv64.patch" | ||
15 | 16 | ||
16 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
17 | 18 | ||