diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-09-16 23:36:23 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-09-20 15:34:02 -0700 |
commit | 2ccedccd6e0665d06ba66a4fb5d4fb72de40b429 (patch) | |
tree | ed299c366537ed483a8a044413cfc9746c8e20c2 /meta-oe | |
parent | f8e7a3d98a204302377e247bfea3e8bb2b81866a (diff) | |
download | meta-openembedded-2ccedccd6e0665d06ba66a4fb5d4fb72de40b429.tar.gz |
poco: Fix ptest runtime errors
* Skip failing tests for now
* Limit supported architecture list to same as mongoDB
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
3 files changed, 73 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/poco/poco/0001-cppignore.lnx-Ignore-PKCS12-and-testLaunch-test.patch b/meta-oe/recipes-support/poco/poco/0001-cppignore.lnx-Ignore-PKCS12-and-testLaunch-test.patch new file mode 100644 index 000000000..25934d61b --- /dev/null +++ b/meta-oe/recipes-support/poco/poco/0001-cppignore.lnx-Ignore-PKCS12-and-testLaunch-test.patch | |||
@@ -0,0 +1,63 @@ | |||
1 | From ac0f06e20bdfaca74c8ab786be8ff8fc96b5a689 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 16 Sep 2023 19:52:56 -0700 | ||
4 | Subject: [PATCH] cppignore.lnx: Ignore PKCS12 and testLaunch test | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | These tests fail on Linux | ||
10 | |||
11 | There were 4 failures: | ||
12 | 1: N7CppUnit10TestCallerI11ProcessTestEE.testLaunch | ||
13 | "rc == 3" | ||
14 | in "/usr/src/debug/poco/1.12.4-r0/Foundation/testsuite/src/ProcessTest.cpp", line 79 | ||
15 | 2: N7CppUnit10TestCallerI11ProcessTestEE.testLaunchRedirectIn | ||
16 | "rc == 100" | ||
17 | in "/usr/src/debug/poco/1.12.4-r0/Foundation/testsuite/src/ProcessTest.cpp", line 106 | ||
18 | 3: N7CppUnit10TestCallerI11ProcessTestEE.testLaunchRedirectOut | ||
19 | "s == "Hello, world!"" | ||
20 | in "/usr/src/debug/poco/1.12.4-r0/Foundation/testsuite/src/ProcessTest.cpp", line 134 | ||
21 | 4: N7CppUnit10TestCallerI11ProcessTestEE.testLaunchEnv | ||
22 | "s == "test"" | ||
23 | in "/usr/src/debug/poco/1.12.4-r0/Foundation/testsuite/src/ProcessTest.cpp", line 166 | ||
24 | |||
25 | There were 4 errors:- | ||
26 | 1: N7CppUnit10TestCallerI7EVPTestEE.testRSAEVPKeyFromPKCS12 | ||
27 | │ │ "N4Poco17NotFoundExceptionE: | ||
28 | Not found: POCO_BASE" | ||
29 | │ │ in "<unknown>", line -1 | ||
30 | 2: N7CppUnit10TestCallerI19PKCS12ContainerTestEE.testFullPKCS12 | ||
31 | │ │ "N4Poco17NotFoundExceptionE: | ||
32 | Not found: POCO_BASE" | ||
33 | │ │ in "<unknown>", line -1 | ||
34 | 3: N7CppUnit10TestCallerI19PKCS12ContainerTestEE.testCertsOnlyPKCS12 | ||
35 | │ │ "N4Poco17NotFoundExceptionE: | ||
36 | Not found: POCO_BASE" | ||
37 | │ │ in "<unknown>", line -1 | ||
38 | 4: N7CppUnit10TestCallerI19PKCS12ContainerTestEE.testPEMReadWrite | ||
39 | │ │ "N4Poco17NotFoundExceptionE: | ||
40 | Not found: POCO_BASE" | ||
41 | │ │ in "<unknown>", line -1 | ||
42 | |||
43 | Upstream-Status: Inappropriate [OE specific] | ||
44 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
45 | --- | ||
46 | cppignore.lnx | 8 ++++++++ | ||
47 | 1 file changed, 8 insertions(+) | ||
48 | |||
49 | --- a/cppignore.lnx | ||
50 | +++ b/cppignore.lnx | ||
51 | @@ -26,3 +26,12 @@ N7CppUnit10TestCallerI9TimerTestEE.testS | ||
52 | N7CppUnit10TestCallerI9TimerTestEE.testScheduleIntervalClock | ||
53 | N7CppUnit10TestCallerI9TimerTestEE.testScheduleIntervalTimestamp | ||
54 | N7CppUnit10TestCallerI9TimerTestEE.testTimer | ||
55 | +N7CppUnit10TestCallerI11ProcessTestEE.testLaunch | ||
56 | +N7CppUnit10TestCallerI11ProcessTestEE.testLaunchRedirectIn | ||
57 | +N7CppUnit10TestCallerI11ProcessTestEE.testLaunchRedirectOut | ||
58 | +N7CppUnit10TestCallerI11ProcessTestEE.testLaunchEnv | ||
59 | +N7CppUnit10TestCallerI7EVPTestEE.testRSAEVPKeyFromPKCS12 | ||
60 | +N7CppUnit10TestCallerI19PKCS12ContainerTestEE.testFullPKCS12 | ||
61 | +N7CppUnit10TestCallerI19PKCS12ContainerTestEE.testCertsOnlyPKCS12 | ||
62 | +N7CppUnit10TestCallerI19PKCS12ContainerTestEE.testPEMReadWrite | ||
63 | +N7CppUnit10TestCallerI11MongoDBTestEE.testArray | ||
diff --git a/meta-oe/recipes-support/poco/poco/run-ptest b/meta-oe/recipes-support/poco/poco/run-ptest index db8cf8511..c8e50fc96 100644 --- a/meta-oe/recipes-support/poco/poco/run-ptest +++ b/meta-oe/recipes-support/poco/poco/run-ptest | |||
@@ -1,4 +1,6 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | export POCO_BASE=/usr/lib/poco/ptest | ||
3 | export LD_LIBRARY_PATH=${POCO_BASE}/bin:${LD_LIBRARY_PATH} | ||
2 | i=0 | 4 | i=0 |
3 | while read runner; do | 5 | while read runner; do |
4 | oldpath=`pwd` >/dev/null | 6 | oldpath=`pwd` >/dev/null |
diff --git a/meta-oe/recipes-support/poco/poco_1.12.4.bb b/meta-oe/recipes-support/poco/poco_1.12.4.bb index 47dac1a89..b02b84fa6 100644 --- a/meta-oe/recipes-support/poco/poco_1.12.4.bb +++ b/meta-oe/recipes-support/poco/poco_1.12.4.bb | |||
@@ -10,6 +10,7 @@ DEPENDS = "libpcre2 zlib" | |||
10 | 10 | ||
11 | SRC_URI = "git://github.com/pocoproject/poco.git;branch=master;protocol=https \ | 11 | SRC_URI = "git://github.com/pocoproject/poco.git;branch=master;protocol=https \ |
12 | file://0001-Use-std-atomic-int-instead-of-std-atomic-bool.patch \ | 12 | file://0001-Use-std-atomic-int-instead-of-std-atomic-bool.patch \ |
13 | file://0001-cppignore.lnx-Ignore-PKCS12-and-testLaunch-test.patch \ | ||
13 | file://run-ptest \ | 14 | file://run-ptest \ |
14 | " | 15 | " |
15 | SRCREV = "1211613642269b7d53bea58b02de7fcd25ece3b9" | 16 | SRCREV = "1211613642269b7d53bea58b02de7fcd25ece3b9" |
@@ -24,6 +25,11 @@ inherit cmake ptest | |||
24 | # Foundation is built anyway and doesn't need to be listed explicitly | 25 | # Foundation is built anyway and doesn't need to be listed explicitly |
25 | # these don't have dependencies outside oe-core | 26 | # these don't have dependencies outside oe-core |
26 | PACKAGECONFIG ??= "XML JSON MongoDB PDF Util Net NetSSL Crypto JWT Data DataSQLite Zip Encodings Redis Prometheus" | 27 | PACKAGECONFIG ??= "XML JSON MongoDB PDF Util Net NetSSL Crypto JWT Data DataSQLite Zip Encodings Redis Prometheus" |
28 | # MongoDB does not build for all architectures yet keep in sync with COMPATIBLE_HOST list in mongodb recipe | ||
29 | PACKAGECONFIG:remove:riscv32 = "MongoDB" | ||
30 | PACKAGECONFIG:remove:riscv64 = "MongoDB" | ||
31 | PACKAGECONFIG:remove:mipsarch = "MongoDB" | ||
32 | PACKAGECONFIG:remove:powerpc = "MongoDB" | ||
27 | 33 | ||
28 | PACKAGECONFIG[XML] = "-DENABLE_XML=ON,-DENABLE_XML=OFF,expat" | 34 | PACKAGECONFIG[XML] = "-DENABLE_XML=ON,-DENABLE_XML=OFF,expat" |
29 | PACKAGECONFIG[JSON] = "-DENABLE_JSON=ON,-DENABLE_JSON=OFF" | 35 | PACKAGECONFIG[JSON] = "-DENABLE_JSON=ON,-DENABLE_JSON=OFF" |
@@ -105,5 +111,7 @@ FILES:${PN}-cppunit += "${libdir}/libCppUnit.so*" | |||
105 | ALLOW_EMPTY:${PN}-cppunit = "1" | 111 | ALLOW_EMPTY:${PN}-cppunit = "1" |
106 | 112 | ||
107 | RDEPENDS:${PN}-ptest += "${PN}-cppunit" | 113 | RDEPENDS:${PN}-ptest += "${PN}-cppunit" |
114 | RDEPENDS:${PN}-ptest += "${@bb.utils.contains('PACKAGECONFIG', 'MongoDB', 'mongodb', '', d)}" | ||
115 | RDEPENDS:${PN}-ptest += "${@bb.utils.contains('PACKAGECONFIG', 'Redis', 'redis', '', d)}" | ||
108 | 116 | ||
109 | BBCLASSEXTEND = "native" | 117 | BBCLASSEXTEND = "native" |