diff options
author | Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> | 2017-11-08 13:10:27 +0100 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2017-11-19 13:41:58 -0800 |
commit | 2bbef0ce64608d09ff4510071931c8d6254d1123 (patch) | |
tree | f107824a7e53992c88a0889d95644f3d028e5668 /meta-oe | |
parent | f888426e9039111c6626c31415c00adfe5af7a9c (diff) | |
download | meta-openembedded-2bbef0ce64608d09ff4510071931c8d6254d1123.tar.gz |
opencv: Fix java wrapper generation
During configuration the java wrappers are generated (if java
is enabled via PACKAGECOFIG).
Unfortunately, the script that generates the .java files do not handle
properly paths with special symbols, such as +.
This is just a workaround for that.
Signed-off-by: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-support/opencv/opencv/javagen.patch | 16 | ||||
-rw-r--r-- | meta-oe/recipes-support/opencv/opencv_3.3.bb | 1 |
2 files changed, 17 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv/javagen.patch b/meta-oe/recipes-support/opencv/opencv/javagen.patch new file mode 100644 index 000000000..56526ecd8 --- /dev/null +++ b/meta-oe/recipes-support/opencv/opencv/javagen.patch | |||
@@ -0,0 +1,16 @@ | |||
1 | Upstream-status: Inappropriate [OE specific] https://github.com/opencv/opencv/pull/10039#issuecomment-342539288 | ||
2 | |||
3 | Signed-off-by: Ricardo Ribalda <ricardo.ribalda@gmail.com> | ||
4 | diff --git a/modules/java/CMakeLists.txt b/modules/java/CMakeLists.txt | ||
5 | index 74bc0ef04169..4622fbf9a5f1 100644 | ||
6 | --- a/modules/java/CMakeLists.txt | ||
7 | +++ b/modules/java/CMakeLists.txt | ||
8 | @@ -291,7 +291,7 @@ foreach(java_file ${step3_input_files}) | ||
9 | endif() | ||
10 | if(__configure) | ||
11 | configure_file("${java_file}" "${java_src_dir}/${output_name}" @ONLY) | ||
12 | - elseif(NOT "${java_file}" MATCHES "${OpenCV_BINARY_DIR}/") | ||
13 | + elseif(EXISTS "${java_file}" AND NOT "${java_file}" MATCHES "${OpenCV_BINARY_DIR}/") | ||
14 | configure_file("${java_file}" "${java_src_dir}/${output_name}" COPYONLY) | ||
15 | else() | ||
16 | add_custom_command(OUTPUT "${java_src_dir}/${output_name}" | ||
diff --git a/meta-oe/recipes-support/opencv/opencv_3.3.bb b/meta-oe/recipes-support/opencv/opencv_3.3.bb index 8f0aa7f54..773bfe9f7 100644 --- a/meta-oe/recipes-support/opencv/opencv_3.3.bb +++ b/meta-oe/recipes-support/opencv/opencv_3.3.bb | |||
@@ -57,6 +57,7 @@ SRC_URI = "git://github.com/opencv/opencv.git;name=opencv \ | |||
57 | file://0001-carotene-don-t-use-__asm__-with-aarch64.patch \ | 57 | file://0001-carotene-don-t-use-__asm__-with-aarch64.patch \ |
58 | file://0002-Do-not-enable-asm-with-clang.patch \ | 58 | file://0002-Do-not-enable-asm-with-clang.patch \ |
59 | file://CVE-2017-14136.patch \ | 59 | file://CVE-2017-14136.patch \ |
60 | file://javagen.patch \ | ||
60 | file://protobuf.patch \ | 61 | file://protobuf.patch \ |
61 | " | 62 | " |
62 | PV = "3.3+git${SRCPV}" | 63 | PV = "3.3+git${SRCPV}" |