diff options
author | Fathi Boudra <fathi.boudra@linaro.org> | 2013-08-26 10:33:13 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-09-03 19:12:36 +0200 |
commit | 24fd2dc97991f972fed128c2529b6d149ec0f9da (patch) | |
tree | 3a974b7c1ba4afa8d0058dfcffbf1c295bad715b /meta-oe | |
parent | b79176adb306d6802d1219dfadfa7ffe080efb22 (diff) | |
download | meta-openembedded-24fd2dc97991f972fed128c2529b6d149ec0f9da.tar.gz |
acpica: fix parallel build
The compilation of the iasl utility fails when `make -j<N>' > 1. This
commit cleans up the rules in generate/unix/iasl such that a `make -j'
will succeed.
Signed-off-by: Andrew McDermott <andrew.mcdermott@linaro.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-extended/acpica/acpica_20130626.bb | 3 | ||||
-rw-r--r-- | meta-oe/recipes-extended/acpica/files/fix-parallel-build.patch | 80 |
2 files changed, 82 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/acpica/acpica_20130626.bb b/meta-oe/recipes-extended/acpica/acpica_20130626.bb index 65eadac0d8..bf38fa3a1e 100644 --- a/meta-oe/recipes-extended/acpica/acpica_20130626.bb +++ b/meta-oe/recipes-extended/acpica/acpica_20130626.bb | |||
@@ -17,7 +17,8 @@ PR="r1" | |||
17 | 17 | ||
18 | SRC_URI="https://acpica.org/sites/acpica/files/acpica-unix2-${PV}.tar.gz \ | 18 | SRC_URI="https://acpica.org/sites/acpica/files/acpica-unix2-${PV}.tar.gz \ |
19 | file://cross-compile.patch \ | 19 | file://cross-compile.patch \ |
20 | file://no-werror.patch" | 20 | file://no-werror.patch \ |
21 | file://fix-parallel-build.patch" | ||
21 | 22 | ||
22 | SRC_URI[md5sum] = "b7112b3deffef8fe25aac7810cc419a9" | 23 | SRC_URI[md5sum] = "b7112b3deffef8fe25aac7810cc419a9" |
23 | SRC_URI[sha256sum] = "888dda6227265c396a686624f971c51693c2bba84f24c634536234c8dca7b465" | 24 | SRC_URI[sha256sum] = "888dda6227265c396a686624f971c51693c2bba84f24c634536234c8dca7b465" |
diff --git a/meta-oe/recipes-extended/acpica/files/fix-parallel-build.patch b/meta-oe/recipes-extended/acpica/files/fix-parallel-build.patch new file mode 100644 index 0000000000..42e3fb14c8 --- /dev/null +++ b/meta-oe/recipes-extended/acpica/files/fix-parallel-build.patch | |||
@@ -0,0 +1,80 @@ | |||
1 | diff --git a/generate/unix/iasl/Makefile b/generate/unix/iasl/Makefile | ||
2 | index e9520ed..1b73d7a 100644 | ||
3 | --- a/generate/unix/iasl/Makefile | ||
4 | +++ b/generate/unix/iasl/Makefile | ||
5 | @@ -212,13 +212,10 @@ INTERMEDIATES = \ | ||
6 | MISC = \ | ||
7 | $(OBJDIR)/aslcompilerparse.h\ | ||
8 | $(OBJDIR)/aslcompiler.y.h\ | ||
9 | - $(OBJDIR)/aslcompilerparse.output\ | ||
10 | $(OBJDIR)/dtparserparse.h\ | ||
11 | $(OBJDIR)/dtparser.y.h\ | ||
12 | - $(OBJDIR)/dtparserparse.output\ | ||
13 | $(OBJDIR)/prparserparse.h\ | ||
14 | - $(OBJDIR)/prparser.y.h\ | ||
15 | - $(OBJDIR)/prparserparse.output | ||
16 | + $(OBJDIR)/prparser.y.h | ||
17 | |||
18 | # | ||
19 | # Flags specific to iASL compiler | ||
20 | @@ -240,21 +237,29 @@ include ../Makefile.rules | ||
21 | $(OBJDIR)/aslcompilerlex.c : $(ASL_COMPILER)/aslcompiler.l $(ASL_COMPILER)/aslsupport.l | ||
22 | $(LEX) $(LFLAGS) -PAslCompiler -o$@ $(ASL_COMPILER)/aslcompiler.l | ||
23 | |||
24 | -$(OBJDIR)/aslcompilerparse.c $(OBJDIR)/aslcompilerparse.h : $(ASL_COMPILER)/aslcompiler.y | ||
25 | +$(OBJDIR)/aslcompilerparse.c : $(ASL_COMPILER)/aslcompiler.y | ||
26 | $(YACC) $(YFLAGS) -pAslCompiler -o$@ $? | ||
27 | |||
28 | $(OBJDIR)/dtparserlex.c : $(ASL_COMPILER)/dtparser.l | ||
29 | $(LEX) $(LFLAGS) -PDtParser -o$@ $? | ||
30 | |||
31 | -$(OBJDIR)/dtparserparse.c $(OBJDIR)/dtparserparse.h : $(ASL_COMPILER)/dtparser.y | ||
32 | +$(OBJDIR)/dtparserparse.c : $(ASL_COMPILER)/dtparser.y | ||
33 | $(YACC) $(YFLAGS) -pDtParser -o$@ $? | ||
34 | |||
35 | $(OBJDIR)/prparserlex.c : $(ASL_COMPILER)/prparser.l | ||
36 | $(LEX) $(LFLAGS) -PPrParser -o$@ $? | ||
37 | |||
38 | -$(OBJDIR)/prparserparse.c $(OBJDIR)/prparserparse.h : $(ASL_COMPILER)/prparser.y | ||
39 | +$(OBJDIR)/prparserparse.c : $(ASL_COMPILER)/prparser.y | ||
40 | $(YACC) $(YFLAGS) -pPrParser -o$@ $? | ||
41 | |||
42 | +$(OBJDIR)/aslcompilerparse.h : $(OBJDIR)/aslcompilerparse.c | ||
43 | + touch $@ | ||
44 | + | ||
45 | +$(OBJDIR)/dtparserparse.h : $(OBJDIR)/dtparserparse.c | ||
46 | + touch $@ | ||
47 | + | ||
48 | +$(OBJDIR)/prparserparse.h: $(OBJDIR)/prparserparse.c | ||
49 | + touch $@ | ||
50 | |||
51 | # | ||
52 | # Rename the headers produced by bison/yacc | ||
53 | @@ -279,19 +284,21 @@ $(OBJDIR)/prparser.y.h: $(OBJDIR)/prparserparse.h | ||
54 | # by the utilities above and they are not necessarily ANSI C, etc. | ||
55 | # | ||
56 | $(OBJDIR)/aslcompilerlex.o : $(OBJDIR)/aslcompilerlex.c | ||
57 | - $(CC) -c $(CFLAGS) -Wall -o$@ $? | ||
58 | + $(CC) -c $(CFLAGS) -Wall -o$@ $< | ||
59 | |||
60 | $(OBJDIR)/aslcompilerparse.o : $(OBJDIR)/aslcompilerparse.c | ||
61 | - $(CC) -c $(CFLAGS) -Wall -o$@ $? | ||
62 | + $(CC) -c $(CFLAGS) -Wall -o$@ $< | ||
63 | |||
64 | $(OBJDIR)/dtparserlex.o : $(OBJDIR)/dtparserlex.c | ||
65 | - $(CC) -c $(CFLAGS) -Wall -o$@ $? | ||
66 | + $(CC) -c $(CFLAGS) -Wall -o$@ $< | ||
67 | |||
68 | $(OBJDIR)/dtparserparse.o : $(OBJDIR)/dtparserparse.c | ||
69 | - $(CC) -c $(CFLAGS) -Wall -o$@ $? | ||
70 | + $(CC) -c $(CFLAGS) -Wall -o$@ $< | ||
71 | |||
72 | $(OBJDIR)/prparserlex.o : $(OBJDIR)/prparserlex.c | ||
73 | - $(CC) -c $(CFLAGS) -Wall -o$@ $? | ||
74 | + $(CC) -c $(CFLAGS) -Wall -o$@ $< | ||
75 | |||
76 | $(OBJDIR)/prparserparse.o : $(OBJDIR)/prparserparse.c | ||
77 | - $(CC) -c $(CFLAGS) -Wall -o$@ $? | ||
78 | + $(CC) -c $(CFLAGS) -Wall -o$@ $< | ||
79 | + | ||
80 | +$(OBJECTS): $(HEADERS) | ||