diff options
author | Tuan Hoang <tuanhoanganh.dev@gmail.com> | 2019-02-23 11:24:51 +0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-02-22 21:30:39 -0800 |
commit | 1a2d6ee5e7882c0a47191c5e120bfcd229296289 (patch) | |
tree | afa0cff026795a579828715defe64ffb546a28b4 /meta-oe | |
parent | 479951ee994e25d8a03704b4186bce42e6684ac5 (diff) | |
download | meta-openembedded-1a2d6ee5e7882c0a47191c5e120bfcd229296289.tar.gz |
tk_8.6.9: Add tkConfig.sh in crossscript
Signed-off-by: Hoang Anh Tuan <tuanha@viosoft.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-devtools/tcltk/tk_8.6.9.bb | 25 |
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/tcltk/tk_8.6.9.bb b/meta-oe/recipes-devtools/tcltk/tk_8.6.9.bb index 9eec4bba7..459ae8253 100644 --- a/meta-oe/recipes-devtools/tcltk/tk_8.6.9.bb +++ b/meta-oe/recipes-devtools/tcltk/tk_8.6.9.bb | |||
@@ -50,6 +50,11 @@ do_install_append() { | |||
50 | ln -sf libtk${VER}.so ${D}${libdir}/libtk${VER}.so.0 | 50 | ln -sf libtk${VER}.so ${D}${libdir}/libtk${VER}.so.0 |
51 | oe_libinstall -so libtk${VER} ${D}${libdir} | 51 | oe_libinstall -so libtk${VER} ${D}${libdir} |
52 | ln -sf wish${VER} ${D}${bindir}/wish | 52 | ln -sf wish${VER} ${D}${bindir}/wish |
53 | |||
54 | sed -i "s;-L${B};-L${STAGING_LIBDIR};g" tkConfig.sh | ||
55 | sed -i "s;'${WORKDIR};'${STAGING_INCDIR};g" tkConfig.sh | ||
56 | install -d ${D}${bindir_crossscripts} | ||
57 | install -m 0755 tkConfig.sh ${D}${bindir_crossscripts} | ||
53 | } | 58 | } |
54 | 59 | ||
55 | PACKAGECONFIG ??= "xft" | 60 | PACKAGECONFIG ??= "xft" |
@@ -69,3 +74,23 @@ BBCLASSEXTEND = "native nativesdk" | |||
69 | 74 | ||
70 | # Fix the path in sstate | 75 | # Fix the path in sstate |
71 | SSTATE_SCAN_FILES += "*Config.sh" | 76 | SSTATE_SCAN_FILES += "*Config.sh" |
77 | |||
78 | inherit binconfig | ||
79 | |||
80 | SYSROOT_DIRS += "${bindir_crossscripts}" | ||
81 | |||
82 | # Fix some paths that might be used by Tcl extensions | ||
83 | BINCONFIG_GLOB = "*Config.sh" | ||
84 | |||
85 | # Cleanup host path from ${libdir}/tclConfig.sh and remove the | ||
86 | # ${bindir_crossscripts}/tclConfig.sh from target | ||
87 | PACKAGE_PREPROCESS_FUNCS += "tcl_package_preprocess" | ||
88 | tcl_package_preprocess() { | ||
89 | sed -i -e "s;${DEBUG_PREFIX_MAP};;g" \ | ||
90 | -e "s;-L${STAGING_LIBDIR};-L${libdir};g" \ | ||
91 | -e "s;${STAGING_INCDIR};${includedir};g" \ | ||
92 | -e "s;--sysroot=${RECIPE_SYSROOT};;g" \ | ||
93 | ${PKGD}${libdir}/tkConfig.sh | ||
94 | |||
95 | rm -f ${PKGD}${bindir_crossscripts}/tkConfig.sh | ||
96 | } | ||