diff options
author | Daniel Hilst Selli <danielhilst@gmail.com> | 2016-12-17 19:53:23 -0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-12-26 08:24:53 +0100 |
commit | 0df6263bf65ee632d2edf22e7ee69362e0518275 (patch) | |
tree | cda41575e901b6f55d1590f0e1f161027bb92436 /meta-oe | |
parent | d0a8298f52f3556a988ec68ac207191c145cae76 (diff) | |
download | meta-openembedded-0df6263bf65ee632d2edf22e7ee69362e0518275.tar.gz |
cxxtest: Add CxxTest framework to recipe-devtools.
>From cxxtest.org/guide.html:
CxxTest is a unit testing framework for C++ that is similar in spirit to JUnit,
CppUnit, and xUnit. CxxTest is easy to use because it does not require
precompiling a CxxTest testing library, it employs no advanced features of C++
(e.g. RTTI) and it supports a very flexible form of test discovery.
Signed-off-by: Daniel Hilst SellI <danielhilst@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-devtools/cxxtest/cxxtest_4.3.bb | 21 |
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/cxxtest/cxxtest_4.3.bb b/meta-oe/recipes-devtools/cxxtest/cxxtest_4.3.bb new file mode 100644 index 000000000..291501173 --- /dev/null +++ b/meta-oe/recipes-devtools/cxxtest/cxxtest_4.3.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | DESCRIPTION = "CxxTest is a unit testing framework for C++ that is similar in spirit to JUnit, CppUnit, and xUnit." | ||
2 | HOMEPAGE = "http://cxxtest.com/" | ||
3 | LICENSE = "LGPL-2.0" | ||
4 | SECTION = "devel" | ||
5 | |||
6 | SRC_URI = "http://downloads.sourceforge.net/project/cxxtest/cxxtest/${PV}/cxxtest-${PV}.tar.gz" | ||
7 | SRC_URI[md5sum] = "b3a24b3e1aad9acf6adac37f4c3f83ec" | ||
8 | SRC_URI[sha256sum] = "356d0f4810e8eb5c344147a0cca50fc0d84122c286e7644b61cb365c2ee22083" | ||
9 | LIC_FILES_CHKSUM = "file://${WORKDIR}/cxxtest-${PV}/COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02" | ||
10 | S = "${WORKDIR}/cxxtest-${PV}/python" | ||
11 | |||
12 | inherit distutils | ||
13 | |||
14 | do_install_append() { | ||
15 | install -d ${D}${includedir} | ||
16 | cp -a ../cxxtest ${D}${includedir} | ||
17 | sed '1c\ | ||
18 | #!/usr/bin/env python' -i ${D}${bindir}/cxxtestgen | ||
19 | } | ||
20 | |||
21 | BBCLASSEXTEND = "native nativesdk" | ||