diff options
author | Christian Hohnstaedt <christian@hohnstaedt.de> | 2023-01-29 10:32:39 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-01-29 08:59:56 -0800 |
commit | 0416a4e538725470d842410efe08c9fb332f6025 (patch) | |
tree | fb1d008dbe05a81a412817ed92d8426c01da5646 /meta-oe | |
parent | c289caf7766957710774f8617da4fb862ba90672 (diff) | |
download | meta-openembedded-0416a4e538725470d842410efe08c9fb332f6025.tar.gz |
libb64: reactivate BUFFERSIZE patch
Bug: http://sourceforge.net/tracker/?func=detail&atid=785907&aid=3591336&group_id=152942
is not fixed in the currently used upstream either.
Signed-off-by: Christian Hohnstaedt <christian@hohnstaedt.de>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-support/libb64/libb64/0002-use-BUFSIZ-as-buffer-size.patch | 57 | ||||
-rw-r--r-- | meta-oe/recipes-support/libb64/libb64_2.0.0.1.bb | 1 |
2 files changed, 58 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libb64/libb64/0002-use-BUFSIZ-as-buffer-size.patch b/meta-oe/recipes-support/libb64/libb64/0002-use-BUFSIZ-as-buffer-size.patch new file mode 100644 index 000000000..f2b8f599c --- /dev/null +++ b/meta-oe/recipes-support/libb64/libb64/0002-use-BUFSIZ-as-buffer-size.patch | |||
@@ -0,0 +1,57 @@ | |||
1 | From 9ec49389f56816d7ac2331296c03d147531a421a Mon Sep 17 00:00:00 2001 | ||
2 | From: Jakub Wilk <jwilk@debian.org> | ||
3 | Date: Sat, 27 Mar 2021 22:01:13 -0700 | ||
4 | Subject: [PATCH] use BUFSIZ as buffer size | ||
5 | |||
6 | Bug: http://sourceforge.net/tracker/?func=detail&atid=785907&aid=3591336&group_id=152942 | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | |||
11 | --- | ||
12 | include/b64/decode.h | 3 ++- | ||
13 | include/b64/encode.h | 3 ++- | ||
14 | 2 files changed, 4 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/include/b64/decode.h b/include/b64/decode.h | ||
17 | index b2362e5..8db1d09 100644 | ||
18 | --- a/include/b64/decode.h | ||
19 | +++ b/include/b64/decode.h | ||
20 | @@ -8,6 +8,7 @@ For details, see http://sourceforge.net/projects/libb64 | ||
21 | #ifndef BASE64_DECODE_H | ||
22 | #define BASE64_DECODE_H | ||
23 | |||
24 | +#include <cstdio> | ||
25 | #include <iostream> | ||
26 | |||
27 | namespace base64 | ||
28 | @@ -22,7 +23,7 @@ namespace base64 | ||
29 | base64_decodestate _state; | ||
30 | int _buffersize; | ||
31 | |||
32 | - decoder(int buffersize_in = BUFFERSIZE) | ||
33 | + decoder(int buffersize_in = BUFSIZ) | ||
34 | : _buffersize(buffersize_in) | ||
35 | { | ||
36 | base64_init_decodestate(&_state); | ||
37 | diff --git a/include/b64/encode.h b/include/b64/encode.h | ||
38 | index c1a5f88..644e4dd 100644 | ||
39 | --- a/include/b64/encode.h | ||
40 | +++ b/include/b64/encode.h | ||
41 | @@ -8,6 +8,7 @@ For details, see http://sourceforge.net/projects/libb64 | ||
42 | #ifndef BASE64_ENCODE_H | ||
43 | #define BASE64_ENCODE_H | ||
44 | |||
45 | +#include <cstdio> | ||
46 | #include <iostream> | ||
47 | |||
48 | namespace base64 | ||
49 | @@ -22,7 +23,7 @@ namespace base64 | ||
50 | base64_encodestate _state; | ||
51 | int _buffersize; | ||
52 | |||
53 | - encoder(int buffersize_in = BUFFERSIZE) | ||
54 | + encoder(int buffersize_in = BUFSIZ) | ||
55 | : _buffersize(buffersize_in) | ||
56 | { | ||
57 | base64_init_encodestate(&_state); | ||
diff --git a/meta-oe/recipes-support/libb64/libb64_2.0.0.1.bb b/meta-oe/recipes-support/libb64/libb64_2.0.0.1.bb index 8122419c5..6a1e7b75e 100644 --- a/meta-oe/recipes-support/libb64/libb64_2.0.0.1.bb +++ b/meta-oe/recipes-support/libb64/libb64_2.0.0.1.bb | |||
@@ -11,6 +11,7 @@ SRCREV = "ce864b17ea0e24a91e77c7dd3eb2d1ac4175b3f0" | |||
11 | 11 | ||
12 | SRC_URI = "git://github.com/libb64/libb64;protocol=https;branch=master \ | 12 | SRC_URI = "git://github.com/libb64/libb64;protocol=https;branch=master \ |
13 | file://0001-example-Do-not-run-the-tests.patch \ | 13 | file://0001-example-Do-not-run-the-tests.patch \ |
14 | file://0002-use-BUFSIZ-as-buffer-size.patch \ | ||
14 | file://0001-Makefile-fix-parallel-build-of-examples.patch \ | 15 | file://0001-Makefile-fix-parallel-build-of-examples.patch \ |
15 | file://0001-examples-Use-proper-function-prototype-for-main.patch \ | 16 | file://0001-examples-Use-proper-function-prototype-for-main.patch \ |
16 | " | 17 | " |