summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-03-04 19:01:15 -0800
committerArmin Kuster <akuster808@gmail.com>2018-03-16 19:44:53 -0700
commitf0f65804de8cfb24ed93ecb6d3c09d46b3669241 (patch)
tree55441a945cf5d4d3543950428d5bb55ae4ffa2ec /meta-oe
parent3543bdb70c7f27295783f8f73caef5965759aa22 (diff)
downloadmeta-openembedded-f0f65804de8cfb24ed93ecb6d3c09d46b3669241.tar.gz
libyui-ncurses: Fix build with musl _nl_msg_cat_cntr in not available
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-use-_nl_msg_cat_cntr-only-with-glibc.patch40
-rw-r--r--meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb1
2 files changed, 41 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-use-_nl_msg_cat_cntr-only-with-glibc.patch b/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-use-_nl_msg_cat_cntr-only-with-glibc.patch
new file mode 100644
index 000000000..8e3774c1a
--- /dev/null
+++ b/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-use-_nl_msg_cat_cntr-only-with-glibc.patch
@@ -0,0 +1,40 @@
1From 4b84f243a70a8c07f6a38dad3c9411fa707f25c9 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 4 Mar 2018 17:08:43 -0800
4Subject: [PATCH] use _nl_msg_cat_cntr only with glibc
5
6The musl libc provides libintl (similar to glibc)
7but does not use the same internals,
8so even though we are using the GNU gettext
9the libintl included with the libc does not define
10_nl_msg_cat_cntr and it does not need to.
11
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14Upstream-Status: Pending
15
16 src/NCi18n.h | 3 ++-
17 1 file changed, 2 insertions(+), 1 deletion(-)
18
19diff --git a/src/NCi18n.h b/src/NCi18n.h
20index 165b0e7..bfc4ed7 100644
21--- a/src/NCi18n.h
22+++ b/src/NCi18n.h
23@@ -59,12 +59,13 @@ inline void setTextdomain( const char * domain )
24 bindtextdomain( domain, YSettings::localeDir().c_str() );
25 bind_textdomain_codeset( domain, "UTF-8" );
26 textdomain( domain );
27-
28+#if defined(__GLIBC__)
29 // Make change known
30 {
31 extern int _nl_msg_cat_cntr;
32 ++_nl_msg_cat_cntr;
33 }
34+#endif
35 }
36
37
38--
392.16.2
40
diff --git a/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb b/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb
index f60c85668..578c71301 100644
--- a/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb
+++ b/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb
@@ -5,6 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING.lgpl-3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
5" 5"
6 6
7SRC_URI = "git://github.com/libyui/libyui-ncurses.git \ 7SRC_URI = "git://github.com/libyui/libyui-ncurses.git \
8 file://0001-use-_nl_msg_cat_cntr-only-with-glibc.patch \
8 " 9 "
9 10
10SRC_URI_append_class-target = " file://0001-Fix-the-error-of-can-t-find-header-file.patch" 11SRC_URI_append_class-target = " file://0001-Fix-the-error-of-can-t-find-header-file.patch"