summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorLi xin <lixin.fnst@cn.fujitsu.com>2015-01-20 16:02:18 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-01-28 09:52:51 +0100
commitb3cff5d52c53aed5a6ae50dc492b9543ab5e8b7f (patch)
tree085e9225bed3eea1c8a153de5348bf68af7d8225 /meta-oe
parent9b2fde424709828d3f42dd15d5b7595099642ea0 (diff)
downloadmeta-openembedded-b3cff5d52c53aed5a6ae50dc492b9543ab5e8b7f.tar.gz
system-config-keyboard: add new recipe
a graphical user interface that allows the user to change the default keyboard of the system. Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/system-config-keyboard/system-config-keyboard_1.4.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/system-config-keyboard/system-config-keyboard_1.4.0.bb b/meta-oe/recipes-support/system-config-keyboard/system-config-keyboard_1.4.0.bb
new file mode 100644
index 000000000..eaca96dca
--- /dev/null
+++ b/meta-oe/recipes-support/system-config-keyboard/system-config-keyboard_1.4.0.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "a graphical user interface that allows the user to \
2change the default keyboard of the system"
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5SRC_URI = "https://fedorahosted.org/releases/s/y/${BPN}/${BP}.tar.bz2"
6SRC_URI[md5sum] = "c267db0ee7a2131ba418399dc17f9e72"
7SRC_URI[sha256sum] = "218c883e4e2bfcc82bfe07e785707b5c2ece28df772f2155fd044b9bb1614284"
8inherit python-dir
9DEPENDS = "intltool"
10
11EXTRA_OEMAKE = " \
12 PYTHON='${STAGING_BINDIR_NATIVE}'/python-native/python \
13 PYTHON_SITELIB=${PYTHON_SITEPACKAGES_DIR} \
14"
15do_install() {
16 oe_runmake 'DESTDIR=${D}' install
17}
18
19do_install_append_class-native() {
20 rm -rf ${D}/usr
21}
22
23FILES_${PN} += " \
24 ${libdir}/python${PYTHON_BASEVERSION}/* \
25 ${datadir}/* \
26"
27BBCLASSEXTEND = "native"