summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMartin Hundebøll <mnhu@prevas.dk>2018-01-26 13:35:58 +0100
committerArmin Kuster <akuster808@gmail.com>2018-03-12 10:02:03 -0700
commit5fe43eb489adc6431ac6be91deb944f627cb64e2 (patch)
tree35ea2f6a06b6bbde12a4f799f17ca197f99d801c /meta-oe
parent790ddac5a9f2d4a40012551eb3b7a0743c2975e6 (diff)
downloadmeta-openembedded-5fe43eb489adc6431ac6be91deb944f627cb64e2.tar.gz
libgpiod: fix packaging of tools
The default packaging adds files from ${bindir} to the primary package, so that following packages don't see any files in ${bindir}. This causes the libgpiod-tools package to empty, as it is appended (+=) to PACKAGES. Change the assignment to PACKAGES to a prepend (=+) to populate the libgpiod-tools package with the gpio{detect,find,get,info,mon,set} executables. To avoid missing tools for existing installations of libgpiod, the libgpiod-tools package is setup as a recommendation by libgpiod when the tools package config is enabled. Signed-off-by: Martin Hundebøll <mnhu@prevas.dk> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/libgpiod/libgpiod.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod.bb b/meta-oe/recipes-support/libgpiod/libgpiod.bb
index 6aa27ad57..b2e3bae69 100644
--- a/meta-oe/recipes-support/libgpiod/libgpiod.bb
+++ b/meta-oe/recipes-support/libgpiod/libgpiod.bb
@@ -18,6 +18,9 @@ PACKAGECONFIG ?= "tools"
18PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev" 18PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev"
19PACKAGECONFIG[tools] = "--enable-tools,--disable-tools," 19PACKAGECONFIG[tools] = "--enable-tools,--disable-tools,"
20 20
21PACKAGES += " ${PN}-tools" 21PACKAGES =+ " ${PN}-tools"
22 22
23FILES_${PN}-tools = "${bindir}/*" 23FILES_${PN}-tools = "${bindir}/*"
24
25RRECOMMENDS_TOOLS = "${@bb.utils.contains('PACKAGECONFIG', 'tools', '${PN}-tools', '',d)}"
26RRECOMMENDS_${PN} += "${RRECOMMENDS_TOOLS}"