summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2017-02-28 16:54:04 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-04 12:38:53 +0100
commita4835a616b33a2bfe6943dff37327f6858e0fbe8 (patch)
tree5948c3e48c25004166af34d642c6edd0d9d5abbb /meta-oe
parentfcd985180b79a8bed177ec9c73d0ab3b25a15eb8 (diff)
downloadmeta-openembedded-a4835a616b33a2bfe6943dff37327f6858e0fbe8.tar.gz
syslog-ng: Run autoreconf twice to avoid problems with libtool
syslog-ng has sub-projects with their own autotools configurations. Something has been messed up after the switch to RSS and now it requires autoreconf to be run twice to fully update all files. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/syslog-ng/syslog-ng.inc11
-rw-r--r--meta-oe/recipes-support/syslog-ng/syslog-ng_3.6.4.bb2
2 files changed, 10 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
index 21d174877..a5e1bfe48 100644
--- a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
+++ b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
@@ -22,7 +22,7 @@ SRC_URI = "http://www.balabit.com/downloads/files/syslog-ng/sources/${PV}/source
22 file://configure.ac-add-option-enable-thread-tls-to-manage-.patch \ 22 file://configure.ac-add-option-enable-thread-tls-to-manage-.patch \
23" 23"
24 24
25inherit autotools systemd pkgconfig update-rc.d 25inherit autotools gettext systemd pkgconfig update-rc.d
26 26
27EXTRA_OECONF = " \ 27EXTRA_OECONF = " \
28 --enable-dynamic-linking \ 28 --enable-dynamic-linking \
@@ -55,6 +55,15 @@ PACKAGECONFIG[json] = "--enable-json,--disable-json,json-c,"
55PACKAGECONFIG[tcp-wrapper] = "--enable-tcp-wrapper,--disable-tcp-wrapper,tcp-wrappers," 55PACKAGECONFIG[tcp-wrapper] = "--enable-tcp-wrapper,--disable-tcp-wrapper,tcp-wrappers,"
56PACKAGECONFIG[geoip] = "--enable-geoip,--disable-geoip,geoip," 56PACKAGECONFIG[geoip] = "--enable-geoip,--disable-geoip,geoip,"
57 57
58do_configure_prepend() {
59 olddir=$(pwd)
60 cd ${AUTOTOOLS_SCRIPT_PATH}
61
62 ACLOCAL="$ACLOCAL" autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} -I ${S}/m4 ${ACLOCALEXTRAPATH} || die "extra autoreconf execution failed."
63
64 cd $olddir
65}
66
58do_install_prepend() { 67do_install_prepend() {
59 sed -i -e 's,@SBINDIR@,${sbindir},g' ${S}/contrib/systemd/*.service 68 sed -i -e 's,@SBINDIR@,${sbindir},g' ${S}/contrib/systemd/*.service
60 sed -i -e 's,@LOCALSTATEDIR@,${localstatedir},g' ${S}/contrib/systemd/*.service 69 sed -i -e 's,@LOCALSTATEDIR@,${localstatedir},g' ${S}/contrib/systemd/*.service
diff --git a/meta-oe/recipes-support/syslog-ng/syslog-ng_3.6.4.bb b/meta-oe/recipes-support/syslog-ng/syslog-ng_3.6.4.bb
index bee1e19e4..73609af10 100644
--- a/meta-oe/recipes-support/syslog-ng/syslog-ng_3.6.4.bb
+++ b/meta-oe/recipes-support/syslog-ng/syslog-ng_3.6.4.bb
@@ -13,5 +13,3 @@ SRC_URI += " \
13 13
14SRC_URI[md5sum] = "e9f401615e92e5eb27396c995c1446ba" 14SRC_URI[md5sum] = "e9f401615e92e5eb27396c995c1446ba"
15SRC_URI[sha256sum] = "7be11df31ac7d716f1f952e22b5ae8e2049edd633a41b223776a853d9106f4e7" 15SRC_URI[sha256sum] = "7be11df31ac7d716f1f952e22b5ae8e2049edd633a41b223776a853d9106f4e7"
16
17PNBLACKLIST[syslog-ng] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130631/"