summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2016-07-18 09:06:05 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-07-29 11:00:56 +0200
commit898b3977afec283c456c970a48d654c74f128d61 (patch)
tree20530ac4f9fec302e537a93a1b315aee1c686ee3 /meta-oe
parent00f6dc9cdb991b80ddb6eee56054e58cbb057eb2 (diff)
downloadmeta-openembedded-898b3977afec283c456c970a48d654c74f128d61.tar.gz
tokyocabinet: add recipe
tokyocabinet is a modern implementation of DBM. And we will use it as default database for cfengine. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/tokyocabinet/tokyocabinet/remove-hard-coded-include-and-lib-paths.patch43
-rw-r--r--meta-oe/recipes-support/tokyocabinet/tokyocabinet_1.4.48.bb27
2 files changed, 70 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/tokyocabinet/tokyocabinet/remove-hard-coded-include-and-lib-paths.patch b/meta-oe/recipes-support/tokyocabinet/tokyocabinet/remove-hard-coded-include-and-lib-paths.patch
new file mode 100644
index 000000000..a8ab23de7
--- /dev/null
+++ b/meta-oe/recipes-support/tokyocabinet/tokyocabinet/remove-hard-coded-include-and-lib-paths.patch
@@ -0,0 +1,43 @@
1Upstream-Status: Inappropriate [embedded specific]
2
3There are hardcode paths in configure.in eg: /usr/include, $HOME/include etc.
4These paths will cause Makefile to search host path when doing cross-compiling.
5and bitbake will prompt this as an error. So remove them.
6
7Signed-off-by: Song.Li <Song.Li@windriver.com>
8Signed-off-by: Kai Kang <kai.kang@windriver.com>
9---
10 configure.in | 10 ++--------
11 1 file changed, 2 insertions(+), 8 deletions(-)
12
13diff --git a/configure.in b/configure.in
14index bcfd5bc..5b24947 100644
15--- a/configure.in
16+++ b/configure.in
17@@ -32,21 +32,15 @@ MYPCFILES="tokyocabinet.pc"
18
19 # Building flags
20 MYCFLAGS="-std=c99 -Wall -fPIC -fsigned-char -O2"
21-MYCPPFLAGS="-I. -I\$(INCLUDEDIR) -I$HOME/include -I/usr/local/include"
22+MYCPPFLAGS="-I."
23 MYCPPFLAGS="$MYCPPFLAGS -DNDEBUG -D_GNU_SOURCE=1 -D_REENTRANT -D__EXTENSIONS__"
24-MYLDFLAGS="-L. -L\$(LIBDIR) -L$HOME/lib -L/usr/local/lib"
25+MYLDFLAGS="-L."
26 MYCMDLDFLAGS=""
27 MYRUNPATH="\$(LIBDIR)"
28 MYLDLIBPATHENV="LD_LIBRARY_PATH"
29 MYPOSTCMD="true"
30
31 # Building paths
32-PATH="$PATH:$HOME/bin:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin"
33-PATH="$PATH:/opt/SUNWspro/bin:/usr/ccs/bin:/usr/xpg4/bin:/usr/xpg6/bin:/usr/ucb"
34-CPATH="$HOME/include:/usr/local/include:$CPATH"
35-LIBRARY_PATH="$HOME/lib:/usr/local/lib:$LIBRARY_PATH"
36-LD_LIBRARY_PATH="$HOME/lib:/usr/local/lib:$LD_LIBRARY_PATH"
37-PKG_CONFIG_PATH="$HOME/lib/pkgconfig:/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH"
38 export PATH CPATH LIBRARY_PATH LD_LIBRARY_PATH PKG_CONFIG_PATH
39
40
41--
421.7.9.5
43
diff --git a/meta-oe/recipes-support/tokyocabinet/tokyocabinet_1.4.48.bb b/meta-oe/recipes-support/tokyocabinet/tokyocabinet_1.4.48.bb
new file mode 100644
index 000000000..9f75cf047
--- /dev/null
+++ b/meta-oe/recipes-support/tokyocabinet/tokyocabinet_1.4.48.bb
@@ -0,0 +1,27 @@
1#
2# Copyright (C) 2012 - 2016 Wind River Systems, Inc.
3#
4SUMMARY = "A modern implementation of DBM"
5
6DESCRIPTION = "Tokyo Cabinet is a library of routines for managing a database. \
7The database is a simple data file containing records, each is a pair of a key \
8and a value. Every key and value is serial bytes with variable length. \
9Both binary data and character string can be used as a key and a value. \
10There is neither concept of data tables nor data types. \
11Records are organized in hash table, B+ tree, or fixed-length array."
12
13HOMEPAGE = "http://fallabs.com/tokyocabinet/"
14
15LICENSE = "GPLv2"
16LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
17
18SRC_URI = "http://fallabs.com/tokyocabinet/${BP}.tar.gz \
19 file://remove-hard-coded-include-and-lib-paths.patch \
20"
21
22SRC_URI[md5sum] = "fd03df6965f8f56dd5b8518ca43b4f5e"
23SRC_URI[sha256sum] = "a003f47c39a91e22d76bc4fe68b9b3de0f38851b160bbb1ca07a4f6441de1f90"
24
25DEPENDS = "bzip2 zlib"
26
27inherit autotools-brokensep