summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-07-15 10:04:48 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-07-29 11:00:55 +0200
commit4c032282d828347e9e57a2bf71eddf3cbfca4d53 (patch)
treedefe477d1d973cf9b3e28c328265d2295c42fe95 /meta-oe
parent74466fce309eef882310635b25aea9a84dbad381 (diff)
downloadmeta-openembedded-4c032282d828347e9e57a2bf71eddf3cbfca4d53.tar.gz
augeas: Move from oe-core
augeas is being removed from oe-core as nothing there uses or tests it. Move the recipe to meta-oe as there's still one dependency in meta-openembedded (netcf in meta-networking). Also upgrade to 1.5.0: no recipe changes needed. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/augeas/augeas.inc30
-rw-r--r--meta-oe/recipes-support/augeas/augeas/0001-Unset-need_charset_alias-when-building-for-musl.patch30
-rw-r--r--meta-oe/recipes-support/augeas/augeas/add-missing-argz-conditional.patch20
-rw-r--r--meta-oe/recipes-support/augeas/augeas/sepbuildfix.patch22
-rw-r--r--meta-oe/recipes-support/augeas/augeas_1.5.0.bb4
5 files changed, 106 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/augeas/augeas.inc b/meta-oe/recipes-support/augeas/augeas.inc
new file mode 100644
index 000000000..23d12cadf
--- /dev/null
+++ b/meta-oe/recipes-support/augeas/augeas.inc
@@ -0,0 +1,30 @@
1SUMMARY = "Augeas configuration API"
2HOMEPAGE = "http://augeas.net/"
3BUGTRACKER = "https://fedorahosted.org/augeas/report/1"
4
5LICENSE = "LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=bbb461211a33b134d42ed5ee802b37ff"
7
8SRC_URI = "http://download.augeas.net/${BP}.tar.gz \
9 file://add-missing-argz-conditional.patch \
10 file://sepbuildfix.patch \
11 file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
12 "
13
14DEPENDS = "readline libxml2"
15
16inherit autotools pkgconfig
17
18PACKAGES =+ "${PN}-lenses lib${BPN}"
19
20FILES_${PN}-lenses = "${datadir}/augeas/lenses"
21FILES_lib${BPN} = "${libdir}/lib*${SOLIBS}"
22
23RDEPENDS_lib${BPN} += "${PN}-lenses"
24RRECOMMENDS_lib${BPN} += "${PN}"
25
26LEAD_SONAME = "libaugeas.so"
27
28do_install_append() {
29 rm -fr ${D}${datadir}/vim
30}
diff --git a/meta-oe/recipes-support/augeas/augeas/0001-Unset-need_charset_alias-when-building-for-musl.patch b/meta-oe/recipes-support/augeas/augeas/0001-Unset-need_charset_alias-when-building-for-musl.patch
new file mode 100644
index 000000000..9a19876aa
--- /dev/null
+++ b/meta-oe/recipes-support/augeas/augeas/0001-Unset-need_charset_alias-when-building-for-musl.patch
@@ -0,0 +1,30 @@
1From b9565dc2fe0c4f7daaec91b7e83bc7313dee2f4a Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 13 Apr 2015 17:02:13 -0700
4Subject: [PATCH] Unset need_charset_alias when building for musl
5
6localcharset uses ac_cv_gnu_library_2_1 from glibc21.m4
7which actually shoudl be fixed in gnulib and then all downstream
8projects will get it eventually. For now we apply the fix to
9coreutils
10
11Upstream-Status: Pending
12
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 lib/gnulib.mk | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18Index: augeas-1.2.0/gnulib/lib/Makefile.am
19===================================================================
20--- augeas-1.2.0.orig/gnulib/lib/Makefile.am
21+++ augeas-1.2.0/gnulib/lib/Makefile.am
22@@ -463,7 +463,7 @@ install-exec-localcharset: all-local
23 case '$(host_os)' in \
24 darwin[56]*) \
25 need_charset_alias=true ;; \
26- darwin* | cygwin* | mingw* | pw32* | cegcc*) \
27+ darwin* | cygwin* | mingw* | pw32* | cegcc* | linux-musl*) \
28 need_charset_alias=false ;; \
29 *) \
30 need_charset_alias=true ;; \
diff --git a/meta-oe/recipes-support/augeas/augeas/add-missing-argz-conditional.patch b/meta-oe/recipes-support/augeas/augeas/add-missing-argz-conditional.patch
new file mode 100644
index 000000000..abbdbaa63
--- /dev/null
+++ b/meta-oe/recipes-support/augeas/augeas/add-missing-argz-conditional.patch
@@ -0,0 +1,20 @@
1Add missing GL_GENERATE_ARGZ_H conditional
2
3- GL_GENERATE_ARGZ_H is used in gnulib/lib/Makefile.am
4
5Upstream-Status: Pending
6Signed-off-by: Constantin Musca <constantinx.musca@intel.com>
7
8Index: augeas-1.0.0/configure.ac
9===================================================================
10--- augeas-1.0.0.orig/configure.ac
11+++ augeas-1.0.0/configure.ac
12@@ -55,6 +55,8 @@ AC_ARG_WITH([failmalloc],
13
14 AM_CONDITIONAL([WITH_FAILMALLOC], [test x$with_failmalloc != xno])
15
16+AM_CONDITIONAL([GL_GENERATE_ARGZ_H], [test -n "$ARGZ_H"])
17+
18 dnl --enable-debug=(yes|no)
19 AC_ARG_ENABLE([debug],
20 [AC_HELP_STRING([--enable-debug=no/yes],
diff --git a/meta-oe/recipes-support/augeas/augeas/sepbuildfix.patch b/meta-oe/recipes-support/augeas/augeas/sepbuildfix.patch
new file mode 100644
index 000000000..b82a3ee2c
--- /dev/null
+++ b/meta-oe/recipes-support/augeas/augeas/sepbuildfix.patch
@@ -0,0 +1,22 @@
1Ensure that builds in separate builddirs (${B} != ${S}) correctly install the
2lenses files.
3
4Upstream-Status: Pending
5
6RP 2013/4/17
7
8Index: augeas-1.0.0/Makefile.am
9===================================================================
10--- augeas-1.0.0.orig/Makefile.am 2012-11-02 15:20:11.000000000 +0000
11+++ augeas-1.0.0/Makefile.am 2013-04-17 10:36:24.033400125 +0000
12@@ -5,8 +5,8 @@
13 lensdir=$(datadir)/augeas/lenses/dist
14 lenstestdir=$(datadir)/augeas/lenses/dist/tests
15
16-dist_lens_DATA=$(wildcard lenses/*.aug)
17-dist_lenstest_DATA=$(wildcard lenses/tests/*.aug)
18+dist_lens_DATA=$(wildcard $(top_srcdir)/lenses/*.aug)
19+dist_lenstest_DATA=$(wildcard $(top_srcdir)lenses/tests/*.aug)
20
21 EXTRA_DIST=augeas.spec build/aux/move-if-change Makefile.am HACKING
22
diff --git a/meta-oe/recipes-support/augeas/augeas_1.5.0.bb b/meta-oe/recipes-support/augeas/augeas_1.5.0.bb
new file mode 100644
index 000000000..c4f62e747
--- /dev/null
+++ b/meta-oe/recipes-support/augeas/augeas_1.5.0.bb
@@ -0,0 +1,4 @@
1require augeas.inc
2
3SRC_URI[md5sum] = "01190e455c513124a2dae29a1182c113"
4SRC_URI[sha256sum] = "223bb6e6fe3e9e92277dafd5d34e623733eb969a72a382998d204feab253f73f"