summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorFlorian Boor <florian@kernelconcepts.de>2015-03-02 11:33:47 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-03-06 07:33:40 +0100
commit308aeec34f79282691e1add962f79810e2374401 (patch)
tree5c6453ef583aa87a85b50c74b46a131518c81edb /meta-oe
parent75212d36f5cc0002ef82c945da8ac693323b32e5 (diff)
downloadmeta-openembedded-308aeec34f79282691e1add962f79810e2374401.tar.gz
fltk: Replace use of freetype-config with pkg-config Drop blacklist entry
Tested building for MIPS 32bit QEMU Signed-off-by: Florian Boor <florian@kernelconcepts.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/fltk/fltk-1.1.10/fltk-no-freetype-config.patch18
-rw-r--r--meta-oe/recipes-support/fltk/fltk_1.1.10.bb7
2 files changed, 21 insertions, 4 deletions
diff --git a/meta-oe/recipes-support/fltk/fltk-1.1.10/fltk-no-freetype-config.patch b/meta-oe/recipes-support/fltk/fltk-1.1.10/fltk-no-freetype-config.patch
new file mode 100644
index 000000000..5dbb0547d
--- /dev/null
+++ b/meta-oe/recipes-support/fltk/fltk-1.1.10/fltk-no-freetype-config.patch
@@ -0,0 +1,18 @@
1--- a/configure.in.orig 2015-03-01 16:00:35.956432907 +0100
2+++ b/configure.in 2015-03-01 16:04:23.269580093 +0100
3@@ -865,11 +865,11 @@
4 AC_ARG_ENABLE(xft, [ --enable-xft turn on Xft support [default=no]])
5
6 if test x$enable_xft = xyes; then
7- AC_PATH_PROG(FTCONFIG,freetype-config)
8+ AC_PATH_PROG(PKGCONFIG,pkg-config)
9
10- if test "x$FTCONFIG" != x; then
11- CPPFLAGS="`$FTCONFIG --cflags` $CPPFLAGS"
12- CXXFLAGS="`$FTCONFIG --cflags` $CXXFLAGS"
13+ if test "x$PKGCONFIG" != x; then
14+ CPPFLAGS="`$PKGCONFIG --cflags xft` $CPPFLAGS"
15+ CXXFLAGS="`$PKGCONFIG --cflags xft` $CXXFLAGS"
16
17 AC_CHECK_HEADER(X11/Xft/Xft.h,
18 AC_CHECK_LIB(Xft, XftDrawCreate,
diff --git a/meta-oe/recipes-support/fltk/fltk_1.1.10.bb b/meta-oe/recipes-support/fltk/fltk_1.1.10.bb
index 4fd3645c6..3229ed0e7 100644
--- a/meta-oe/recipes-support/fltk/fltk_1.1.10.bb
+++ b/meta-oe/recipes-support/fltk/fltk_1.1.10.bb
@@ -6,19 +6,18 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=1c0b73db66884b6a925e727400315130"
6 6
7DEPENDS = "alsa-lib zlib jpeg libpng libxext libxft" 7DEPENDS = "alsa-lib zlib jpeg libpng libxext libxft"
8 8
9PR = "r1" 9PR = "r2"
10
11PNBLACKLIST[fltk] ?= "broken: still uses /usr/bin/freetype-config"
12 10
13SRC_URI = "ftp://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/fltk/${PV}/fltk-${PV}-source.tar.bz2 \ 11SRC_URI = "ftp://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/fltk/${PV}/fltk-${PV}-source.tar.bz2 \
14 file://disable_test.patch \ 12 file://disable_test.patch \
15 file://dso-fix.patch \ 13 file://dso-fix.patch \
16 file://libpng15.patch \ 14 file://libpng15.patch \
15 file://fltk-no-freetype-config.patch \
17" 16"
18 17
19S = "${WORKDIR}/fltk-${PV}" 18S = "${WORKDIR}/fltk-${PV}"
20 19
21inherit lib_package autotools-brokensep binconfig 20inherit lib_package autotools-brokensep binconfig pkgconfig
22 21
23TARGET_CC_ARCH += "${LDFLAGS} -DXFT_MAJOR=2" 22TARGET_CC_ARCH += "${LDFLAGS} -DXFT_MAJOR=2"
24 23