summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-10-11 10:03:22 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-11 10:03:22 +0200
commit2c7210ea29f890ee8534355cb6fb280e04fb0c66 (patch)
treedef2f20f843110cce9d74705c44cce66a866d58b /meta-oe
parent0f52cc583d829e4df410bbdcd8d487b2f21ccc1b (diff)
downloadmeta-openembedded-2c7210ea29f890ee8534355cb6fb280e04fb0c66.tar.gz
libsdl-mixer 1.2.11: import from OE classic
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer/configure.patch22
-rw-r--r--meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer/fix-flac-madness.diff28
-rw-r--r--meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer_1.2.11.bb38
3 files changed, 88 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer/configure.patch b/meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer/configure.patch
new file mode 100644
index 000000000..7cc69e057
--- /dev/null
+++ b/meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer/configure.patch
@@ -0,0 +1,22 @@
1Index: SDL_mixer-1.2.11/configure.in
2===================================================================
3--- SDL_mixer-1.2.11.orig/configure.in 2011-02-15 11:54:23.929086120 +0100
4+++ SDL_mixer-1.2.11/configure.in 2011-02-15 11:56:53.745736645 +0100
5@@ -1,6 +1,5 @@
6 dnl Process this file with autoconf to produce a configure script.
7 AC_INIT(README)
8-AC_CONFIG_AUX_DIRS($srcdir/build-scripts)
9
10 dnl Set various version strings - taken gratefully from the GTk sources
11
12@@ -40,10 +39,6 @@
13 AC_SUBST(LT_REVISION)
14 AC_SUBST(LT_AGE)
15
16-dnl Detect the canonical build and host environments
17-AC_CONFIG_AUX_DIRS($srcdir/build-scripts)
18-dnl AC_CANONICAL_HOST
19-
20 dnl Check for tools
21 AC_PROG_LIBTOOL
22 AC_PROG_CC
diff --git a/meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer/fix-flac-madness.diff b/meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer/fix-flac-madness.diff
new file mode 100644
index 000000000..48fe88ef4
--- /dev/null
+++ b/meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer/fix-flac-madness.diff
@@ -0,0 +1,28 @@
1--- /tmp/configure.in 2009-12-02 16:18:33.000000000 +0100
2+++ SDL_mixer-1.2.11/configure.in 2009-12-02 16:20:02.000000000 +0100
3@@ -413,24 +413,7 @@
4 [], [enable_music_flac_shared=yes])
5 if test x$enable_music_flac = xyes; then
6 AC_CHECK_HEADER([FLAC/export.h], [have_flac_export=yes])
7- if test x$have_flac_export = xyes; then
8- LIBS_SAVED="$LIBS"
9- LIBS="-lFLAC"
10- AC_MSG_CHECKING([for libflac so-name version >= $libflac_ver])
11- AC_TRY_RUN([
12-#include "FLAC/export.h"
13-#include "stdio.h"
14-int main( int argc, char *argv[] ) {
15-#if defined(FLAC_API_VERSION_CURRENT) && (FLAC_API_VERSION_CURRENT >= $libflac_ver)
16- return 0;
17-#else
18- return 1;
19-#endif
20-}
21-], have_flac_ver=yes, have_flac_ver=no)
22- LIBS="$LIBS_SAVED"
23- AC_MSG_RESULT($have_flac_ver)
24- fi
25+ have_flac_ver=yes
26
27 if test x$have_flac_ver = xyes; then
28 AC_CHECK_HEADER([FLAC/stream_decoder.h], [have_flac_hdr=yes])
diff --git a/meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer_1.2.11.bb b/meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer_1.2.11.bb
new file mode 100644
index 000000000..bccbc50fc
--- /dev/null
+++ b/meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer_1.2.11.bb
@@ -0,0 +1,38 @@
1DESCRIPTION = "Simple DirectMedia Layer mixer library."
2SECTION = "libs"
3DEPENDS = "virtual/libsdl flac libmikmod libvorbis ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad', d)}"
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=27818cd7fd83877a8e3ef82b82798ef4"
6
7SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz \
8 file://fix-flac-madness.diff \
9 file://configure.patch \
10 "
11SRC_URI[md5sum] = "65ada3d997fe85109191a5fb083f248c"
12SRC_URI[sha256sum] = "86145ac39cac6d2c6169c226f937648dca5e89dcd828751763dd174fa9af9cf9"
13
14S = "${WORKDIR}/SDL_mixer-${PV}"
15
16inherit autotools
17
18EXTRA_AUTORECONF += "--include=acinclude"
19EXTRA_OECONF = "--disable-music-mp3 --enable-music-ogg --enable-music-ogg-tremor ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '--enable-music-mp3-mad-gpl', d)} LIBS=-L${STAGING_LIBDIR}"
20
21do_configure () {
22 # Remove old libtool macros.
23 MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
24 for i in ${MACROS}; do
25 rm -f acinclude/$i
26 done
27 cp build-scripts/* . || true
28 rm -rf build-scripts/
29 export SYSROOT=$PKG_CONFIG_SYSROOT_DIR
30
31 autotools_do_configure
32
33 rm config.log
34 for i in $(find -name "Makefile") ; do
35 sed -i -e 's:-L/usr/lib:-L${STAGING_LIBDIR}:g' $i
36 done
37}
38