summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-09-07 22:33:20 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-13 11:13:21 +0200
commit02009e21146c369506684a94d2ab7710874aab65 (patch)
tree3009f02c54f605fb8fdd6a3e4f2f1d3c142572b0 /meta-oe
parentd50aee5e41361a7a89e3e901b7e5aaa56532a8a2 (diff)
downloadmeta-openembedded-02009e21146c369506684a94d2ab7710874aab65.tar.gz
sblim-sfcc: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc/0001-cimxml-Include-sys-select.h-for-fd_set.patch37
-rw-r--r--meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc_2.2.8.bb4
2 files changed, 40 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc/0001-cimxml-Include-sys-select.h-for-fd_set.patch b/meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc/0001-cimxml-Include-sys-select.h-for-fd_set.patch
new file mode 100644
index 000000000..19e50ec79
--- /dev/null
+++ b/meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc/0001-cimxml-Include-sys-select.h-for-fd_set.patch
@@ -0,0 +1,37 @@
1From 9981542cb443cdaf9134500b78fe7eda9f99861f Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 7 Sep 2017 21:43:26 -0700
4Subject: [PATCH] cimxml: Include sys/select.h for fd_set
5
6define __SOCKADDR_ARG on linux when libc != glibc
7
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9---
10Upstream-Status: Pending
11 backend/cimxml/indicationlistener.c | 3 ++-
12 1 file changed, 2 insertions(+), 1 deletion(-)
13
14diff --git a/backend/cimxml/indicationlistener.c b/backend/cimxml/indicationlistener.c
15index 0d7d9fe..37c45ae 100755
16--- a/backend/cimxml/indicationlistener.c
17+++ b/backend/cimxml/indicationlistener.c
18@@ -25,6 +25,7 @@
19
20 #include <pthread.h>
21 #include <sys/socket.h>
22+#include <sys/select.h>
23 #include <netinet/in.h>
24 #include <fcntl.h>
25 #include <errno.h>
26@@ -36,7 +37,7 @@ static int do_listen=1;
27 #define hdrBufsize 5000
28 #define hdrLimmit 5000
29
30-#ifdef __APPLE__
31+#if defined(__APPLE__) || (defined(__linux__) && !defined(__GLIBC__))
32 # define __SOCKADDR_ARG struct sockaddr *__restrict
33 #endif
34
35--
362.14.1
37
diff --git a/meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc_2.2.8.bb b/meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc_2.2.8.bb
index 1ec99404a..df55a6799 100644
--- a/meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc_2.2.8.bb
+++ b/meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc_2.2.8.bb
@@ -2,7 +2,9 @@ SUMMARY = "Small Footprint CIM Client Library"
2DESCRIPTION = "Small Footprint CIM Client Library Runtime Libraries" 2DESCRIPTION = "Small Footprint CIM Client Library Runtime Libraries"
3HOMEPAGE = "http://www.sblim.org" 3HOMEPAGE = "http://www.sblim.org"
4 4
5SRC_URI = "http://netcologne.dl.sourceforge.net/project/sblim/${BPN}/${BPN}-${PV}.tar.bz2" 5SRC_URI = "http://netcologne.dl.sourceforge.net/project/sblim/${BPN}/${BPN}-${PV}.tar.bz2 \
6 file://0001-cimxml-Include-sys-select.h-for-fd_set.patch \
7 "
6 8
7SRC_URI[md5sum] = "0bac0dec19f17ec065b6c332a56d7bae" 9SRC_URI[md5sum] = "0bac0dec19f17ec065b6c332a56d7bae"
8SRC_URI[sha256sum] = "1b8f187583bc6c6b0a63aae0165ca37892a2a3bd4bb0682cd76b56268b42c3d6" 10SRC_URI[sha256sum] = "1b8f187583bc6c6b0a63aae0165ca37892a2a3bd4bb0682cd76b56268b42c3d6"