summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2013-03-29 15:25:01 +0100
committerJoe MacDonald <joe.macdonald@windriver.com>2013-04-02 08:53:13 -0400
commit7d6f5f468566b7f475da246328ff95844ba60f61 (patch)
tree397551fae3497327796a1b4fe2cf799f9b48ee5d /meta-oe
parent74eee8a7960cf0a898d795cb024b10a58357dbcd (diff)
downloadmeta-openembedded-7d6f5f468566b7f475da246328ff95844ba60f61.tar.gz
python-m2crypto: add 0.21.1
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch39
-rw-r--r--meta-oe/recipes-devtools/python/python-m2crypto_0.21.1.bb19
2 files changed, 58 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch b/meta-oe/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
new file mode 100644
index 000000000..bcbdf24bb
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
@@ -0,0 +1,39 @@
1From f11b9c71080513f9b867ba8f40613ba2ebc6e960 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Fri, 29 Mar 2013 15:17:17 +0100
4Subject: [PATCH] setup.py: link in sysroot, not in host directories
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7
8Upstream-status: Unknown
9---
10 setup.py | 6 +++---
11 1 file changed, 3 insertions(+), 3 deletions(-)
12
13diff --git a/setup.py b/setup.py
14index e7c49eb..8deaa34 100644
15--- a/setup.py
16+++ b/setup.py
17@@ -40,7 +40,7 @@ class _M2CryptoBuildExt(build_ext.build_ext):
18 self.openssl = 'c:\\pkg'
19 else:
20 self.libraries = ['ssl', 'crypto']
21- self.openssl = '/usr'
22+ self.openssl = os.environ.get( "STAGING_DIR" )
23
24
25 def finalize_options(self):
26@@ -49,8 +49,8 @@ class _M2CryptoBuildExt(build_ext.build_ext):
27
28 build_ext.build_ext.finalize_options(self)
29
30- opensslIncludeDir = os.path.join(self.openssl, 'include')
31- opensslLibraryDir = os.path.join(self.openssl, 'lib')
32+ opensslIncludeDir = os.environ.get( "STAGING_INCDIR" )
33+ opensslLibraryDir = os.environ.get( "STAGING_LIBDIR" )
34
35 self.swig_opts = ['-I%s' % i for i in self.include_dirs + \
36 [opensslIncludeDir]]
37--
381.8.1.4
39
diff --git a/meta-oe/recipes-devtools/python/python-m2crypto_0.21.1.bb b/meta-oe/recipes-devtools/python/python-m2crypto_0.21.1.bb
new file mode 100644
index 000000000..9babc04e3
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-m2crypto_0.21.1.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "A Python crypto and SSL toolkit"
2HOMEPAGE = "http://chandlerproject.org/bin/view/Projects/MeTooCrypto"
3
4DEPENDS = "openssl swig-native"
5
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://LICENCE;md5=b0e1f0b7d0ce8a62c18b1287b991800e"
8
9SRC_URI = "http://pypi.python.org/packages/source/M/M2Crypto/M2Crypto-${PV}.tar.gz \
10 file://0001-setup.py-link-in-sysroot-not-in-host-directories.patch"
11
12SRC_URI[md5sum] = "f93d8462ff7646397a9f77a2fe602d17"
13SRC_URI[sha256sum] = "25b94498505c2d800ee465db0cc1aff097b1615adc3ac042a1c85ceca264fc0a"
14
15S = "${WORKDIR}/M2Crypto-${PV}"
16
17inherit setuptools
18
19BBCLASSEXTEND = "native"