summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2015-07-07 13:14:40 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-07-30 21:31:02 +0200
commit7ca0d80cb6bba7b4a43e18df0d48bc1d66841a1c (patch)
tree51856ab0a682350a2bc7fdd80d2a3f2641723077 /meta-oe
parent77c9fb809448d94bddc9a92166110518053f5879 (diff)
downloadmeta-openembedded-7ca0d80cb6bba7b4a43e18df0d48bc1d66841a1c.tar.gz
hostapd: consider sysroot when search header files
Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-connectivity/hostapd/hostapd-2.2/add-sysroot-to-gcc.patch40
-rw-r--r--meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb1
2 files changed, 41 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/hostapd/hostapd-2.2/add-sysroot-to-gcc.patch b/meta-oe/recipes-connectivity/hostapd/hostapd-2.2/add-sysroot-to-gcc.patch
new file mode 100644
index 000000000..d1134b9aa
--- /dev/null
+++ b/meta-oe/recipes-connectivity/hostapd/hostapd-2.2/add-sysroot-to-gcc.patch
@@ -0,0 +1,40 @@
1Upstream-Status: Pending
2
3We should make sure that sysroot is used by gcc instead of assuming
4hardcoded locations for include paths
5
6Signed-off-by: Roy Li <rongqing.li@windriver.com>
7---
8 src/drivers/drivers.mak | 2 +-
9 src/drivers/drivers.mk | 2 +-
10 2 files changed, 2 insertions(+), 2 deletions(-)
11
12diff --git a/src/drivers/drivers.mak b/src/drivers/drivers.mak
13index 7e175f4..950701f 100644
14--- a/src/drivers/drivers.mak
15+++ b/src/drivers/drivers.mak
16@@ -35,7 +35,7 @@ NEED_RFKILL=y
17 ifdef CONFIG_LIBNL32
18 DRV_LIBS += -lnl-3
19 DRV_LIBS += -lnl-genl-3
20- DRV_CFLAGS += -DCONFIG_LIBNL20 -I/usr/include/libnl3
21+ DRV_CFLAGS += -DCONFIG_LIBNL20 -I=/usr/include/libnl3
22 else
23 ifdef CONFIG_LIBNL_TINY
24 DRV_LIBS += -lnl-tiny
25diff --git a/src/drivers/drivers.mk b/src/drivers/drivers.mk
26index db8561a..c93e88d 100644
27--- a/src/drivers/drivers.mk
28+++ b/src/drivers/drivers.mk
29@@ -30,7 +30,7 @@ NEED_RFKILL=y
30 ifdef CONFIG_LIBNL32
31 DRV_LIBS += -lnl-3
32 DRV_LIBS += -lnl-genl-3
33- DRV_CFLAGS += -DCONFIG_LIBNL20 -I/usr/include/libnl3
34+ DRV_CFLAGS += -DCONFIG_LIBNL20 -I=/usr/include/libnl3
35 else
36 ifdef CONFIG_LIBNL_TINY
37 DRV_LIBS += -lnl-tiny
38--
392.1.2
40
diff --git a/meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb b/meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb
index b75f2b9a7..02b78f186 100644
--- a/meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb
+++ b/meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb
@@ -18,6 +18,7 @@ SRC_URI = " \
18 file://defconfig \ 18 file://defconfig \
19 file://init \ 19 file://init \
20 file://hostapd.service \ 20 file://hostapd.service \
21 file://add-sysroot-to-gcc.patch;patchdir=.. \
21" 22"
22 23
23S = "${WORKDIR}/hostapd-${PV}/hostapd" 24S = "${WORKDIR}/hostapd-${PV}/hostapd"