diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-02-04 18:05:04 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-02-06 15:16:01 +0100 |
commit | 61911b23099c2658186179504ded318c987b5276 (patch) | |
tree | aa06906b8a9f0e08253b560fd519a6f03f233d80 /meta-oe | |
parent | 4128325a4c87bcde6ac6ffe5dbf5d6d057ee4804 (diff) | |
download | meta-openembedded-61911b23099c2658186179504ded318c987b5276.tar.gz |
ttf: introduce update-fonts bbclass and change all ttf recipes to use it
* without this ttf.inc had to set RRECOMMENDS and
postinst/postrm without PN suffix to cover all
subpackages created in ttf recipes
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
12 files changed, 82 insertions, 48 deletions
diff --git a/meta-oe/classes/update-fonts.bbclass b/meta-oe/classes/update-fonts.bbclass new file mode 100644 index 000000000..db2e814a4 --- /dev/null +++ b/meta-oe/classes/update-fonts.bbclass | |||
@@ -0,0 +1,40 @@ | |||
1 | |||
2 | update_fonts_postinst() { | ||
3 | if [ -z "$D" ]; then | ||
4 | update-fonts | ||
5 | fi | ||
6 | } | ||
7 | |||
8 | # the same but keep it separate for now | ||
9 | update_fonts_postrm() { | ||
10 | if [ -z "$D" ]; then | ||
11 | update-fonts | ||
12 | fi | ||
13 | } | ||
14 | |||
15 | python populate_packages_append () { | ||
16 | update_fonts_pkgs = d.getVar('UPDATE_FONTS_PACKAGES', True).split() | ||
17 | |||
18 | for pkg in update_fonts_pkgs: | ||
19 | postinst = d.getVar('pkg_postinst_%s' % pkg, True) or d.getVar('pkg_postinst', True) | ||
20 | if not postinst: | ||
21 | postinst = '#!/bin/sh\n' | ||
22 | postinst += d.getVar('update_fonts_postinst', True) | ||
23 | d.setVar('pkg_postinst_%s' % pkg, postinst) | ||
24 | |||
25 | postrm = d.getVar('pkg_postrm_%s' % pkg, True) or d.getVar('pkg_postrm', True) | ||
26 | if not postrm: | ||
27 | postrm = '#!/bin/sh\n' | ||
28 | postrm += d.getVar('update_fonts_postrm', True) | ||
29 | d.setVar('pkg_postrm_%s' % pkg, postrm) | ||
30 | |||
31 | d.appendVar('RDEPENDS_%s' % pkg, ' font-update-common') | ||
32 | } | ||
33 | |||
34 | python __anonymous() { | ||
35 | if not bb.data.inherits_class('native', d) and not bb.data.inherits_class('cross', d): | ||
36 | updatefonts_check = d.getVar('UPDATE_FONTS_PACKAGES') | ||
37 | if not updatefonts_check: | ||
38 | bb_filename = d.getVar('FILE') | ||
39 | raise bb.build.FuncFailed, "\n\n\nERROR: %s inherits update-fonts but doesn't set UPDATE_FONTS_PACKAGES" % bb_filename | ||
40 | } | ||
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-arphic-uming_20080216.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-arphic-uming_20080216.bb index 97b67b29d..06e06ca52 100644 --- a/meta-oe/recipes-graphics/ttf-fonts/ttf-arphic-uming_20080216.bb +++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-arphic-uming_20080216.bb | |||
@@ -4,16 +4,16 @@ LICENSE = "Arphic Public License" | |||
4 | LIC_FILES_CHKSUM = "file://README;md5=62be011094b7865ddc4d1a648444d31a" | 4 | LIC_FILES_CHKSUM = "file://README;md5=62be011094b7865ddc4d1a648444d31a" |
5 | SRC_DISTRIBUTE_LICENSES += "${PN}" | 5 | SRC_DISTRIBUTE_LICENSES += "${PN}" |
6 | RPROVIDES_${PN} = "virtual-chinese-font" | 6 | RPROVIDES_${PN} = "virtual-chinese-font" |
7 | PR = "r4" | 7 | PR = "r5" |
8 | 8 | ||
9 | SRC_URI = \ | 9 | UPDATE_FONTS_PACKAGES = "${PN}" |
10 | "http://archive.ubuntu.com/ubuntu/pool/main/t/ttf-arphic-uming/ttf-arphic-uming_0.2.${PV}.1.orig.tar.gz" | 10 | |
11 | SRC_URI = "http://archive.ubuntu.com/ubuntu/pool/main/t/ttf-arphic-uming/ttf-arphic-uming_0.2.${PV}.1.orig.tar.gz" | ||
11 | S = "${WORKDIR}" | 12 | S = "${WORKDIR}" |
12 | 13 | ||
13 | require ttf.inc | 14 | require ttf.inc |
14 | 15 | ||
15 | FILES_${PN} = "${datadir}" | 16 | FILES_${PN} = "${datadir}" |
16 | 17 | ||
17 | |||
18 | SRC_URI[md5sum] = "d219fcaf953f3eb1889399955a00379f" | 18 | SRC_URI[md5sum] = "d219fcaf953f3eb1889399955a00379f" |
19 | SRC_URI[sha256sum] = "8038a6db9e832456d5da5559aff8d15130243be1091bf24f3243503a6f1bda98" | 19 | SRC_URI[sha256sum] = "8038a6db9e832456d5da5559aff8d15130243be1091bf24f3243503a6f1bda98" |
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-dejavu_2.23.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-dejavu_2.23.bb index d7b39771f..eead861bc 100644 --- a/meta-oe/recipes-graphics/ttf-fonts/ttf-dejavu_2.23.bb +++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-dejavu_2.23.bb | |||
@@ -5,14 +5,14 @@ HOMEPAGE = "http://dejavu.sourceforge.net/wiki/" | |||
5 | LICENSE = "Bitstream Vera" | 5 | LICENSE = "Bitstream Vera" |
6 | LIC_FILES_CHKSUM = "file://${WORKDIR}/dejavu-fonts-ttf-${PV}/LICENSE;md5=9f867da7a73fad2715291348e80d0763" | 6 | LIC_FILES_CHKSUM = "file://${WORKDIR}/dejavu-fonts-ttf-${PV}/LICENSE;md5=9f867da7a73fad2715291348e80d0763" |
7 | 7 | ||
8 | # all subpackages except ${PN}-dbg and ${PN}-common itself rdepends on ${PN}-common | 8 | # all subpackages except ${PN}-common itself rdepends on ${PN}-common |
9 | RDEPENDS_${PN}-sans = "${PN}-common" | 9 | RDEPENDS_${PN}-sans = "${PN}-common" |
10 | RDEPENDS_${PN}-sans-mono = "${PN}-common" | 10 | RDEPENDS_${PN}-sans-mono = "${PN}-common" |
11 | RDEPENDS_${PN}-sans-condensed = "${PN}-common" | 11 | RDEPENDS_${PN}-sans-condensed = "${PN}-common" |
12 | RDEPENDS_${PN}-serif = "${PN}-common" | 12 | RDEPENDS_${PN}-serif = "${PN}-common" |
13 | RDEPENDS_${PN}-serif-condensed = "${PN}-common" | 13 | RDEPENDS_${PN}-serif-condensed = "${PN}-common" |
14 | RDEPENDS_${PN}-common = "" | 14 | RDEPENDS_${PN}-common = "" |
15 | PR = "r5" | 15 | PR = "r6" |
16 | 16 | ||
17 | SRC_URI = "${SOURCEFORGE_MIRROR}/dejavu/dejavu-fonts-ttf-${PV}.tar.bz2 \ | 17 | SRC_URI = "${SOURCEFORGE_MIRROR}/dejavu/dejavu-fonts-ttf-${PV}.tar.bz2 \ |
18 | file://30-dejavu-aliases.conf" | 18 | file://30-dejavu-aliases.conf" |
@@ -24,14 +24,14 @@ do_install_append () { | |||
24 | install -m 0644 ${WORKDIR}/30-dejavu-aliases.conf ${D}${sysconfdir}/fonts/conf.d/ | 24 | install -m 0644 ${WORKDIR}/30-dejavu-aliases.conf ${D}${sysconfdir}/fonts/conf.d/ |
25 | } | 25 | } |
26 | 26 | ||
27 | PACKAGES = "${PN}-dbg \ | 27 | PACKAGES = "\ |
28 | ${PN}-sans \ | 28 | ${PN}-sans \ |
29 | ${PN}-sans-mono \ | 29 | ${PN}-sans-mono \ |
30 | ${PN}-sans-condensed \ | 30 | ${PN}-sans-condensed \ |
31 | ${PN}-serif \ | 31 | ${PN}-serif \ |
32 | ${PN}-serif-condensed \ | 32 | ${PN}-serif-condensed \ |
33 | ${PN}-common" | 33 | ${PN}-common" |
34 | RRECOMMENDS_${PN}-dbg = "" | 34 | UPDATE_FONTS_PACKAGES = "${PN}-sans ${PN}-sans-mono ${PN}-sans-condensed ${PN}-serif ${PN}-serif-condensed" |
35 | 35 | ||
36 | FILES_${PN}-sans = "${datadir}/fonts/truetype/DejaVuSans.ttf ${datadir}/fonts/truetype/DejaVuSans-*.ttf" | 36 | FILES_${PN}-sans = "${datadir}/fonts/truetype/DejaVuSans.ttf ${datadir}/fonts/truetype/DejaVuSans-*.ttf" |
37 | FILES_${PN}-sans-mono = "${datadir}/fonts/truetype/DejaVuSansMono*.ttf" | 37 | FILES_${PN}-sans-mono = "${datadir}/fonts/truetype/DejaVuSansMono*.ttf" |
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-droid_git.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-droid_git.bb index 2c3bf2e9a..1a04a5fb3 100644 --- a/meta-oe/recipes-graphics/ttf-fonts/ttf-droid_git.bb +++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-droid_git.bb | |||
@@ -6,7 +6,7 @@ LICENSE = "Apache-2.0" | |||
6 | LIC_FILES_CHKSUM = "file://README.txt;md5=83544262a86f1f1ec761e75897df92bc" | 6 | LIC_FILES_CHKSUM = "file://README.txt;md5=83544262a86f1f1ec761e75897df92bc" |
7 | SRCREV = "21e6e2de1f0062f949fcc52d0b4559dfa3246e0e" | 7 | SRCREV = "21e6e2de1f0062f949fcc52d0b4559dfa3246e0e" |
8 | PV = "0.1+gitr${SRCPV}" | 8 | PV = "0.1+gitr${SRCPV}" |
9 | PR = "r1" | 9 | PR = "r2" |
10 | 10 | ||
11 | SRC_URI = "git://github.com/android/platform_frameworks_base.git;protocol=git;branch=master" | 11 | SRC_URI = "git://github.com/android/platform_frameworks_base.git;protocol=git;branch=master" |
12 | 12 | ||
@@ -16,9 +16,9 @@ do_install_prepend() { | |||
16 | rm ${S}/Ahem.ttf MTLc3m.ttf DroidSansArabic.ttf DroidSansThai.ttf Clockopia.ttf MTLmr3m.ttf DroidSansHebrew.ttf DroidSansFallbackLegacy.ttf # we're not packaging it | 16 | rm ${S}/Ahem.ttf MTLc3m.ttf DroidSansArabic.ttf DroidSansThai.ttf Clockopia.ttf MTLmr3m.ttf DroidSansHebrew.ttf DroidSansFallbackLegacy.ttf # we're not packaging it |
17 | } | 17 | } |
18 | 18 | ||
19 | PACKAGES = "${PN}-dbg ttf-droid-sans ttf-droid-sans-mono \ | 19 | PACKAGES = "ttf-droid-sans ttf-droid-sans-mono \ |
20 | ttf-droid-sans-fallback ttf-droid-sans-japanese ttf-droid-serif" | 20 | ttf-droid-sans-fallback ttf-droid-sans-japanese ttf-droid-serif" |
21 | RRECOMMENDS_${PN}-dbg = "" | 21 | UPDATE_FONTS_PACKAGES = "ttf-droid-sans ttf-droid-sans-mono ttf-droid-sans-fallback ttf-droid-sans-japanese ttf-droid-serif" |
22 | 22 | ||
23 | FILES_ttf-droid-sans = "${datadir}/fonts/truetype/DroidSans.ttf ${datadir}/fonts/truetype/DroidSans-Bold.ttf" | 23 | FILES_ttf-droid-sans = "${datadir}/fonts/truetype/DroidSans.ttf ${datadir}/fonts/truetype/DroidSans-Bold.ttf" |
24 | FILES_ttf-droid-sans-mono = "${datadir}/fonts/truetype/DroidSansMono.ttf" | 24 | FILES_ttf-droid-sans-mono = "${datadir}/fonts/truetype/DroidSansMono.ttf" |
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-gentium_1.02.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-gentium_1.02.bb index 3c49e2483..1e21e1476 100644 --- a/meta-oe/recipes-graphics/ttf-fonts/ttf-gentium_1.02.bb +++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-gentium_1.02.bb | |||
@@ -6,7 +6,7 @@ LICENSE = "OFL" | |||
6 | LICENSE_URL = "http://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&item_id=OFL" | 6 | LICENSE_URL = "http://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&item_id=OFL" |
7 | LIC_FILES_CHKSUM = "file://OFL;md5=33a5bf7b98a9c0ae87430760ba762295 \ | 7 | LIC_FILES_CHKSUM = "file://OFL;md5=33a5bf7b98a9c0ae87430760ba762295 \ |
8 | " | 8 | " |
9 | PR = "r6" | 9 | PR = "r7" |
10 | 10 | ||
11 | SRC_URI = "${DEBIAN_MIRROR}/main/t/ttf-gentium/ttf-gentium_${PV}.orig.tar.gz " | 11 | SRC_URI = "${DEBIAN_MIRROR}/main/t/ttf-gentium/ttf-gentium_${PV}.orig.tar.gz " |
12 | 12 | ||
@@ -22,15 +22,16 @@ do_install_append() { | |||
22 | 22 | ||
23 | } | 23 | } |
24 | 24 | ||
25 | PACKAGES = "${PN}-dbg ${PN} ${PN}-alt" | 25 | PACKAGES = "${PN} ${PN}-alt" |
26 | UPDATE_FONTS_PACKAGES = "${PN} ${PN}-alt" | ||
26 | 27 | ||
27 | FILES_ttf-gentium-alt = "${datadir}/fonts/truetype/GenAI*.ttf \ | 28 | FILES_${PN}-alt = "${datadir}/fonts/truetype/GenAI*.ttf \ |
28 | ${datadir}/fonts/truetype/GenAR*.ttf \ | 29 | ${datadir}/fonts/truetype/GenAR*.ttf \ |
29 | ${datadir}/doc/ttf-gentium-alt/*" | 30 | ${datadir}/doc/ttf-gentium-alt/*" |
30 | 31 | ||
31 | FILES_${PN} = "${datadir}/fonts/truetype/GenI*.ttf \ | 32 | FILES_${PN} = "${datadir}/fonts/truetype/GenI*.ttf \ |
32 | ${datadir}/fonts/truetype/GenR*.ttf \ | 33 | ${datadir}/fonts/truetype/GenR*.ttf \ |
33 | ${datadir}/doc/ttf-gentium/*" | 34 | ${datadir}/doc/ttf-gentium/*" |
34 | 35 | ||
35 | SRC_URI[md5sum] = "4c3e6ae586be277537ebb68f2a45b883" | 36 | SRC_URI[md5sum] = "4c3e6ae586be277537ebb68f2a45b883" |
36 | SRC_URI[sha256sum] = "4746c04c9a4ad9e0788a38e0a2f81919a630d8070ceabc89f156b6d41d8ceb37" | 37 | SRC_URI[sha256sum] = "4746c04c9a4ad9e0788a38e0a2f81919a630d8070ceabc89f156b6d41d8ceb37" |
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-hunkyfonts_0.3.0.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-hunkyfonts_0.3.0.bb index 4a234517c..1f7721118 100644 --- a/meta-oe/recipes-graphics/ttf-fonts/ttf-hunkyfonts_0.3.0.bb +++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-hunkyfonts_0.3.0.bb | |||
@@ -4,14 +4,15 @@ DESCRIPTION = "Hunky fonts - TTF Version" | |||
4 | HOMEPAGE = "http://sourceforge.net/projects/hunkyfonts" | 4 | HOMEPAGE = "http://sourceforge.net/projects/hunkyfonts" |
5 | LICENSE = "LGPL" | 5 | LICENSE = "LGPL" |
6 | LIC_FILES_CHKSUM = "file://../LICENSE;md5=7fbc338309ac38fefcd64b04bb903e34" | 6 | LIC_FILES_CHKSUM = "file://../LICENSE;md5=7fbc338309ac38fefcd64b04bb903e34" |
7 | PR = "r5" | 7 | PR = "r6" |
8 | 8 | ||
9 | SRC_URI = "${SOURCEFORGE_MIRROR}/hunkyfonts/hunkyfonts-${PV}.tar.bz2" | 9 | SRC_URI = "${SOURCEFORGE_MIRROR}/hunkyfonts/hunkyfonts-${PV}.tar.bz2" |
10 | 10 | ||
11 | S = "${WORKDIR}/hunkyfonts-${PV}/TTF/" | 11 | S = "${WORKDIR}/hunkyfonts-${PV}/TTF/" |
12 | 12 | ||
13 | PACKAGES = "${PN}-dbg ttf-hunky-sans ttf-hunky-serif" | 13 | PACKAGES = "ttf-hunky-sans ttf-hunky-serif" |
14 | RRECOMMENDS_${PN}-dbg = "" | 14 | UPDATE_FONTS_PACKAGES = "ttf-hunky-sans ttf-hunky-serif" |
15 | |||
15 | FILES_ttf-hunky-sans = "${datadir}/fonts/truetype/HunkySans*.ttf" | 16 | FILES_ttf-hunky-sans = "${datadir}/fonts/truetype/HunkySans*.ttf" |
16 | FILES_ttf-hunky-serif = "${datadir}/fonts/truetype/HunkySerif*.ttf" | 17 | FILES_ttf-hunky-serif = "${datadir}/fonts/truetype/HunkySerif*.ttf" |
17 | 18 | ||
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-liberation_0.2.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-liberation_0.2.bb index c0d77fd46..901b8b294 100644 --- a/meta-oe/recipes-graphics/ttf-fonts/ttf-liberation_0.2.bb +++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-liberation_0.2.bb | |||
@@ -7,13 +7,13 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ | |||
7 | file://License.txt;md5=5b171c5100029d884fcea21d9a2b7543 \ | 7 | file://License.txt;md5=5b171c5100029d884fcea21d9a2b7543 \ |
8 | " | 8 | " |
9 | 9 | ||
10 | PR = "r5" | 10 | PR = "r6" |
11 | 11 | ||
12 | SRC_URI = "http://fedorahosted.org/liberation-fonts/export/807b6dfd069b998cd9b4d3158da98817ef23c79d/F-9/liberation-fonts-ttf-3.tar.gz" | 12 | SRC_URI = "http://fedorahosted.org/liberation-fonts/export/807b6dfd069b998cd9b4d3158da98817ef23c79d/F-9/liberation-fonts-ttf-3.tar.gz" |
13 | S = "${WORKDIR}/liberation-fonts-${PV}" | 13 | S = "${WORKDIR}/liberation-fonts-${PV}" |
14 | 14 | ||
15 | PACKAGES = "${PN}-dbg ttf-liberation-mono ttf-liberation-sans ttf-liberation-serif" | 15 | PACKAGES = "ttf-liberation-mono ttf-liberation-sans ttf-liberation-serif" |
16 | RRECOMMENDS_${PN}-dbg = "" | 16 | UPDATE_FONTS_PACKAGES = "ttf-liberation-mono ttf-liberation-sans ttf-liberation-serif" |
17 | 17 | ||
18 | FILES_ttf-liberation-mono = "${datadir}/fonts/truetype/*Mono*" | 18 | FILES_ttf-liberation-mono = "${datadir}/fonts/truetype/*Mono*" |
19 | FILES_ttf-liberation-sans = "${datadir}/fonts/truetype/*Sans*" | 19 | FILES_ttf-liberation-sans = "${datadir}/fonts/truetype/*Sans*" |
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb index 9103dabfe..6f12d29be 100644 --- a/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb +++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb | |||
@@ -6,16 +6,20 @@ LICENSE = "${PN}" | |||
6 | LIC_FILES_CHKSUM = "file://LICENSE_E;md5=ac161e96eda00db9a3aec7870b5d9658 \ | 6 | LIC_FILES_CHKSUM = "file://LICENSE_E;md5=ac161e96eda00db9a3aec7870b5d9658 \ |
7 | file://LICENSE_J;md5=a120ca8d7c8e4a475d5277c9aeb95221 \ | 7 | file://LICENSE_J;md5=a120ca8d7c8e4a475d5277c9aeb95221 \ |
8 | " | 8 | " |
9 | PR = "r2" | 9 | PR = "r3" |
10 | 10 | ||
11 | SRC_URI = "http://osdn.dl.sourceforge.jp/mplus-fonts/6650/mplus-TESTFLIGHT-${PV}.tar.gz" | 11 | SRC_URI = "http://osdn.dl.sourceforge.jp/mplus-fonts/6650/mplus-TESTFLIGHT-${PV}.tar.gz" |
12 | S = "${WORKDIR}/mplus-TESTFLIGHT-${PV}" | 12 | S = "${WORKDIR}/mplus-TESTFLIGHT-${PV}" |
13 | 13 | ||
14 | python populate_packages_prepend() { | 14 | python populate_packages_prepend() { |
15 | plugindir = d.expand('${datadir}/fonts/ttf-mplus/') | 15 | plugindir = d.expand('${datadir}/fonts/ttf-mplus/') |
16 | do_split_packages(d, plugindir, '^(.*)\.ttf$', 'ttf-%s', 'TTF Font %s', extra_depends = "ttf-common") | 16 | packages = do_split_packages(d, plugindir, '^(.*)\.ttf$', 'ttf-%s', 'TTF Font %s', extra_depends = "ttf-common") |
17 | d.setVar('UPDATE_FONTS_PACKAGES', ' '.join(packages)) | ||
17 | } | 18 | } |
18 | 19 | ||
20 | # for update-fonts.bbclass sake only, replaced later in populate_packages_prepend | ||
21 | UPDATE_FONTS_PACKAGES = "${PN}" | ||
22 | |||
19 | do_install() { | 23 | do_install() { |
20 | install -d ${D}${datadir}/fonts/ttf-mplus | 24 | install -d ${D}${datadir}/fonts/ttf-mplus |
21 | install -m 0644 *.ttf ${D}${datadir}/fonts/ttf-mplus/ | 25 | install -m 0644 *.ttf ${D}${datadir}/fonts/ttf-mplus/ |
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-sazanami_20040629.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-sazanami_20040629.bb index 3c4cb26d4..d982c112b 100644 --- a/meta-oe/recipes-graphics/ttf-fonts/ttf-sazanami_20040629.bb +++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-sazanami_20040629.bb | |||
@@ -9,17 +9,18 @@ LICENSE = "Public domain" | |||
9 | LIC_FILES_CHKSUM = "file://README;md5=97d739900be6e852830f55aa3c07d4a0" | 9 | LIC_FILES_CHKSUM = "file://README;md5=97d739900be6e852830f55aa3c07d4a0" |
10 | SRC_DISTRIBUTE_LICENSES += "${PN}" | 10 | SRC_DISTRIBUTE_LICENSES += "${PN}" |
11 | RPROVIDES_${PN} = "virtual-japanese-font" | 11 | RPROVIDES_${PN} = "virtual-japanese-font" |
12 | PR = "r7" | 12 | PR = "r8" |
13 | 13 | ||
14 | SRC_URI = "http://osdn.dl.sourceforge.jp/efont/10087/sazanami-20040629.tar.bz2" | 14 | SRC_URI = "http://osdn.dl.sourceforge.jp/efont/10087/sazanami-20040629.tar.bz2" |
15 | S = "${WORKDIR}/sazanami-20040629" | 15 | S = "${WORKDIR}/sazanami-20040629" |
16 | 16 | ||
17 | PACKAGES = "${PN}-dbg ttf-sazanami-gothic ttf-sazanami-mincho" | 17 | PACKAGES = "ttf-sazanami-gothic ttf-sazanami-mincho" |
18 | RRECOMMENDS_${PN}-dbg = "" | 18 | UPDATE_FONTS_PACKAGES = "ttf-sazanami-gothic ttf-sazanami-mincho" |
19 | |||
19 | FILES_ttf-sazanami-gothic = "${datadir}/fonts/truetype/sazanami-gothic.ttf \ | 20 | FILES_ttf-sazanami-gothic = "${datadir}/fonts/truetype/sazanami-gothic.ttf \ |
20 | ${datadir}/doc/ttf-sazanami-gothic/README" | 21 | ${datadir}/doc/ttf-sazanami-gothic/README" |
21 | FILES_ttf-sazanami-mincho = "${datadir}/fonts/truetype/sazanami-mincho.ttf \ | 22 | FILES_ttf-sazanami-mincho = "${datadir}/fonts/truetype/sazanami-mincho.ttf \ |
22 | ${datadir}/doc/ttf-sazanami-mincho/README" | 23 | ${datadir}/doc/ttf-sazanami-mincho/README" |
23 | 24 | ||
24 | do_install_append() { | 25 | do_install_append() { |
25 | # README contains the redistribution license | 26 | # README contains the redistribution license |
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-ubuntu-font-family_0.80.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-ubuntu-font-family_0.80.bb index 08d79a18c..8d992590a 100644 --- a/meta-oe/recipes-graphics/ttf-fonts/ttf-ubuntu-font-family_0.80.bb +++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-ubuntu-font-family_0.80.bb | |||
@@ -13,8 +13,8 @@ SRC_URI[sha256sum] = "107170099bbc3beae8602b97a5c423525d363106c3c24f787d43e09811 | |||
13 | 13 | ||
14 | S = "${WORKDIR}/ubuntu-font-family-${PV}" | 14 | S = "${WORKDIR}/ubuntu-font-family-${PV}" |
15 | 15 | ||
16 | PACKAGES = "${PN}-dbg ttf-ubuntu-mono ttf-ubuntu-sans" | 16 | PACKAGES = "ttf-ubuntu-mono ttf-ubuntu-sans" |
17 | RRECOMMENDS_${PN}-dbg = "" | 17 | UPDATE_FONTS_PACKAGES = "ttf-ubuntu-mono ttf-ubuntu-sans" |
18 | 18 | ||
19 | FILES_ttf-ubuntu-mono = "${datadir}/fonts/truetype/*Mono*" | 19 | FILES_ttf-ubuntu-mono = "${datadir}/fonts/truetype/*Mono*" |
20 | FILES_ttf-ubuntu-sans = "${datadir}/fonts/truetype/Ubuntu-*" | 20 | FILES_ttf-ubuntu-sans = "${datadir}/fonts/truetype/Ubuntu-*" |
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-wqy-zenhei_0.6.26.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-wqy-zenhei_0.6.26.bb index d8c88d544..0263301ab 100644 --- a/meta-oe/recipes-graphics/ttf-fonts/ttf-wqy-zenhei_0.6.26.bb +++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-wqy-zenhei_0.6.26.bb | |||
@@ -5,7 +5,7 @@ AUTHOR = "Qianqian Fang and The WenQuanYi Project Contributors" | |||
5 | HOMEPAGE = "http://wqy.sourceforge.net/en/" | 5 | HOMEPAGE = "http://wqy.sourceforge.net/en/" |
6 | LICENSE = "GPLv2" | 6 | LICENSE = "GPLv2" |
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=cf540fc7d35b5777e36051280b3a911c" | 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=cf540fc7d35b5777e36051280b3a911c" |
8 | PR = "r2" | 8 | PR = "r3" |
9 | 9 | ||
10 | SRC_URI = "${SOURCEFORGE_MIRROR}/wqy/wqy-zenhei-${PV}-0.tar.gz" | 10 | SRC_URI = "${SOURCEFORGE_MIRROR}/wqy/wqy-zenhei-${PV}-0.tar.gz" |
11 | S = "${WORKDIR}/wqy-zenhei" | 11 | S = "${WORKDIR}/wqy-zenhei" |
@@ -17,6 +17,7 @@ do_install_append () { | |||
17 | } | 17 | } |
18 | 18 | ||
19 | PACKAGES = "${PN}" | 19 | PACKAGES = "${PN}" |
20 | UPDATE_FONTS_PACKAGES = "${PN}" | ||
20 | 21 | ||
21 | FILES_${PN} = "${datadir}/fonts ${sysconfdir}" | 22 | FILES_${PN} = "${datadir}/fonts ${sysconfdir}" |
22 | 23 | ||
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf.inc b/meta-oe/recipes-graphics/ttf-fonts/ttf.inc index d48f692fe..70283be78 100644 --- a/meta-oe/recipes-graphics/ttf-fonts/ttf.inc +++ b/meta-oe/recipes-graphics/ttf-fonts/ttf.inc | |||
@@ -1,7 +1,5 @@ | |||
1 | DESCRIPTION ?= "TrueType font package ${PN}" | 1 | DESCRIPTION ?= "TrueType font package ${PN}" |
2 | SECTION = "fonts" | 2 | SECTION = "fonts" |
3 | # don't use RRECOMMENDS_${PN} here because sometimes each font is packaged to separate package and each one needs this dep to call update-fonts | ||
4 | RRECOMMENDS += "font-update-common" | ||
5 | 3 | ||
6 | # we don't need a compiler nor a c library for these fonts | 4 | # we don't need a compiler nor a c library for these fonts |
7 | INHIBIT_DEFAULT_DEPS = "1" | 5 | INHIBIT_DEFAULT_DEPS = "1" |
@@ -11,16 +9,4 @@ do_install() { | |||
11 | find ./ -name '*.tt[cf]' -exec install -m 0644 {} ${D}${datadir}/fonts/truetype/ \; | 9 | find ./ -name '*.tt[cf]' -exec install -m 0644 {} ${D}${datadir}/fonts/truetype/ \; |
12 | } | 10 | } |
13 | 11 | ||
14 | pkg_postinst_append() { | 12 | inherit allarch update-fonts |
15 | if [ -z "$D" ]; then | ||
16 | update-fonts | ||
17 | fi | ||
18 | } | ||
19 | |||
20 | pkg_postrm_append() { | ||
21 | if [ -z "$D" ]; then | ||
22 | update-fonts | ||
23 | fi | ||
24 | } | ||
25 | |||
26 | inherit allarch | ||