diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2012-09-04 14:11:58 +0200 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-09-05 10:05:06 +0200 |
commit | 21a4be0e36bb1ee6c3c469c83a623c5d9a45257a (patch) | |
tree | be14375786b4756c8c9d62020cc99a8b2da808fa /meta-oe | |
parent | f3dbc97b44a5dd2588eb0c6ed7e3ce1b1e997847 (diff) | |
download | meta-openembedded-21a4be0e36bb1ee6c3c469c83a623c5d9a45257a.tar.gz |
task*: rename to packagegroup to match oe-core
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-core/packagegroups/packagegroup-basic.bb (renamed from meta-oe/recipes-core/tasks/task-basic.bb) | 6 | ||||
-rw-r--r-- | meta-oe/recipes-core/packagegroups/packagegroup-boot.bb (renamed from meta-oe/recipes-core/tasks/task-boot.bb) | 2 | ||||
-rw-r--r-- | meta-oe/recipes-core/packagegroups/packagegroup-cli-tools.bb (renamed from meta-oe/recipes-core/tasks/task-cli-tools.bb) | 2 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/packagegroups/packagegroup-sdk-target.bb (renamed from meta-oe/recipes-devtools/tasks/task-sdk-target.bb) | 4 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/packagegroups/packagegroup-fonts-truetype.bb (renamed from meta-oe/recipes-graphics/tasks/task-fonts-truetype.bb) | 10 | ||||
-rw-r--r-- | meta-oe/recipes-qt/packagegroups/packagegroup-qte-toolchain-target.bbappend (renamed from meta-oe/recipes-qt/tasks/task-qte-toolchain-target.bbappend) | 0 |
6 files changed, 12 insertions, 12 deletions
diff --git a/meta-oe/recipes-core/tasks/task-basic.bb b/meta-oe/recipes-core/packagegroups/packagegroup-basic.bb index 47b09de0e..e46afc278 100644 --- a/meta-oe/recipes-core/tasks/task-basic.bb +++ b/meta-oe/recipes-core/packagegroups/packagegroup-basic.bb | |||
@@ -1,4 +1,4 @@ | |||
1 | # This recipe is intended as a 'simpler' replacement for task-base. | 1 | # This recipe is intended as a 'simpler' replacement for packagegroup-base. |
2 | # Please communicate your use cases and suggestions to the mailinglist(s) | 2 | # Please communicate your use cases and suggestions to the mailinglist(s) |
3 | 3 | ||
4 | DESCRIPTION = "Basic task to get a device online" | 4 | DESCRIPTION = "Basic task to get a device online" |
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3 | |||
7 | 7 | ||
8 | PR = "r9" | 8 | PR = "r9" |
9 | 9 | ||
10 | inherit task | 10 | inherit packagegroup |
11 | 11 | ||
12 | # packages which content depend on MACHINE_FEATURES need to be MACHINE_ARCH | 12 | # packages which content depend on MACHINE_FEATURES need to be MACHINE_ARCH |
13 | # | 13 | # |
@@ -24,7 +24,7 @@ MACHINE_EXTRA_RRECOMMENDS ?= "" | |||
24 | TASK_BASIC_SSHDAEMON ?= "dropbear openssh-sftp openssh-sftp-server" | 24 | TASK_BASIC_SSHDAEMON ?= "dropbear openssh-sftp openssh-sftp-server" |
25 | 25 | ||
26 | # | 26 | # |
27 | # The section below is designed to match with task-boot, but doesn't depend on it to allow for more freedom | 27 | # The section below is designed to match with packagegroup-boot, but doesn't depend on it to allow for more freedom |
28 | # when writing image recipes. | 28 | # when writing image recipes. |
29 | # It also avoids the choice between connman/networkmanager/ifupdown since that is an image feature, not a | 29 | # It also avoids the choice between connman/networkmanager/ifupdown since that is an image feature, not a |
30 | # distro feature. | 30 | # distro feature. |
diff --git a/meta-oe/recipes-core/tasks/task-boot.bb b/meta-oe/recipes-core/packagegroups/packagegroup-boot.bb index 6c27ffe44..ac3111834 100644 --- a/meta-oe/recipes-core/tasks/task-boot.bb +++ b/meta-oe/recipes-core/packagegroups/packagegroup-boot.bb | |||
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3 | |||
4 | 4 | ||
5 | PR = "r57" | 5 | PR = "r57" |
6 | 6 | ||
7 | inherit task | 7 | inherit packagegroup |
8 | 8 | ||
9 | # packages which content depend on MACHINE_FEATURES need to be MACHINE_ARCH | 9 | # packages which content depend on MACHINE_FEATURES need to be MACHINE_ARCH |
10 | # | 10 | # |
diff --git a/meta-oe/recipes-core/tasks/task-cli-tools.bb b/meta-oe/recipes-core/packagegroups/packagegroup-cli-tools.bb index a849978b4..0ab3703bd 100644 --- a/meta-oe/recipes-core/tasks/task-cli-tools.bb +++ b/meta-oe/recipes-core/packagegroups/packagegroup-cli-tools.bb | |||
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384 | |||
6 | PV = "1.0" | 6 | PV = "1.0" |
7 | PR = "r19" | 7 | PR = "r19" |
8 | 8 | ||
9 | inherit task allarch | 9 | inherit packagegroup allarch |
10 | 10 | ||
11 | PACKAGES += "${PN}-debug" | 11 | PACKAGES += "${PN}-debug" |
12 | 12 | ||
diff --git a/meta-oe/recipes-devtools/tasks/task-sdk-target.bb b/meta-oe/recipes-devtools/packagegroups/packagegroup-sdk-target.bb index 03141f2d1..3ad9b5557 100644 --- a/meta-oe/recipes-devtools/tasks/task-sdk-target.bb +++ b/meta-oe/recipes-devtools/packagegroups/packagegroup-sdk-target.bb | |||
@@ -2,9 +2,9 @@ DESCRIPTION = "Packages required for a target (on-device) SDK" | |||
2 | LICENSE = "MIT" | 2 | LICENSE = "MIT" |
3 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" | 3 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" |
4 | 4 | ||
5 | inherit task allarch | 5 | inherit packagegroup allarch |
6 | 6 | ||
7 | RPROVIDES_${PN} = "task-native-sdk" | 7 | RPROVIDES_${PN} = "packagegroup-native-sdk" |
8 | RDEPENDS_${PN} = "gcc-symlinks g++-symlinks cpp cpp-symlinks \ | 8 | RDEPENDS_${PN} = "gcc-symlinks g++-symlinks cpp cpp-symlinks \ |
9 | binutils-symlinks \ | 9 | binutils-symlinks \ |
10 | perl-modules \ | 10 | perl-modules \ |
diff --git a/meta-oe/recipes-graphics/tasks/task-fonts-truetype.bb b/meta-oe/recipes-graphics/packagegroups/packagegroup-fonts-truetype.bb index 112e8cbc1..816a67f59 100644 --- a/meta-oe/recipes-graphics/tasks/task-fonts-truetype.bb +++ b/meta-oe/recipes-graphics/packagegroups/packagegroup-fonts-truetype.bb | |||
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384 | |||
5 | PV = "1.0" | 5 | PV = "1.0" |
6 | PR = "r1" | 6 | PR = "r1" |
7 | 7 | ||
8 | inherit task allarch | 8 | inherit packagegroup allarch |
9 | 9 | ||
10 | PACKAGES += "\ | 10 | PACKAGES += "\ |
11 | ${PN}-core \ | 11 | ${PN}-core \ |
@@ -13,13 +13,13 @@ PACKAGES += "\ | |||
13 | ${PN}-japanese \ | 13 | ${PN}-japanese \ |
14 | " | 14 | " |
15 | 15 | ||
16 | RRECOMMENDS_task-fonts-truetype = "\ | 16 | RRECOMMENDS_packagegroup-fonts-truetype = "\ |
17 | ${PN}-core \ | 17 | ${PN}-core \ |
18 | ${PN}-chinese \ | 18 | ${PN}-chinese \ |
19 | ${PN}-japanese \ | 19 | ${PN}-japanese \ |
20 | " | 20 | " |
21 | 21 | ||
22 | RDEPENDS_task-fonts-truetype-core = "\ | 22 | RDEPENDS_packagegroup-fonts-truetype-core = "\ |
23 | fontconfig-utils \ | 23 | fontconfig-utils \ |
24 | \ | 24 | \ |
25 | ttf-dejavu-common \ | 25 | ttf-dejavu-common \ |
@@ -28,12 +28,12 @@ RDEPENDS_task-fonts-truetype-core = "\ | |||
28 | " | 28 | " |
29 | # ttf-dejavu-serif \ | 29 | # ttf-dejavu-serif \ |
30 | 30 | ||
31 | RDEPENDS_task-fonts-truetype-chinese = "\ | 31 | RDEPENDS_packagegroup-fonts-truetype-chinese = "\ |
32 | ${PN}-core \ | 32 | ${PN}-core \ |
33 | ttf-arphic-uming \ | 33 | ttf-arphic-uming \ |
34 | " | 34 | " |
35 | 35 | ||
36 | RDEPENDS_task-fonts-truetype-japanese = "\ | 36 | RDEPENDS_packagegroup-fonts-truetype-japanese = "\ |
37 | ${PN}-core \ | 37 | ${PN}-core \ |
38 | ttf-sazanami-gothic \ | 38 | ttf-sazanami-gothic \ |
39 | ttf-sazanami-mincho \ | 39 | ttf-sazanami-mincho \ |
diff --git a/meta-oe/recipes-qt/tasks/task-qte-toolchain-target.bbappend b/meta-oe/recipes-qt/packagegroups/packagegroup-qte-toolchain-target.bbappend index 7ca6c592b..7ca6c592b 100644 --- a/meta-oe/recipes-qt/tasks/task-qte-toolchain-target.bbappend +++ b/meta-oe/recipes-qt/packagegroups/packagegroup-qte-toolchain-target.bbappend | |||