summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-04-23 22:20:45 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-26 20:13:30 +0200
commit68c22d5bf159110be7d8f6897d54f42e1f1f1834 (patch)
tree950a06cb489df9d2d6166ab85906a3ecdc88b3f7 /meta-oe
parentcc275f0b112c31381bf2258203ad58d64146900a (diff)
downloadmeta-openembedded-68c22d5bf159110be7d8f6897d54f42e1f1f1834.tar.gz
fluentbit: Upgrade to 0.11.3 release
Fix cross compiling for external modules Fix build with gcc7 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/fluentbit/fluentbit/0001-CMakeLists.txt-Add-AUTOCONF_HOST_OPT-to-help-cross-c.patch52
-rw-r--r--meta-oe/recipes-extended/fluentbit/fluentbit/0002-msgpack-Add-comment-for-intended-fallthrough.patch28
-rw-r--r--meta-oe/recipes-extended/fluentbit/fluentbit_0.11.3.bb24
-rw-r--r--meta-oe/recipes-extended/fluentbit/fluentbit_0.7.2.bb16
4 files changed, 104 insertions, 16 deletions
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit/0001-CMakeLists.txt-Add-AUTOCONF_HOST_OPT-to-help-cross-c.patch b/meta-oe/recipes-extended/fluentbit/fluentbit/0001-CMakeLists.txt-Add-AUTOCONF_HOST_OPT-to-help-cross-c.patch
new file mode 100644
index 000000000..539a42a7d
--- /dev/null
+++ b/meta-oe/recipes-extended/fluentbit/fluentbit/0001-CMakeLists.txt-Add-AUTOCONF_HOST_OPT-to-help-cross-c.patch
@@ -0,0 +1,52 @@
1From ceb47f37582a055bb7f253f813c435ad55c5b6eb Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 22 Apr 2017 10:02:50 -0700
4Subject: [PATCH 1/2] CMakeLists.txt: Add AUTOCONF_HOST_OPT to help cross
5 compiling
6
7This helps in doing cross compiles for modules which are using
8GNU autoconf for build system
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 CMakeLists.txt | 10 ++++++++--
13 1 file changed, 8 insertions(+), 2 deletions(-)
14
15diff --git a/CMakeLists.txt b/CMakeLists.txt
16index b093f9a..ebf0cd7 100644
17--- a/CMakeLists.txt
18+++ b/CMakeLists.txt
19@@ -290,6 +290,12 @@ else()
20 endif()
21 endif()
22
23+if("${GNU_HOST}" STREQUAL "")
24+ set(AUTOCONF_HOST_OPT "")
25+else()
26+ set(AUTOCONF_HOST_OPT "--host=${GNU_HOST}")
27+endif()
28+
29 # Memory Allocator
30 # ================
31 if(FLB_JEMALLOC AND ${CMAKE_SYSTEM_NAME} MATCHES "Linux")
32@@ -299,7 +305,7 @@ if(FLB_JEMALLOC AND ${CMAKE_SYSTEM_NAME} MATCHES "Linux")
33 # Link to Jemalloc as an external dependency
34 ExternalProject_Add(jemalloc
35 SOURCE_DIR ${CMAKE_CURRENT_SOURCE_DIR}/lib/jemalloc
36- CONFIGURE_COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/lib/jemalloc/configure --with-lg-quantum=3 --enable-cc-silence --prefix=<INSTALL_DIR>
37+ CONFIGURE_COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/lib/jemalloc/configure ${AUTOCONF_HOST_OPT} --with-lg-quantum=3 --enable-cc-silence --prefix=<INSTALL_DIR>
38 CFLAGS=-std=gnu99\ -Wall\ -pipe\ -g3\ -O3\ -funroll-loops
39 BUILD_COMMAND ${MAKE}
40 INSTALL_DIR ${CMAKE_CURRENT_BINARY_DIR}/
41@@ -317,7 +323,7 @@ endif()
42 if(FLB_REGEX)
43 ExternalProject_Add(onigmo
44 SOURCE_DIR ${CMAKE_CURRENT_SOURCE_DIR}/lib/onigmo
45- CONFIGURE_COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/lib/onigmo/configure --with-pic --disable-shared --enable-static --prefix=<INSTALL_DIR>
46+ CONFIGURE_COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/lib/onigmo/configure ${AUTOCONF_HOST_OPT} --with-pic --disable-shared --enable-static --prefix=<INSTALL_DIR>
47 CFLAGS=-std=gnu99\ -Wall\ -pipe\ -g3\ -O3\ -funroll-loops
48 BUILD_COMMAND ${MAKE}
49 INSTALL_DIR ${CMAKE_CURRENT_BINARY_DIR}/
50--
512.12.2
52
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit/0002-msgpack-Add-comment-for-intended-fallthrough.patch b/meta-oe/recipes-extended/fluentbit/fluentbit/0002-msgpack-Add-comment-for-intended-fallthrough.patch
new file mode 100644
index 000000000..35cdb18ad
--- /dev/null
+++ b/meta-oe/recipes-extended/fluentbit/fluentbit/0002-msgpack-Add-comment-for-intended-fallthrough.patch
@@ -0,0 +1,28 @@
1From d95c2977da074be0d3913e94fb8fb5ed1c64404a Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 22 Apr 2017 10:04:03 -0700
4Subject: [PATCH 2/2] msgpack: Add comment for intended fallthrough
5
6Helps fixing build with gcc7
7
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9---
10 lib/msgpack-c-0b7cabd/include/msgpack/unpack_template.h | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/lib/msgpack-c-0b7cabd/include/msgpack/unpack_template.h b/lib/msgpack-c-0b7cabd/include/msgpack/unpack_template.h
14index a6dae6f..651e6c2 100644
15--- a/lib/msgpack-c-0b7cabd/include/msgpack/unpack_template.h
16+++ b/lib/msgpack-c-0b7cabd/include/msgpack/unpack_template.h
17@@ -248,7 +248,7 @@ msgpack_unpack_func(int, _execute)(msgpack_unpack_struct(_context)* ctx, const c
18
19 _fixed_trail_again:
20 ++p;
21-
22+ // fallthrough
23 default:
24 if((size_t)(pe - p) < trail) { goto _out; }
25 n = p; p += trail - 1;
26--
272.12.2
28
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.3.bb b/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.3.bb
new file mode 100644
index 000000000..8d756e6a4
--- /dev/null
+++ b/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.3.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Fast data collector for Embedded Linux"
2HOMEPAGE = "http://fluentbit.io"
3BUGTRACKER = "https://github.com/fluent/fluent-bit/issues"
4
5SRC_URI = "http://fluentbit.io/releases/0.11/fluent-bit-${PV}.tar.gz \
6 file://0001-CMakeLists.txt-Add-AUTOCONF_HOST_OPT-to-help-cross-c.patch \
7 file://0002-msgpack-Add-comment-for-intended-fallthrough.patch \
8 "
9SRC_URI[md5sum] = "9383262339412782b80cc49e7ad15609"
10SRC_URI[sha256sum] = "eb8a85c656fa60682b0bf8dd1ad58d848cd251dab4f35a6777acd552c65b0511"
11
12S = "${WORKDIR}/fluent-bit-${PV}"
13
14LICENSE = "Apache-2.0"
15LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
16
17DEPENDS = "zlib"
18INSANE_SKIP_${PN}-dev += "dev-elf"
19
20inherit cmake systemd
21
22EXTRA_OECMAKE = "-DGNU_HOST=${HOST_SYS}"
23
24SYSTEMD_SERVICE_${PN} = "fluent-bit.service"
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit_0.7.2.bb b/meta-oe/recipes-extended/fluentbit/fluentbit_0.7.2.bb
deleted file mode 100644
index c75f446e1..000000000
--- a/meta-oe/recipes-extended/fluentbit/fluentbit_0.7.2.bb
+++ /dev/null
@@ -1,16 +0,0 @@
1SUMMARY = "Fast data collector for Embedded Linux"
2HOMEPAGE = "http://fluentbit.io"
3BUGTRACKER = "https://github.com/fluent/fluent-bit/issues"
4
5SRC_URI = "http://fluentbit.io/releases/0.7/fluent-bit-${PV}.tar.gz"
6SRC_URI[md5sum] = "6df9d676e1d2d782a243e655e144e8ae"
7SRC_URI[sha256sum] = "695b56ce378f56855c9554f88f5d8e4f7b11ba7691284903870f779912af4ebe"
8S = "${WORKDIR}/fluent-bit-${PV}"
9
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
12
13DEPENDS = "zlib"
14INSANE_SKIP_${PN}-dev += "dev-elf"
15
16inherit cmake