summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2017-02-08 10:37:40 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-02-13 18:43:32 +0100
commit4071e6b4b0a13a716c7473fd2f569a5b197c72bd (patch)
treeadf4452ad4579f1298b5604d3c671db6e16880ce /meta-oe
parentf732d17969f90e41dcb57a25567ad3ec4ba3a901 (diff)
downloadmeta-openembedded-4071e6b4b0a13a716c7473fd2f569a5b197c72bd.tar.gz
lvm2: enable native compilation
Required for cryptsetup-native, which useful for setting up dm-verity during a build. "native-sdk" gets added just in case that this may also be used in an SDK. Signed-off-by: Patrick Ohly <patrick.ohly@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2.inc28
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2_2.02.166.bb2
2 files changed, 25 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/lvm2/lvm2.inc b/meta-oe/recipes-support/lvm2/lvm2.inc
index 7bd26c02e..333223ad0 100644
--- a/meta-oe/recipes-support/lvm2/lvm2.inc
+++ b/meta-oe/recipes-support/lvm2/lvm2.inc
@@ -1,6 +1,6 @@
1SECTION = "utils" 1SECTION = "utils"
2DESCRIPTION = "LVM2 is a set of utilities to manage logical volumes in Linux." 2DESCRIPTION = "LVM2 is a set of utilities to manage logical volumes in Linux."
3DEPENDS = "udev" 3DEPENDS_append_class-target = " udev"
4LICENSE = "GPLv2 & LGPLv2" 4LICENSE = "GPLv2 & LGPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=12713b4d9386533feeb07d6e4831765a \ 5LIC_FILES_CHKSUM = "file://COPYING;md5=12713b4d9386533feeb07d6e4831765a \
6 file://COPYING.LIB;md5=fbc093901857fcd118f065f900982c24" 6 file://COPYING.LIB;md5=fbc093901857fcd118f065f900982c24"
@@ -16,11 +16,20 @@ S = "${WORKDIR}/LVM2.${PV}"
16 16
17inherit autotools-brokensep pkgconfig systemd 17inherit autotools-brokensep pkgconfig systemd
18 18
19PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)} \ 19PACKAGECONFIG_class-target ??= " \
20 ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)} \
20 thin-provisioning-tools \ 21 thin-provisioning-tools \
21 odirect \ 22 odirect \
22" 23"
23 24
25# odirect is enabled by default also for native compilation because
26# there's currently a bug in lib/device/dev-io.c which prevents
27# compiling without it. It is better to stick to configurations that
28# were actually tested by upstream...
29PACKAGECONFIG ??= " \
30 odirect \
31"
32
24PACKAGECONFIG[readline] = "--enable-readline,--disable-readline,readline" 33PACKAGECONFIG[readline] = "--enable-readline,--disable-readline,readline"
25PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux" 34PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux"
26PACKAGECONFIG[thin-provisioning-tools] = "--with-thin=internal,--with-thin=none,,thin-provisioning-tools" 35PACKAGECONFIG[thin-provisioning-tools] = "--with-thin=internal,--with-thin=none,,thin-provisioning-tools"
@@ -32,12 +41,9 @@ EXTRA_OECONF = "--with-user= \
32 --enable-realtime \ 41 --enable-realtime \
33 --enable-applib \ 42 --enable-applib \
34 --enable-cmdlib \ 43 --enable-cmdlib \
35 --enable-udev_sync \
36 --enable-udev_rules \
37 --enable-pkgconfig \ 44 --enable-pkgconfig \
38 --enable-dmeventd \ 45 --enable-dmeventd \
39 --enable-lvmetad \ 46 --enable-lvmetad \
40 --with-udev-prefix= \
41 --with-usrlibdir=${libdir} \ 47 --with-usrlibdir=${libdir} \
42 --with-systemdsystemunitdir=${systemd_system_unitdir} \ 48 --with-systemdsystemunitdir=${systemd_system_unitdir} \
43 --disable-thin_check_needs_check \ 49 --disable-thin_check_needs_check \
@@ -45,12 +51,24 @@ EXTRA_OECONF = "--with-user= \
45 --with-thin-dump=${sbindir}/thin_dump \ 51 --with-thin-dump=${sbindir}/thin_dump \
46 --with-thin-repair=${sbindir}/thin_repair \ 52 --with-thin-repair=${sbindir}/thin_repair \
47 --with-thin-restore=${sbindir}/thin_restore \ 53 --with-thin-restore=${sbindir}/thin_restore \
54 ${EXTRA_OECONF_UDEV} \
55"
56
57EXTRA_OECONF_UDEV = " \
58 --disable-udev_sync \
59 --disable-udev_rules \
60"
61EXTRA_OECONF_UDEV_class-target = " \
62 --enable-udev_sync \
63 --enable-udev_rules \
64 --with-udev-prefix= \
48" 65"
49 66
50CACHED_CONFIGUREVARS += "MODPROBE_CMD=${base_sbindir}/modprobe" 67CACHED_CONFIGUREVARS += "MODPROBE_CMD=${base_sbindir}/modprobe"
51 68
52do_install_append() { 69do_install_append() {
53 # Install machine specific configuration file 70 # Install machine specific configuration file
71 install -d ${D}${sysconfdir}/lvm
54 install -m 0644 ${WORKDIR}/lvm.conf ${D}${sysconfdir}/lvm/lvm.conf 72 install -m 0644 ${WORKDIR}/lvm.conf ${D}${sysconfdir}/lvm/lvm.conf
55 sed -i -e 's:@libdir@:${libdir}:g' ${D}${sysconfdir}/lvm/lvm.conf 73 sed -i -e 's:@libdir@:${libdir}:g' ${D}${sysconfdir}/lvm/lvm.conf
56 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then 74 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
diff --git a/meta-oe/recipes-support/lvm2/lvm2_2.02.166.bb b/meta-oe/recipes-support/lvm2/lvm2_2.02.166.bb
index 8476b01fa..6983bca4d 100644
--- a/meta-oe/recipes-support/lvm2/lvm2_2.02.166.bb
+++ b/meta-oe/recipes-support/lvm2/lvm2_2.02.166.bb
@@ -4,3 +4,5 @@ SRC_URI[md5sum] = "c5a54ee0b86703daaad6e856439e115a"
4SRC_URI[sha256sum] = "e120b066b85b224552efda40204488c5123de068725676fd6e5c8bc655051b94" 4SRC_URI[sha256sum] = "e120b066b85b224552efda40204488c5123de068725676fd6e5c8bc655051b94"
5 5
6DEPENDS += "autoconf-archive" 6DEPENDS += "autoconf-archive"
7
8BBCLASSEXTEND = "native nativesdk"