diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2012-03-06 10:21:15 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-03-09 07:03:52 +0100 |
commit | 112c1f86fc26c960cc2a69266f44e149b60ba307 (patch) | |
tree | 138527f34f5413624698199337e824670575e937 /meta-oe | |
parent | 81703d249df4d5e03808e9c6b219dd4b227df9c6 (diff) | |
download | meta-openembedded-112c1f86fc26c960cc2a69266f44e149b60ba307.tar.gz |
systemd: update to latest git
This is in preparation for the v44 release.
* drop 2 patches that aren't needed anymore
* fix more endianness problems
* fix journal crashes with large files
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
3 files changed, 7 insertions, 78 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd/0001-docs-fix-build-without-xsltproc.patch b/meta-oe/recipes-core/systemd/systemd/0001-docs-fix-build-without-xsltproc.patch deleted file mode 100644 index 390d65c72..000000000 --- a/meta-oe/recipes-core/systemd/systemd/0001-docs-fix-build-without-xsltproc.patch +++ /dev/null | |||
@@ -1,41 +0,0 @@ | |||
1 | From 7395173a5af08e9e58aed33e831d0bfc6515891d Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Sun, 2 Oct 2011 19:54:29 +0200 | ||
4 | Subject: [PATCH 1/2] docs: fix build without xsltproc | ||
5 | |||
6 | Make would choke on missing rules for man/systemd.1 | ||
7 | |||
8 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
9 | |||
10 | Upstream-status: rejected [fix your docbook install] | ||
11 | |||
12 | --- | ||
13 | Makefile.am | 5 +++++ | ||
14 | 1 files changed, 5 insertions(+), 0 deletions(-) | ||
15 | |||
16 | diff --git a/Makefile.am b/Makefile.am | ||
17 | index f1f975f..53f99a1 100644 | ||
18 | --- a/Makefile.am | ||
19 | +++ b/Makefile.am | ||
20 | @@ -649,6 +649,7 @@ EXTRA_DIST += \ | ||
21 | src/acl-util.h \ | ||
22 | src/logs-show.h | ||
23 | |||
24 | +if HAVE_XSLTPROC | ||
25 | MANPAGES = \ | ||
26 | man/systemd.1 \ | ||
27 | man/systemctl.1 \ | ||
28 | @@ -721,6 +722,10 @@ EXTRA_DIST += \ | ||
29 | $(XML_IN_FILES) \ | ||
30 | ${nodist_man_MANS:=.in} \ | ||
31 | ${XML_IN_FILES:.xml.in=.html.in} | ||
32 | +else | ||
33 | +MANPAGES = | ||
34 | +MANPAGES_ALIAS = | ||
35 | +endif | ||
36 | |||
37 | systemd_SOURCES = \ | ||
38 | src/main.c | ||
39 | -- | ||
40 | 1.7.2.5 | ||
41 | |||
diff --git a/meta-oe/recipes-core/systemd/systemd/0001-systemd-journald-fix-endianess-bug.patch b/meta-oe/recipes-core/systemd/systemd/0001-systemd-journald-fix-endianess-bug.patch deleted file mode 100644 index b41d5ebad..000000000 --- a/meta-oe/recipes-core/systemd/systemd/0001-systemd-journald-fix-endianess-bug.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | From d228134ff5af3bd0ef1087e9bee66583c1546553 Mon Sep 17 00:00:00 2001 | ||
2 | From: Dirk Eibach <eibach@gdsys.de> | ||
3 | Date: Wed, 29 Feb 2012 12:45:46 +0100 | ||
4 | Subject: [PATCH] systemd-journald: fix endianess bug | ||
5 | |||
6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
7 | --- | ||
8 | |||
9 | Upstream-status: Submitted | ||
10 | |||
11 | src/journal/journal-file.c | 2 +- | ||
12 | 1 files changed, 1 insertions(+), 1 deletions(-) | ||
13 | |||
14 | diff --git a/src/journal/journal-file.c b/src/journal/journal-file.c | ||
15 | index 20ca3f6..275caea 100644 | ||
16 | --- a/src/journal/journal-file.c | ||
17 | +++ b/src/journal/journal-file.c | ||
18 | @@ -238,7 +238,7 @@ static int journal_file_allocate(JournalFile *f, uint64_t offset, uint64_t size) | ||
19 | if (fstat(f->fd, &f->last_stat) < 0) | ||
20 | return -errno; | ||
21 | |||
22 | - f->header->arena_size = new_size - htole64(f->header->arena_offset); | ||
23 | + f->header->arena_size = htole64(new_size - le64toh(f->header->arena_offset)); | ||
24 | |||
25 | return 0; | ||
26 | } | ||
27 | -- | ||
28 | 1.7.7.4 | ||
29 | |||
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb index 4a8e9a199..918b31418 100644 --- a/meta-oe/recipes-core/systemd/systemd_git.bb +++ b/meta-oe/recipes-core/systemd/systemd_git.bb | |||
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.freedesktop.org/wiki/Software/systemd" | |||
3 | LICENSE = "GPLv2+" | 3 | LICENSE = "GPLv2+" |
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe" |
5 | 5 | ||
6 | DEPENDS = "xz docbook-sgml-dtd-4.1-native intltool-native gperf-native acl readline udev dbus libcap libcgroup tcp-wrappers" | 6 | DEPENDS = "xz kmod docbook-sgml-dtd-4.1-native intltool-native gperf-native acl readline udev dbus libcap libcgroup tcp-wrappers" |
7 | DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" | 7 | DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" |
8 | 8 | ||
9 | SERIAL_CONSOLE ?= "115200 /dev/ttyS0" | 9 | SERIAL_CONSOLE ?= "115200 /dev/ttyS0" |
@@ -14,16 +14,14 @@ inherit gitpkgv | |||
14 | PKGV = "v${GITPKGVTAG}" | 14 | PKGV = "v${GITPKGVTAG}" |
15 | 15 | ||
16 | PV = "git" | 16 | PV = "git" |
17 | PR = "r19" | 17 | PR = "r21" |
18 | 18 | ||
19 | inherit useradd pkgconfig autotools vala perlnative | 19 | inherit useradd pkgconfig autotools vala perlnative |
20 | 20 | ||
21 | SRCREV = "d26e4270409506cd398875216413b651d6ee7de6" | 21 | SRCREV = "48496df65c3ad1e3ad055d2b4632da7b73211715" |
22 | 22 | ||
23 | SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;protocol=git \ | 23 | SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;protocol=git \ |
24 | file://0001-docs-fix-build-without-xsltproc.patch \ | ||
25 | file://0002-systemd-logind-don-t-kill-user-processes-on-exit.patch \ | 24 | file://0002-systemd-logind-don-t-kill-user-processes-on-exit.patch \ |
26 | file://0001-systemd-journald-fix-endianess-bug.patch \ | ||
27 | ${UCLIBCPATCHES} \ | 25 | ${UCLIBCPATCHES} \ |
28 | " | 26 | " |
29 | UCLIBCPATCHES = "" | 27 | UCLIBCPATCHES = "" |
@@ -45,6 +43,7 @@ EXTRA_OECONF = " --with-distro=${SYSTEMDDISTRO} \ | |||
45 | ${@base_contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)} \ | 43 | ${@base_contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)} \ |
46 | --disable-gtk \ | 44 | --disable-gtk \ |
47 | --enable-xz \ | 45 | --enable-xz \ |
46 | --disable-manpages \ | ||
48 | " | 47 | " |
49 | 48 | ||
50 | # There's no docbook-xsl-native, so for the xsltproc check to false | 49 | # There's no docbook-xsl-native, so for the xsltproc check to false |
@@ -58,7 +57,7 @@ do_install() { | |||
58 | rm ${D}${base_libdir}/systemd/system/serial-getty* -f | 57 | rm ${D}${base_libdir}/systemd/system/serial-getty* -f |
59 | 58 | ||
60 | # provide support for initramfs | 59 | # provide support for initramfs |
61 | ln -s ${base_bindir}/systemd ${D}/init | 60 | ln -s ${base_libdir}/systemd/systemd ${D}/init |
62 | 61 | ||
63 | # create dir for journal | 62 | # create dir for journal |
64 | install -d ${D}${localstatedir}/log/journal | 63 | install -d ${D}${localstatedir}/log/journal |
@@ -134,7 +133,7 @@ RRECOMMENDS_${PN} += "systemd-serialgetty \ | |||
134 | # u-a for runlevel and telinit | 133 | # u-a for runlevel and telinit |
135 | 134 | ||
136 | pkg_postinst_systemd () { | 135 | pkg_postinst_systemd () { |
137 | update-alternatives --install ${base_sbindir}/init init ${base_bindir}/systemd 300 | 136 | update-alternatives --install ${base_sbindir}/init init ${base_libdir}/systemd/systemd 300 |
138 | update-alternatives --install ${base_sbindir}/halt halt ${base_bindir}/systemctl 300 | 137 | update-alternatives --install ${base_sbindir}/halt halt ${base_bindir}/systemctl 300 |
139 | update-alternatives --install ${base_sbindir}/reboot reboot ${base_bindir}/systemctl 300 | 138 | update-alternatives --install ${base_sbindir}/reboot reboot ${base_bindir}/systemctl 300 |
140 | update-alternatives --install ${base_sbindir}/shutdown shutdown ${base_bindir}/systemctl 300 | 139 | update-alternatives --install ${base_sbindir}/shutdown shutdown ${base_bindir}/systemctl 300 |
@@ -142,7 +141,7 @@ update-alternatives --install ${base_sbindir}/poweroff poweroff ${base_bindir}/s | |||
142 | } | 141 | } |
143 | 142 | ||
144 | pkg_prerm_systemd () { | 143 | pkg_prerm_systemd () { |
145 | update-alternatives --remove init ${base_bindir}/systemd | 144 | update-alternatives --remove init ${base_libdir}/systemd/systemd |
146 | update-alternatives --remove halt ${base_bindir}/systemctl | 145 | update-alternatives --remove halt ${base_bindir}/systemctl |
147 | update-alternatives --remove reboot ${base_bindir}/systemctl | 146 | update-alternatives --remove reboot ${base_bindir}/systemctl |
148 | update-alternatives --remove shutdown ${base_bindir}/systemctl | 147 | update-alternatives --remove shutdown ${base_bindir}/systemctl |