diff options
author | William A. Kennington III via Openembedded-devel <openembedded-devel@lists.openembedded.org> | 2018-10-11 11:46:51 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-10-11 13:35:19 -0700 |
commit | e4baf298cd658b37fd90134dc54a92c75fd117d9 (patch) | |
tree | 8e1053b6b137c2780cc0edeb15bc4d9e0e839afa /meta-oe | |
parent | 9f47fcd33739c92dc86003182ac32b2535db7f32 (diff) | |
download | meta-openembedded-e4baf298cd658b37fd90134dc54a92c75fd117d9.tar.gz |
dbus-broker: update to 16
Dropped the patches for version 13 as they are now included in the
upstream dbus-broker codebase.
Signed-off-by: William A. Kennington III <wak@google.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
3 files changed, 3 insertions, 72 deletions
diff --git a/meta-oe/recipes-core/dbus/dbus-broker/0001-Include-sys-wait.h-for-WEXITED-definition.patch b/meta-oe/recipes-core/dbus/dbus-broker/0001-Include-sys-wait.h-for-WEXITED-definition.patch deleted file mode 100644 index 8b8be074f..000000000 --- a/meta-oe/recipes-core/dbus/dbus-broker/0001-Include-sys-wait.h-for-WEXITED-definition.patch +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | From 99657fcbba288a843dc9e411bdfd3934b2074db5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 28 Jun 2018 07:11:58 -0700 | ||
4 | Subject: [PATCH] Include sys/wait.h for WEXITED definition | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | --- | ||
8 | Upstream-Status: Submitted | ||
9 | |||
10 | src/launch/main.c | 1 + | ||
11 | test/dbus/util-broker.c | 1 + | ||
12 | 2 files changed, 2 insertions(+) | ||
13 | |||
14 | diff --git a/src/launch/main.c b/src/launch/main.c | ||
15 | index f335d6b..6475ae6 100644 | ||
16 | --- a/src/launch/main.c | ||
17 | +++ b/src/launch/main.c | ||
18 | @@ -16,6 +16,7 @@ | ||
19 | #include <sys/socket.h> | ||
20 | #include <sys/types.h> | ||
21 | #include <sys/un.h> | ||
22 | +#include <sys/wait.h> | ||
23 | #include <systemd/sd-bus.h> | ||
24 | #include <systemd/sd-daemon.h> | ||
25 | #include <systemd/sd-event.h> | ||
26 | diff --git a/test/dbus/util-broker.c b/test/dbus/util-broker.c | ||
27 | index d9367ae..3bd021b 100644 | ||
28 | --- a/test/dbus/util-broker.c | ||
29 | +++ b/test/dbus/util-broker.c | ||
30 | @@ -11,6 +11,7 @@ | ||
31 | #include <sys/socket.h> | ||
32 | #include <sys/types.h> | ||
33 | #include <sys/un.h> | ||
34 | +#include <sys/wait.h> | ||
35 | #include <systemd/sd-bus.h> | ||
36 | #include <systemd/sd-event.h> | ||
37 | #include "dbus/protocol.h" | ||
diff --git a/meta-oe/recipes-core/dbus/dbus-broker/0002-Use-getenv-instead-of-secure_getenv-on-musl.patch b/meta-oe/recipes-core/dbus/dbus-broker/0002-Use-getenv-instead-of-secure_getenv-on-musl.patch deleted file mode 100644 index bebd2145f..000000000 --- a/meta-oe/recipes-core/dbus/dbus-broker/0002-Use-getenv-instead-of-secure_getenv-on-musl.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | From 95a5541f8b75f7896ee6e5e71edd61838cab3c8b Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 28 Jun 2018 07:16:34 -0700 | ||
4 | Subject: [PATCH] Use getenv instead of secure_getenv on musl | ||
5 | |||
6 | musl doesnt implement secure version | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | Upstream-Status: Pending | ||
11 | |||
12 | src/launch/main.c | 4 ++++ | ||
13 | 1 file changed, 4 insertions(+) | ||
14 | |||
15 | diff --git a/src/launch/main.c b/src/launch/main.c | ||
16 | index 6475ae6..6468d84 100644 | ||
17 | --- a/src/launch/main.c | ||
18 | +++ b/src/launch/main.c | ||
19 | @@ -30,6 +30,10 @@ | ||
20 | #include "util/log.h" | ||
21 | #include "util/misc.h" | ||
22 | |||
23 | +#ifndef __GLIBC__ | ||
24 | +#define secure_getenv getenv | ||
25 | +#endif | ||
26 | + | ||
27 | typedef struct Manager Manager; | ||
28 | typedef struct Service Service; | ||
29 | |||
diff --git a/meta-oe/recipes-core/dbus/dbus-broker_git.bb b/meta-oe/recipes-core/dbus/dbus-broker_git.bb index 4a025cfeb..ac2c50063 100644 --- a/meta-oe/recipes-core/dbus/dbus-broker_git.bb +++ b/meta-oe/recipes-core/dbus/dbus-broker_git.bb | |||
@@ -8,13 +8,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=7b486c2338d225a1405d979ed2c15ce8" | |||
8 | 8 | ||
9 | DEPENDS = "dbus glib-2.0 expat" | 9 | DEPENDS = "dbus glib-2.0 expat" |
10 | 10 | ||
11 | PV = "13+git${SRCPV}" | 11 | PV = "16+git${SRCPV}" |
12 | SRCREV = "1165025e26c3b46160402841dadf08d3d42f5cbb" | 12 | SRCREV = "fc874afa0992d0c75ec25acb43d344679f0ee7d2" |
13 | 13 | ||
14 | SRC_URI = "git://github.com/bus1/dbus-broker;protocol=git \ | 14 | SRC_URI = "git://github.com/bus1/dbus-broker;protocol=git" |
15 | file://0001-Include-sys-wait.h-for-WEXITED-definition.patch \ | ||
16 | file://0002-Use-getenv-instead-of-secure_getenv-on-musl.patch \ | ||
17 | " | ||
18 | 15 | ||
19 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
20 | 17 | ||