diff options
author | Gary Thomas <gary@mlbassoc.com> | 2015-01-30 16:20:45 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-02-12 19:33:45 +0100 |
commit | e38e5e2dc744c73c3b0aff6a9937a70e8162cb9d (patch) | |
tree | 003947ab764504a084405c968705ec3e95137e6c /meta-oe | |
parent | 5fd605ae3a2c32867cec247742460b1768b3c7e6 (diff) | |
download | meta-openembedded-e38e5e2dc744c73c3b0aff6a9937a70e8162cb9d.tar.gz |
rng-tools: Fixes for latest OE layouts
The current recipe has a few installation errors:
* The manipulation of configurable paths drops a '/'
* The init script defaults are placed in the wrong file
* Finer control over init script start/stop
* The default device is non-standard
This patch fixes these little nits and makes the package usable again.
Based on the original patch:
http://patchwork.openembedded.org/patch/41049/
Signed-off-by: Gary Thomas <gary@mlbassoc.com>
Signed-off-by: Ting Liu <ting.liu@freescale.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-support/rng-tools/files/default | 3 | ||||
-rw-r--r-- | meta-oe/recipes-support/rng-tools/rng-tools_4.bb | 6 |
2 files changed, 5 insertions, 4 deletions
diff --git a/meta-oe/recipes-support/rng-tools/files/default b/meta-oe/recipes-support/rng-tools/files/default index ab7cd9327..7aede9be0 100644 --- a/meta-oe/recipes-support/rng-tools/files/default +++ b/meta-oe/recipes-support/rng-tools/files/default | |||
@@ -1,2 +1,3 @@ | |||
1 | # Specify rng device | 1 | # Specify rng device |
2 | RNG_DEVICE=/dev/hwrng | 2 | #RNG_DEVICE=/dev/hwrng |
3 | RNG_DEVICE=/dev/urandom | ||
diff --git a/meta-oe/recipes-support/rng-tools/rng-tools_4.bb b/meta-oe/recipes-support/rng-tools/rng-tools_4.bb index 0b40fc547..b3d880ff3 100644 --- a/meta-oe/recipes-support/rng-tools/rng-tools_4.bb +++ b/meta-oe/recipes-support/rng-tools/rng-tools_4.bb | |||
@@ -24,13 +24,13 @@ do_install_append() { | |||
24 | if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then | 24 | if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then |
25 | install -d "${D}${sysconfdir}/init.d" | 25 | install -d "${D}${sysconfdir}/init.d" |
26 | install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/rng-tools | 26 | install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/rng-tools |
27 | sed -i -e 's,/etc/,${sysconfdir}/,' -e 's,/usr/sbin/,${sbindir},' \ | 27 | sed -i -e 's,/etc/,${sysconfdir}/,' -e 's,/usr/sbin/,${sbindir}/,' \ |
28 | ${D}${sysconfdir}/init.d/rng-tools | 28 | ${D}${sysconfdir}/init.d/rng-tools |
29 | 29 | ||
30 | install -d "${D}${sysconfdir}/default" | 30 | install -d "${D}${sysconfdir}/default" |
31 | install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default | 31 | install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/rng-tools |
32 | fi | 32 | fi |
33 | } | 33 | } |
34 | 34 | ||
35 | INITSCRIPT_NAME = "rng-tools" | 35 | INITSCRIPT_NAME = "rng-tools" |
36 | INITSCRIPT_PARAMS = "defaults" | 36 | INITSCRIPT_PARAMS = "start 30 S . stop 30 0 6 1 ." |