diff options
author | Martin Siegumfeldt <mns@gomspace.com> | 2019-10-30 14:40:26 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-11-01 17:22:52 -0700 |
commit | bfe856b5799bec8ba712416c7df02e3a6b0bf123 (patch) | |
tree | 3acb833eb26a3eb04877672f3f25fa7ad7b3b474 /meta-oe | |
parent | ccd88c0c040657aa810dc11ea08408ae3d4c645d (diff) | |
download | meta-openembedded-bfe856b5799bec8ba712416c7df02e3a6b0bf123.tar.gz |
libiio: add python3 packageconfig
* used for enabling python bindings - note that behavior is changed
from 'opt-out' to 'opt-in'
* config is used for potentially inheriting distutils3-base
* also decapitalize packageconfig names similar to other recipes
Signed-off-by: Martin Siegumfeldt <mns@gomspace.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-support/libiio/libiio_git.bb | 11 |
1 files changed, 7 insertions, 4 deletions
diff --git a/meta-oe/recipes-support/libiio/libiio_git.bb b/meta-oe/recipes-support/libiio/libiio_git.bb index e6e0eaef8..b53ba4647 100644 --- a/meta-oe/recipes-support/libiio/libiio_git.bb +++ b/meta-oe/recipes-support/libiio/libiio_git.bb | |||
@@ -12,7 +12,7 @@ SRC_URI = "git://github.com/analogdevicesinc/libiio.git;protocol=https" | |||
12 | 12 | ||
13 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |
14 | 14 | ||
15 | inherit cmake python3native systemd distutils3-base | 15 | inherit cmake python3native systemd |
16 | 16 | ||
17 | DEPENDS = " \ | 17 | DEPENDS = " \ |
18 | flex-native bison-native libaio \ | 18 | flex-native bison-native libaio \ |
@@ -25,10 +25,13 @@ EXTRA_OECMAKE = " \ | |||
25 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '-DWITH_SYSTEMD=ON -DSYSTEMD_UNIT_INSTALL_DIR=${systemd_system_unitdir}', '', d)} \ | 25 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '-DWITH_SYSTEMD=ON -DSYSTEMD_UNIT_INSTALL_DIR=${systemd_system_unitdir}', '', d)} \ |
26 | " | 26 | " |
27 | 27 | ||
28 | PACKAGECONFIG ??= "USB_BACKEND NETWORK_BACKEND" | 28 | PACKAGECONFIG ??= "usb_backend network_backend" |
29 | 29 | ||
30 | PACKAGECONFIG[USB_BACKEND] = "-DWITH_USB_BACKEND=ON,-DWITH_USB_BACKEND=OFF,libusb1,libxml2" | 30 | PACKAGECONFIG[usb_backend] = "-DWITH_USB_BACKEND=ON,-DWITH_USB_BACKEND=OFF,libusb1,libxml2" |
31 | PACKAGECONFIG[NETWORK_BACKEND] = "-DWITH_NETWORK_BACKEND=ON,-DWITH_NETWORK_BACKEND=OFF,libxml2" | 31 | PACKAGECONFIG[network_backend] = "-DWITH_NETWORK_BACKEND=ON,-DWITH_NETWORK_BACKEND=OFF,libxml2" |
32 | PACKAGECONFIG[libiio-python3] = "-DPYTHON_BINDINGS=ON,-DPYTHON_BINDINGS=OFF" | ||
33 | |||
34 | inherit ${@bb.utils.contains('PACKAGECONFIG', 'libiio-python3', 'distutils3-base', '', d)} | ||
32 | 35 | ||
33 | PACKAGES =+ "${PN}-iiod ${PN}-tests ${PN}-${PYTHON_PN}" | 36 | PACKAGES =+ "${PN}-iiod ${PN}-tests ${PN}-${PYTHON_PN}" |
34 | 37 | ||