summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2013-03-13 21:23:46 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-03-18 16:31:33 +0100
commitb55fbf81bed5d56ce4592abed9210f27870f096f (patch)
tree2583c0b79a67af8e2e7138253867df0aa83b4a8a /meta-oe
parent19eb91d66d5ec899a781a14f3b9b50469d741d89 (diff)
downloadmeta-openembedded-b55fbf81bed5d56ce4592abed9210f27870f096f.tar.gz
xfsprogs: fix compile with uclibc
Uclibc doesn't have aio.h, which xfsprogs checks for. However, xfsprogs doesn't use aio. Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/xfsprogs/xfsprogs-3.1.8/drop-configure-check-for-aio.patch99
-rw-r--r--meta-oe/recipes-support/xfsprogs/xfsprogs_3.1.8.bb10
2 files changed, 108 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/xfsprogs/xfsprogs-3.1.8/drop-configure-check-for-aio.patch b/meta-oe/recipes-support/xfsprogs/xfsprogs-3.1.8/drop-configure-check-for-aio.patch
new file mode 100644
index 000000000..a1c60424a
--- /dev/null
+++ b/meta-oe/recipes-support/xfsprogs/xfsprogs-3.1.8/drop-configure-check-for-aio.patch
@@ -0,0 +1,99 @@
1Upstream-Status: Pending
2
3From a38bf800a655ea32cbddd6504e15c2f18597fd13 Mon Sep 17 00:00:00 2001
4From: Andreas Oberritter <obi@opendreambox.org>
5Date: Wed, 13 Mar 2013 14:40:13 +0100
6Subject: [PATCH] xfsprogs: drop configure check for aio
7
8It's unused and breaks compilation with uclibc.
9
10Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
11---
12 configure.in | 6 +++---
13 m4/Makefile | 1 -
14 m4/package_aiodev.m4 | 37 -------------------------------------
15 3 files changed, 3 insertions(+), 41 deletions(-)
16 delete mode 100644 m4/package_aiodev.m4
17
18diff --git a/configure.in b/configure.in
19index 664c0e9..f7d35f1 100644
20--- a/configure.in
21+++ b/configure.in
22@@ -46,6 +46,9 @@ AC_ARG_ENABLE(lib64,
23 enable_lib64=yes)
24 AC_SUBST(enable_lib64)
25
26+librt="-lrt"
27+AC_SUBST(librt)
28+
29 #
30 # If the user specified a libdir ending in lib64 do not append another
31 # 64 to the library names.
32@@ -91,9 +94,6 @@ AC_PACKAGE_GLOBALS(xfsprogs)
33 AC_PACKAGE_UTILITIES(xfsprogs)
34 AC_MULTILIB($enable_lib64)
35
36-AC_PACKAGE_NEED_AIO_H
37-AC_PACKAGE_NEED_LIO_LISTIO
38-
39 AC_PACKAGE_NEED_UUID_H
40 AC_PACKAGE_NEED_UUIDCOMPARE
41
42diff --git a/m4/Makefile b/m4/Makefile
43index 654a4fb..d282f0a 100644
44--- a/m4/Makefile
45+++ b/m4/Makefile
46@@ -14,7 +14,6 @@ CONFIGURE = \
47
48 LSRCFILES = \
49 manual_format.m4 \
50- package_aiodev.m4 \
51 package_blkid.m4 \
52 package_globals.m4 \
53 package_libcdev.m4 \
54diff --git a/m4/package_aiodev.m4 b/m4/package_aiodev.m4
55deleted file mode 100644
56index 490d9c8..0000000
57--- a/m4/package_aiodev.m4
58+++ /dev/null
59@@ -1,37 +0,0 @@
60-#
61-# Check if we have a libaio.h installed
62-#
63-AC_DEFUN([AC_PACKAGE_WANT_AIO],
64- [ AC_CHECK_HEADERS(libaio.h, [ have_aio=true ], [ have_aio=false ])
65- AC_SUBST(have_aio)
66- ])
67-
68-#
69-# Check if we have an aio.h installed
70-#
71-AC_DEFUN([AC_PACKAGE_NEED_AIO_H],
72- [ AC_CHECK_HEADERS(aio.h)
73- if test $ac_cv_header_aio_h = no; then
74- echo
75- echo 'FATAL ERROR: could not find a valid <aio.h> header.'
76- exit 1
77- fi
78- ])
79-
80-#
81-# Check if we have the lio_listio routine in either libc/librt
82-#
83-AC_DEFUN([AC_PACKAGE_NEED_LIO_LISTIO],
84- [ AC_CHECK_FUNCS(lio_listio)
85- if test $ac_cv_func_lio_listio = yes; then
86- librt=""
87- else
88- AC_CHECK_LIB(rt, lio_listio,, [
89- echo
90- echo 'FATAL ERROR: could not find a library with lio_listio.'
91- exit 1],[-lpthread])
92- librt="-lrt"
93- fi
94- AC_SUBST(librt)
95- ])
96-
97--
981.7.10.4
99
diff --git a/meta-oe/recipes-support/xfsprogs/xfsprogs_3.1.8.bb b/meta-oe/recipes-support/xfsprogs/xfsprogs_3.1.8.bb
index f83561d91..ef5224b5f 100644
--- a/meta-oe/recipes-support/xfsprogs/xfsprogs_3.1.8.bb
+++ b/meta-oe/recipes-support/xfsprogs/xfsprogs_3.1.8.bb
@@ -5,10 +5,11 @@ LICENSE = "GPLv2"
5LICENSE_libhandle = "LGPLv2.1" 5LICENSE_libhandle = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://doc/COPYING;md5=dbdb5f4329b7e7145de650e9ecd4ac2a" 6LIC_FILES_CHKSUM = "file://doc/COPYING;md5=dbdb5f4329b7e7145de650e9ecd4ac2a"
7DEPENDS = "util-linux" 7DEPENDS = "util-linux"
8PR = "r0" 8PR = "r1"
9 9
10SRC_URI = "ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz \ 10SRC_URI = "ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz \
11 file://remove-install-as-user.patch \ 11 file://remove-install-as-user.patch \
12 file://drop-configure-check-for-aio.patch \
12" 13"
13 14
14SRC_URI[md5sum] = "f70b2e7200d4c29f0af1cf70e7be1db6" 15SRC_URI[md5sum] = "f70b2e7200d4c29f0af1cf70e7be1db6"
@@ -26,6 +27,13 @@ FILES_libhandle = "${base_libdir}/libhandle${SOLIBS}"
26 27
27EXTRA_OECONF = "--enable-gettext=no" 28EXTRA_OECONF = "--enable-gettext=no"
28do_configure () { 29do_configure () {
30 # Prevent Makefile from calling configure without arguments,
31 # when do_configure gets called for a second time.
32 rm -f include/builddefs include/platform_defs.h
33 # Recreate configure script.
34 rm -f configure
35 oe_runmake configure
36 # Configure.
29 export DEBUG="-DNDEBUG" 37 export DEBUG="-DNDEBUG"
30 gnu-configize --force 38 gnu-configize --force
31 oe_runconf 39 oe_runconf