diff options
author | Eric BENARD <eric@eukrea.com> | 2012-11-27 16:16:43 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-12-04 10:43:10 +0100 |
commit | 94a59521dc54409ca2438ff5496991ed3e8d43b9 (patch) | |
tree | 66d5927ddc45ce2969190dcd586c683bd9f020ce /meta-oe | |
parent | c1a900b011247193d40ed9e09371f37efee6eb13 (diff) | |
download | meta-openembedded-94a59521dc54409ca2438ff5496991ed3e8d43b9.tar.gz |
php: enable php-fpm
- php-fpm is an alternative PHP FastCGI implementation which seems to
be now prefered to php-fcgi
- this patch enable the build of php-fpm and packages it in its own
package
- it's tested with hiawatha on an armv5te target
Signed-off-by: Eric BĂ©nard <eric@eukrea.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-devtools/php/php.inc | 21 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/php/php/fix-fpm-cross-compile.patch | 38 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/php/php/php-fpm.conf | 510 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/php/php_5.3.19.bb | 2 |
4 files changed, 567 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/php/php.inc b/meta-oe/recipes-devtools/php/php.inc index 10dc15437..7850c1ea5 100644 --- a/meta-oe/recipes-devtools/php/php.inc +++ b/meta-oe/recipes-devtools/php/php.inc | |||
@@ -7,7 +7,7 @@ DEPENDS = "zlib libxml2 virtual/libiconv php-native lemon-native mysql5 \ | |||
7 | libc-client openssl sqlite3" | 7 | libc-client openssl sqlite3" |
8 | DEPENDS_virtclass-native = "zlib-native libxml2-native" | 8 | DEPENDS_virtclass-native = "zlib-native libxml2-native" |
9 | 9 | ||
10 | INC_PR = "r1" | 10 | INC_PR = "r2" |
11 | 11 | ||
12 | SRC_URI = "http://www.php.net/distributions/php-${PV}.tar.bz2" | 12 | SRC_URI = "http://www.php.net/distributions/php-${PV}.tar.bz2" |
13 | 13 | ||
@@ -20,7 +20,7 @@ SSTATE_SCAN_FILES += "build-defs.h" | |||
20 | # Common EXTRA_OECONF | 20 | # Common EXTRA_OECONF |
21 | COMMON_EXTRA_OECONF = "--enable-sockets --enable-pcntl --enable-shared" | 21 | COMMON_EXTRA_OECONF = "--enable-sockets --enable-pcntl --enable-shared" |
22 | EXTRA_OECONF = "--enable-mbstring --enable-discard-path --enable-wddx \ | 22 | EXTRA_OECONF = "--enable-mbstring --enable-discard-path --enable-wddx \ |
23 | --enable-magic-quotes --enable-fastcgi \ | 23 | --enable-magic-quotes --enable-fastcgi --enable-fpm \ |
24 | --with-imap=${STAGING_DIR_HOST} \ | 24 | --with-imap=${STAGING_DIR_HOST} \ |
25 | --with-gettext=${STAGING_LIBDIR}/.. \ | 25 | --with-gettext=${STAGING_LIBDIR}/.. \ |
26 | --with-imap-ssl=${STAGING_DIR_HOST} \ | 26 | --with-imap-ssl=${STAGING_DIR_HOST} \ |
@@ -57,25 +57,38 @@ do_install () { | |||
57 | 57 | ||
58 | # fixme | 58 | # fixme |
59 | do_install_append_pn-php() { | 59 | do_install_append_pn-php() { |
60 | mv ${D}/${STAGING_DIR_NATIVE}/${sysconfdir} ${D}/${sysconfdir} | 60 | install -d ${D}/${sysconfdir}/ |
61 | mv ${D}/${STAGING_DIR_NATIVE}/${sysconfdir}/* ${D}/${sysconfdir}/ | ||
61 | rm -rf ${D}/${STAGING_DIR_NATIVE} | 62 | rm -rf ${D}/${STAGING_DIR_NATIVE} |
62 | rm -rf ${D}/.registry | 63 | rm -rf ${D}/.registry |
63 | rm -rf ${D}/.channels | 64 | rm -rf ${D}/.channels |
64 | rm -rf ${D}/.[a-z]* | 65 | rm -rf ${D}/.[a-z]* |
65 | sed -i 's:${STAGING_DIR_NATIVE}::g' ${D}/${sysconfdir}/pear.conf | 66 | sed -i 's:${STAGING_DIR_NATIVE}::g' ${D}/${sysconfdir}/pear.conf |
67 | install -m 0644 ${WORKDIR}/php-fpm.conf ${D}/${sysconfdir}/php-fpm.conf | ||
68 | install -d ${D}${sysconfdir}/init.d | ||
69 | sed -i 's:=/usr/sbin:=${sbindir}:g' ${S}/sapi/fpm/init.d.php-fpm | ||
70 | sed -i 's:=/etc:=${sysconfdir}:g' ${S}/sapi/fpm/init.d.php-fpm | ||
71 | sed -i 's:=/var:=${localstatedir}:g' ${S}/sapi/fpm/init.d.php-fpm | ||
72 | install -m 0755 ${S}/sapi/fpm/init.d.php-fpm ${D}${sysconfdir}/init.d/php-fpm | ||
66 | } | 73 | } |
67 | 74 | ||
68 | PACKAGES = "${PN}-dbg ${PN}-cli ${PN}-cgi ${PN}-pear ${PN}-dev ${PN}-staticdev ${PN}-doc ${PN}" | 75 | PACKAGES = "${PN}-dbg ${PN}-cli ${PN}-cgi ${PN}-fpm ${PN}-pear ${PN}-dev ${PN}-staticdev ${PN}-doc ${PN}" |
69 | 76 | ||
70 | RDEPENDS_${PN}-pear = "${PN}" | 77 | RDEPENDS_${PN}-pear = "${PN}" |
71 | RDEPENDS_${PN}-cli = "${PN}" | 78 | RDEPENDS_${PN}-cli = "${PN}" |
72 | RDEPENDS_${PN}-dev = "${PN}" | 79 | RDEPENDS_${PN}-dev = "${PN}" |
73 | 80 | ||
81 | INITSCRIPT_PACKAGES = "${PN}-fpm" | ||
82 | inherit update-rc.d | ||
74 | 83 | ||
75 | FILES_${PN}-dbg =+ "${bindir}/.debug" | 84 | FILES_${PN}-dbg =+ "${bindir}/.debug" |
76 | FILES_${PN}-doc += "${libdir}/php/doc" | 85 | FILES_${PN}-doc += "${libdir}/php/doc" |
77 | FILES_${PN}-cli = "${bindir}/php" | 86 | FILES_${PN}-cli = "${bindir}/php" |
78 | FILES_${PN}-cgi = "${bindir}/php-cgi" | 87 | FILES_${PN}-cgi = "${bindir}/php-cgi" |
88 | FILES_${PN}-fpm = "${sbindir}/php-fpm ${sysconfdir}/php-fpm.conf ${datadir}/fpm ${sysconfdir}/init.d/php-fpm" | ||
89 | CONFFILES_${PN}-fpm = "${sysconfdir}/php-fpm.conf" | ||
90 | INITSCRIPT_NAME_${PN}-fpm = "php-fpm" | ||
91 | INITSCRIPT_PARAMS_${PN}-fpm = "defaults 60" | ||
79 | FILES_${PN}-pear = "${bindir}/pear* ${bindir}/pecl ${libdir}/php/PEAR \ | 92 | FILES_${PN}-pear = "${bindir}/pear* ${bindir}/pecl ${libdir}/php/PEAR \ |
80 | ${libdir}/php/PEAR.php ${libdir}/php/System.php \ | 93 | ${libdir}/php/PEAR.php ${libdir}/php/System.php \ |
81 | ${libdir}php/peclcmd.php ${libdir}/php/pearcmd.php \ | 94 | ${libdir}php/peclcmd.php ${libdir}/php/pearcmd.php \ |
diff --git a/meta-oe/recipes-devtools/php/php/fix-fpm-cross-compile.patch b/meta-oe/recipes-devtools/php/php/fix-fpm-cross-compile.patch new file mode 100644 index 000000000..b009347a2 --- /dev/null +++ b/meta-oe/recipes-devtools/php/php/fix-fpm-cross-compile.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From 0b44f16ea2f18a08eb1249db6621840527eab5e0 Mon Sep 17 00:00:00 2001 | ||
2 | From: Jerome Loyet <fat@php.net> | ||
3 | Date: Wed, 23 May 2012 11:40:22 +0200 | ||
4 | Subject: [PATCH] - Fixed bug #61839 (Unable to cross-compile PHP with | ||
5 | --enable-fpm) | ||
6 | |||
7 | --- | ||
8 | Upstream-Status: Applied | ||
9 | http://git.php.net/?p=php-src.git;a=commit;h=0b44f16ea2f18a08eb1249db6621840527eab5e0 | ||
10 | |||
11 | NEWS | 1 + | ||
12 | sapi/fpm/config.m4 | 4 ++++ | ||
13 | 2 files changed, 5 insertions(+) | ||
14 | |||
15 | diff --git a/sapi/fpm/config.m4 b/sapi/fpm/config.m4 | ||
16 | index 8962810..6c860c9 100644 | ||
17 | --- a/sapi/fpm/config.m4 | ||
18 | +++ b/sapi/fpm/config.m4 | ||
19 | @@ -192,6 +192,8 @@ AC_DEFUN([AC_FPM_TRACE], | ||
20 | have_ptrace=no | ||
21 | have_broken_ptrace=yes | ||
22 | AC_MSG_RESULT([no]) | ||
23 | + ], [ | ||
24 | + AC_MSG_RESULT([skipped (cross compiling)]) | ||
25 | ]) | ||
26 | fi | ||
27 | |||
28 | @@ -264,6 +266,8 @@ AC_DEFUN([AC_FPM_TRACE], | ||
29 | ], [ | ||
30 | proc_mem_file="" | ||
31 | AC_MSG_RESULT([no]) | ||
32 | + ], [ | ||
33 | + AC_MSG_RESULT([skipped (cross compiling)]) | ||
34 | ]) | ||
35 | fi | ||
36 | |||
37 | -- | ||
38 | 1.7.11.5 | ||
diff --git a/meta-oe/recipes-devtools/php/php/php-fpm.conf b/meta-oe/recipes-devtools/php/php/php-fpm.conf new file mode 100644 index 000000000..21e3dfb5c --- /dev/null +++ b/meta-oe/recipes-devtools/php/php/php-fpm.conf | |||
@@ -0,0 +1,510 @@ | |||
1 | ;;;;;;;;;;;;;;;;;;;;; | ||
2 | ; FPM Configuration ; | ||
3 | ;;;;;;;;;;;;;;;;;;;;; | ||
4 | |||
5 | ; All relative paths in this configuration file are relative to PHP's install | ||
6 | ; prefix (/usr). This prefix can be dynamicaly changed by using the | ||
7 | ; '-p' argument from the command line. | ||
8 | |||
9 | ; Include one or more files. If glob(3) exists, it is used to include a bunch of | ||
10 | ; files from a glob(3) pattern. This directive can be used everywhere in the | ||
11 | ; file. | ||
12 | ; Relative path can also be used. They will be prefixed by: | ||
13 | ; - the global prefix if it's been set (-p arguement) | ||
14 | ; - /usr otherwise | ||
15 | ;include=etc/fpm.d/*.conf | ||
16 | |||
17 | ;;;;;;;;;;;;;;;;;; | ||
18 | ; Global Options ; | ||
19 | ;;;;;;;;;;;;;;;;;; | ||
20 | |||
21 | [global] | ||
22 | ; Pid file | ||
23 | ; Note: the default prefix is /var | ||
24 | ; Default Value: none | ||
25 | ;pid = run/php-fpm.pid | ||
26 | |||
27 | ; Error log file | ||
28 | ; If it's set to "syslog", log is sent to syslogd instead of being written | ||
29 | ; in a local file. | ||
30 | ; Note: the default prefix is /var | ||
31 | ; Default Value: log/php-fpm.log | ||
32 | ;error_log = log/php-fpm.log | ||
33 | |||
34 | ; syslog_facility is used to specify what type of program is logging the | ||
35 | ; message. This lets syslogd specify that messages from different facilities | ||
36 | ; will be handled differently. | ||
37 | ; See syslog(3) for possible values (ex daemon equiv LOG_DAEMON) | ||
38 | ; Default Value: daemon | ||
39 | ;syslog.facility = daemon | ||
40 | |||
41 | ; syslog_ident is prepended to every message. If you have multiple FPM | ||
42 | ; instances running on the same server, you can change the default value | ||
43 | ; which must suit common needs. | ||
44 | ; Default Value: php-fpm | ||
45 | ;syslog.ident = php-fpm | ||
46 | |||
47 | ; Log level | ||
48 | ; Possible Values: alert, error, warning, notice, debug | ||
49 | ; Default Value: notice | ||
50 | ;log_level = notice | ||
51 | |||
52 | ; If this number of child processes exit with SIGSEGV or SIGBUS within the time | ||
53 | ; interval set by emergency_restart_interval then FPM will restart. A value | ||
54 | ; of '0' means 'Off'. | ||
55 | ; Default Value: 0 | ||
56 | ;emergency_restart_threshold = 0 | ||
57 | |||
58 | ; Interval of time used by emergency_restart_interval to determine when | ||
59 | ; a graceful restart will be initiated. This can be useful to work around | ||
60 | ; accidental corruptions in an accelerator's shared memory. | ||
61 | ; Available Units: s(econds), m(inutes), h(ours), or d(ays) | ||
62 | ; Default Unit: seconds | ||
63 | ; Default Value: 0 | ||
64 | ;emergency_restart_interval = 0 | ||
65 | |||
66 | ; Time limit for child processes to wait for a reaction on signals from master. | ||
67 | ; Available units: s(econds), m(inutes), h(ours), or d(ays) | ||
68 | ; Default Unit: seconds | ||
69 | ; Default Value: 0 | ||
70 | ;process_control_timeout = 0 | ||
71 | |||
72 | ; The maximum number of processes FPM will fork. This has been design to control | ||
73 | ; the global number of processes when using dynamic PM within a lot of pools. | ||
74 | ; Use it with caution. | ||
75 | ; Note: A value of 0 indicates no limit | ||
76 | ; Default Value: 0 | ||
77 | ; process.max = 128 | ||
78 | |||
79 | ; Specify the nice(2) priority to apply to the master process (only if set) | ||
80 | ; The value can vary from -19 (highest priority) to 20 (lower priority) | ||
81 | ; Note: - It will only work if the FPM master process is launched as root | ||
82 | ; - The pool process will inherit the master process priority | ||
83 | ; unless it specified otherwise | ||
84 | ; Default Value: no set | ||
85 | ; process.priority = -19 | ||
86 | |||
87 | ; Send FPM to background. Set to 'no' to keep FPM in foreground for debugging. | ||
88 | ; Default Value: yes | ||
89 | ;daemonize = yes | ||
90 | |||
91 | ; Set open file descriptor rlimit for the master process. | ||
92 | ; Default Value: system defined value | ||
93 | ;rlimit_files = 1024 | ||
94 | |||
95 | ; Set max core size rlimit for the master process. | ||
96 | ; Possible Values: 'unlimited' or an integer greater or equal to 0 | ||
97 | ; Default Value: system defined value | ||
98 | ;rlimit_core = 0 | ||
99 | |||
100 | ; Specify the event mechanism FPM will use. The following is available: | ||
101 | ; - select (any POSIX os) | ||
102 | ; - poll (any POSIX os) | ||
103 | ; - epoll (linux >= 2.5.44) | ||
104 | ; - kqueue (FreeBSD >= 4.1, OpenBSD >= 2.9, NetBSD >= 2.0) | ||
105 | ; - /dev/poll (Solaris >= 7) | ||
106 | ; - port (Solaris >= 10) | ||
107 | ; Default Value: not set (auto detection) | ||
108 | ; events.mechanism = epoll | ||
109 | |||
110 | ;;;;;;;;;;;;;;;;;;;; | ||
111 | ; Pool Definitions ; | ||
112 | ;;;;;;;;;;;;;;;;;;;; | ||
113 | |||
114 | ; Multiple pools of child processes may be started with different listening | ||
115 | ; ports and different management options. The name of the pool will be | ||
116 | ; used in logs and stats. There is no limitation on the number of pools which | ||
117 | ; FPM can handle. Your system will tell you anyway :) | ||
118 | |||
119 | ; Start a new pool named 'www'. | ||
120 | ; the variable $pool can we used in any directive and will be replaced by the | ||
121 | ; pool name ('www' here) | ||
122 | [www] | ||
123 | |||
124 | ; Per pool prefix | ||
125 | ; It only applies on the following directives: | ||
126 | ; - 'slowlog' | ||
127 | ; - 'listen' (unixsocket) | ||
128 | ; - 'chroot' | ||
129 | ; - 'chdir' | ||
130 | ; - 'php_values' | ||
131 | ; - 'php_admin_values' | ||
132 | ; When not set, the global prefix (or /usr) applies instead. | ||
133 | ; Note: This directive can also be relative to the global prefix. | ||
134 | ; Default Value: none | ||
135 | ;prefix = /path/to/pools/$pool | ||
136 | |||
137 | ; Unix user/group of processes | ||
138 | ; Note: The user is mandatory. If the group is not set, the default user's group | ||
139 | ; will be used. | ||
140 | user = nobody | ||
141 | ;group = nobody | ||
142 | |||
143 | ; The address on which to accept FastCGI requests. | ||
144 | ; Valid syntaxes are: | ||
145 | ; 'ip.add.re.ss:port' - to listen on a TCP socket to a specific address on | ||
146 | ; a specific port; | ||
147 | ; 'port' - to listen on a TCP socket to all addresses on a | ||
148 | ; specific port; | ||
149 | ; '/path/to/unix/socket' - to listen on a unix socket. | ||
150 | ; Note: This value is mandatory. | ||
151 | listen = 127.0.0.1:9000 | ||
152 | |||
153 | ; Set listen(2) backlog. A value of '-1' means unlimited. | ||
154 | ; Default Value: 128 (-1 on FreeBSD and OpenBSD) | ||
155 | ;listen.backlog = -1 | ||
156 | |||
157 | ; Set permissions for unix socket, if one is used. In Linux, read/write | ||
158 | ; permissions must be set in order to allow connections from a web server. Many | ||
159 | ; BSD-derived systems allow connections regardless of permissions. | ||
160 | ; Default Values: user and group are set as the running user | ||
161 | ; mode is set to 0666 | ||
162 | ;listen.owner = nobody | ||
163 | ;listen.group = nobody | ||
164 | ;listen.mode = 0666 | ||
165 | |||
166 | ; List of ipv4 addresses of FastCGI clients which are allowed to connect. | ||
167 | ; Equivalent to the FCGI_WEB_SERVER_ADDRS environment variable in the original | ||
168 | ; PHP FCGI (5.2.2+). Makes sense only with a tcp listening socket. Each address | ||
169 | ; must be separated by a comma. If this value is left blank, connections will be | ||
170 | ; accepted from any ip address. | ||
171 | ; Default Value: any | ||
172 | ;listen.allowed_clients = 127.0.0.1 | ||
173 | |||
174 | ; Specify the nice(2) priority to apply to the pool processes (only if set) | ||
175 | ; The value can vary from -19 (highest priority) to 20 (lower priority) | ||
176 | ; Note: - It will only work if the FPM master process is launched as root | ||
177 | ; - The pool processes will inherit the master process priority | ||
178 | ; unless it specified otherwise | ||
179 | ; Default Value: no set | ||
180 | ; priority = -19 | ||
181 | |||
182 | ; Choose how the process manager will control the number of child processes. | ||
183 | ; Possible Values: | ||
184 | ; static - a fixed number (pm.max_children) of child processes; | ||
185 | ; dynamic - the number of child processes are set dynamically based on the | ||
186 | ; following directives. With this process management, there will be | ||
187 | ; always at least 1 children. | ||
188 | ; pm.max_children - the maximum number of children that can | ||
189 | ; be alive at the same time. | ||
190 | ; pm.start_servers - the number of children created on startup. | ||
191 | ; pm.min_spare_servers - the minimum number of children in 'idle' | ||
192 | ; state (waiting to process). If the number | ||
193 | ; of 'idle' processes is less than this | ||
194 | ; number then some children will be created. | ||
195 | ; pm.max_spare_servers - the maximum number of children in 'idle' | ||
196 | ; state (waiting to process). If the number | ||
197 | ; of 'idle' processes is greater than this | ||
198 | ; number then some children will be killed. | ||
199 | ; ondemand - no children are created at startup. Children will be forked when | ||
200 | ; new requests will connect. The following parameter are used: | ||
201 | ; pm.max_children - the maximum number of children that | ||
202 | ; can be alive at the same time. | ||
203 | ; pm.process_idle_timeout - The number of seconds after which | ||
204 | ; an idle process will be killed. | ||
205 | ; Note: This value is mandatory. | ||
206 | pm = dynamic | ||
207 | |||
208 | ; The number of child processes to be created when pm is set to 'static' and the | ||
209 | ; maximum number of child processes when pm is set to 'dynamic' or 'ondemand'. | ||
210 | ; This value sets the limit on the number of simultaneous requests that will be | ||
211 | ; served. Equivalent to the ApacheMaxClients directive with mpm_prefork. | ||
212 | ; Equivalent to the PHP_FCGI_CHILDREN environment variable in the original PHP | ||
213 | ; CGI. The below defaults are based on a server without much resources. Don't | ||
214 | ; forget to tweak pm.* to fit your needs. | ||
215 | ; Note: Used when pm is set to 'static', 'dynamic' or 'ondemand' | ||
216 | ; Note: This value is mandatory. | ||
217 | pm.max_children = 5 | ||
218 | |||
219 | ; The number of child processes created on startup. | ||
220 | ; Note: Used only when pm is set to 'dynamic' | ||
221 | ; Default Value: min_spare_servers + (max_spare_servers - min_spare_servers) / 2 | ||
222 | pm.start_servers = 2 | ||
223 | |||
224 | ; The desired minimum number of idle server processes. | ||
225 | ; Note: Used only when pm is set to 'dynamic' | ||
226 | ; Note: Mandatory when pm is set to 'dynamic' | ||
227 | pm.min_spare_servers = 1 | ||
228 | |||
229 | ; The desired maximum number of idle server processes. | ||
230 | ; Note: Used only when pm is set to 'dynamic' | ||
231 | ; Note: Mandatory when pm is set to 'dynamic' | ||
232 | pm.max_spare_servers = 3 | ||
233 | |||
234 | ; The number of seconds after which an idle process will be killed. | ||
235 | ; Note: Used only when pm is set to 'ondemand' | ||
236 | ; Default Value: 10s | ||
237 | ;pm.process_idle_timeout = 10s; | ||
238 | |||
239 | ; The number of requests each child process should execute before respawning. | ||
240 | ; This can be useful to work around memory leaks in 3rd party libraries. For | ||
241 | ; endless request processing specify '0'. Equivalent to PHP_FCGI_MAX_REQUESTS. | ||
242 | ; Default Value: 0 | ||
243 | ;pm.max_requests = 500 | ||
244 | |||
245 | ; The URI to view the FPM status page. If this value is not set, no URI will be | ||
246 | ; recognized as a status page. It shows the following informations: | ||
247 | ; pool - the name of the pool; | ||
248 | ; process manager - static, dynamic or ondemand; | ||
249 | ; start time - the date and time FPM has started; | ||
250 | ; start since - number of seconds since FPM has started; | ||
251 | ; accepted conn - the number of request accepted by the pool; | ||
252 | ; listen queue - the number of request in the queue of pending | ||
253 | ; connections (see backlog in listen(2)); | ||
254 | ; max listen queue - the maximum number of requests in the queue | ||
255 | ; of pending connections since FPM has started; | ||
256 | ; listen queue len - the size of the socket queue of pending connections; | ||
257 | ; idle processes - the number of idle processes; | ||
258 | ; active processes - the number of active processes; | ||
259 | ; total processes - the number of idle + active processes; | ||
260 | ; max active processes - the maximum number of active processes since FPM | ||
261 | ; has started; | ||
262 | ; max children reached - number of times, the process limit has been reached, | ||
263 | ; when pm tries to start more children (works only for | ||
264 | ; pm 'dynamic' and 'ondemand'); | ||
265 | ; Value are updated in real time. | ||
266 | ; Example output: | ||
267 | ; pool: www | ||
268 | ; process manager: static | ||
269 | ; start time: 01/Jul/2011:17:53:49 +0200 | ||
270 | ; start since: 62636 | ||
271 | ; accepted conn: 190460 | ||
272 | ; listen queue: 0 | ||
273 | ; max listen queue: 1 | ||
274 | ; listen queue len: 42 | ||
275 | ; idle processes: 4 | ||
276 | ; active processes: 11 | ||
277 | ; total processes: 15 | ||
278 | ; max active processes: 12 | ||
279 | ; max children reached: 0 | ||
280 | ; | ||
281 | ; By default the status page output is formatted as text/plain. Passing either | ||
282 | ; 'html', 'xml' or 'json' in the query string will return the corresponding | ||
283 | ; output syntax. Example: | ||
284 | ; http://www.foo.bar/status | ||
285 | ; http://www.foo.bar/status?json | ||
286 | ; http://www.foo.bar/status?html | ||
287 | ; http://www.foo.bar/status?xml | ||
288 | ; | ||
289 | ; By default the status page only outputs short status. Passing 'full' in the | ||
290 | ; query string will also return status for each pool process. | ||
291 | ; Example: | ||
292 | ; http://www.foo.bar/status?full | ||
293 | ; http://www.foo.bar/status?json&full | ||
294 | ; http://www.foo.bar/status?html&full | ||
295 | ; http://www.foo.bar/status?xml&full | ||
296 | ; The Full status returns for each process: | ||
297 | ; pid - the PID of the process; | ||
298 | ; state - the state of the process (Idle, Running, ...); | ||
299 | ; start time - the date and time the process has started; | ||
300 | ; start since - the number of seconds since the process has started; | ||
301 | ; requests - the number of requests the process has served; | ||
302 | ; request duration - the duration in µs of the requests; | ||
303 | ; request method - the request method (GET, POST, ...); | ||
304 | ; request URI - the request URI with the query string; | ||
305 | ; content length - the content length of the request (only with POST); | ||
306 | ; user - the user (PHP_AUTH_USER) (or '-' if not set); | ||
307 | ; script - the main script called (or '-' if not set); | ||
308 | ; last request cpu - the %cpu the last request consumed | ||
309 | ; it's always 0 if the process is not in Idle state | ||
310 | ; because CPU calculation is done when the request | ||
311 | ; processing has terminated; | ||
312 | ; last request memory - the max amount of memory the last request consumed | ||
313 | ; it's always 0 if the process is not in Idle state | ||
314 | ; because memory calculation is done when the request | ||
315 | ; processing has terminated; | ||
316 | ; If the process is in Idle state, then informations are related to the | ||
317 | ; last request the process has served. Otherwise informations are related to | ||
318 | ; the current request being served. | ||
319 | ; Example output: | ||
320 | ; ************************ | ||
321 | ; pid: 31330 | ||
322 | ; state: Running | ||
323 | ; start time: 01/Jul/2011:17:53:49 +0200 | ||
324 | ; start since: 63087 | ||
325 | ; requests: 12808 | ||
326 | ; request duration: 1250261 | ||
327 | ; request method: GET | ||
328 | ; request URI: /test_mem.php?N=10000 | ||
329 | ; content length: 0 | ||
330 | ; user: - | ||
331 | ; script: /home/fat/web/docs/php/test_mem.php | ||
332 | ; last request cpu: 0.00 | ||
333 | ; last request memory: 0 | ||
334 | ; | ||
335 | ; Note: There is a real-time FPM status monitoring sample web page available | ||
336 | ; It's available in: /usr/share/fpm/status.html | ||
337 | ; | ||
338 | ; Note: The value must start with a leading slash (/). The value can be | ||
339 | ; anything, but it may not be a good idea to use the .php extension or it | ||
340 | ; may conflict with a real PHP file. | ||
341 | ; Default Value: not set | ||
342 | ;pm.status_path = /status | ||
343 | |||
344 | ; The ping URI to call the monitoring page of FPM. If this value is not set, no | ||
345 | ; URI will be recognized as a ping page. This could be used to test from outside | ||
346 | ; that FPM is alive and responding, or to | ||
347 | ; - create a graph of FPM availability (rrd or such); | ||
348 | ; - remove a server from a group if it is not responding (load balancing); | ||
349 | ; - trigger alerts for the operating team (24/7). | ||
350 | ; Note: The value must start with a leading slash (/). The value can be | ||
351 | ; anything, but it may not be a good idea to use the .php extension or it | ||
352 | ; may conflict with a real PHP file. | ||
353 | ; Default Value: not set | ||
354 | ;ping.path = /ping | ||
355 | |||
356 | ; This directive may be used to customize the response of a ping request. The | ||
357 | ; response is formatted as text/plain with a 200 response code. | ||
358 | ; Default Value: pong | ||
359 | ;ping.response = pong | ||
360 | |||
361 | ; The access log file | ||
362 | ; Default: not set | ||
363 | ;access.log = log/$pool.access.log | ||
364 | |||
365 | ; The access log format. | ||
366 | ; The following syntax is allowed | ||
367 | ; %%: the '%' character | ||
368 | ; %C: %CPU used by the request | ||
369 | ; it can accept the following format: | ||
370 | ; - %{user}C for user CPU only | ||
371 | ; - %{system}C for system CPU only | ||
372 | ; - %{total}C for user + system CPU (default) | ||
373 | ; %d: time taken to serve the request | ||
374 | ; it can accept the following format: | ||
375 | ; - %{seconds}d (default) | ||
376 | ; - %{miliseconds}d | ||
377 | ; - %{mili}d | ||
378 | ; - %{microseconds}d | ||
379 | ; - %{micro}d | ||
380 | ; %e: an environment variable (same as $_ENV or $_SERVER) | ||
381 | ; it must be associated with embraces to specify the name of the env | ||
382 | ; variable. Some exemples: | ||
383 | ; - server specifics like: %{REQUEST_METHOD}e or %{SERVER_PROTOCOL}e | ||
384 | ; - HTTP headers like: %{HTTP_HOST}e or %{HTTP_USER_AGENT}e | ||
385 | ; %f: script filename | ||
386 | ; %l: content-length of the request (for POST request only) | ||
387 | ; %m: request method | ||
388 | ; %M: peak of memory allocated by PHP | ||
389 | ; it can accept the following format: | ||
390 | ; - %{bytes}M (default) | ||
391 | ; - %{kilobytes}M | ||
392 | ; - %{kilo}M | ||
393 | ; - %{megabytes}M | ||
394 | ; - %{mega}M | ||
395 | ; %n: pool name | ||
396 | ; %o: ouput header | ||
397 | ; it must be associated with embraces to specify the name of the header: | ||
398 | ; - %{Content-Type}o | ||
399 | ; - %{X-Powered-By}o | ||
400 | ; - %{Transfert-Encoding}o | ||
401 | ; - .... | ||
402 | ; %p: PID of the child that serviced the request | ||
403 | ; %P: PID of the parent of the child that serviced the request | ||
404 | ; %q: the query string | ||
405 | ; %Q: the '?' character if query string exists | ||
406 | ; %r: the request URI (without the query string, see %q and %Q) | ||
407 | ; %R: remote IP address | ||
408 | ; %s: status (response code) | ||
409 | ; %t: server time the request was received | ||
410 | ; it can accept a strftime(3) format: | ||
411 | ; %d/%b/%Y:%H:%M:%S %z (default) | ||
412 | ; %T: time the log has been written (the request has finished) | ||
413 | ; it can accept a strftime(3) format: | ||
414 | ; %d/%b/%Y:%H:%M:%S %z (default) | ||
415 | ; %u: remote user | ||
416 | ; | ||
417 | ; Default: "%R - %u %t \"%m %r\" %s" | ||
418 | ;access.format = "%R - %u %t \"%m %r%Q%q\" %s %f %{mili}d %{kilo}M %C%%" | ||
419 | |||
420 | ; The log file for slow requests | ||
421 | ; Default Value: not set | ||
422 | ; Note: slowlog is mandatory if request_slowlog_timeout is set | ||
423 | ;slowlog = log/$pool.log.slow | ||
424 | |||
425 | ; The timeout for serving a single request after which a PHP backtrace will be | ||
426 | ; dumped to the 'slowlog' file. A value of '0s' means 'off'. | ||
427 | ; Available units: s(econds)(default), m(inutes), h(ours), or d(ays) | ||
428 | ; Default Value: 0 | ||
429 | ;request_slowlog_timeout = 0 | ||
430 | |||
431 | ; The timeout for serving a single request after which the worker process will | ||
432 | ; be killed. This option should be used when the 'max_execution_time' ini option | ||
433 | ; does not stop script execution for some reason. A value of '0' means 'off'. | ||
434 | ; Available units: s(econds)(default), m(inutes), h(ours), or d(ays) | ||
435 | ; Default Value: 0 | ||
436 | ;request_terminate_timeout = 0 | ||
437 | |||
438 | ; Set open file descriptor rlimit. | ||
439 | ; Default Value: system defined value | ||
440 | ;rlimit_files = 1024 | ||
441 | |||
442 | ; Set max core size rlimit. | ||
443 | ; Possible Values: 'unlimited' or an integer greater or equal to 0 | ||
444 | ; Default Value: system defined value | ||
445 | ;rlimit_core = 0 | ||
446 | |||
447 | ; Chroot to this directory at the start. This value must be defined as an | ||
448 | ; absolute path. When this value is not set, chroot is not used. | ||
449 | ; Note: you can prefix with '$prefix' to chroot to the pool prefix or one | ||
450 | ; of its subdirectories. If the pool prefix is not set, the global prefix | ||
451 | ; will be used instead. | ||
452 | ; Note: chrooting is a great security feature and should be used whenever | ||
453 | ; possible. However, all PHP paths will be relative to the chroot | ||
454 | ; (error_log, sessions.save_path, ...). | ||
455 | ; Default Value: not set | ||
456 | ;chroot = | ||
457 | |||
458 | ; Chdir to this directory at the start. | ||
459 | ; Note: relative path can be used. | ||
460 | ; Default Value: current directory or / when chroot | ||
461 | ;chdir = /var/www | ||
462 | |||
463 | ; Redirect worker stdout and stderr into main error log. If not set, stdout and | ||
464 | ; stderr will be redirected to /dev/null according to FastCGI specs. | ||
465 | ; Note: on highloaded environement, this can cause some delay in the page | ||
466 | ; process time (several ms). | ||
467 | ; Default Value: no | ||
468 | ;catch_workers_output = yes | ||
469 | |||
470 | ; Limits the extensions of the main script FPM will allow to parse. This can | ||
471 | ; prevent configuration mistakes on the web server side. You should only limit | ||
472 | ; FPM to .php extensions to prevent malicious users to use other extensions to | ||
473 | ; exectute php code. | ||
474 | ; Note: set an empty value to allow all extensions. | ||
475 | ; Default Value: .php | ||
476 | ;security.limit_extensions = .php .php3 .php4 .php5 | ||
477 | |||
478 | ; Pass environment variables like LD_LIBRARY_PATH. All $VARIABLEs are taken from | ||
479 | ; the current environment. | ||
480 | ; Default Value: clean env | ||
481 | ;env[HOSTNAME] = $HOSTNAME | ||
482 | ;env[PATH] = /usr/local/bin:/usr/bin:/bin | ||
483 | ;env[TMP] = /tmp | ||
484 | ;env[TMPDIR] = /tmp | ||
485 | ;env[TEMP] = /tmp | ||
486 | |||
487 | ; Additional php.ini defines, specific to this pool of workers. These settings | ||
488 | ; overwrite the values previously defined in the php.ini. The directives are the | ||
489 | ; same as the PHP SAPI: | ||
490 | ; php_value/php_flag - you can set classic ini defines which can | ||
491 | ; be overwritten from PHP call 'ini_set'. | ||
492 | ; php_admin_value/php_admin_flag - these directives won't be overwritten by | ||
493 | ; PHP call 'ini_set' | ||
494 | ; For php_*flag, valid values are on, off, 1, 0, true, false, yes or no. | ||
495 | |||
496 | ; Defining 'extension' will load the corresponding shared extension from | ||
497 | ; extension_dir. Defining 'disable_functions' or 'disable_classes' will not | ||
498 | ; overwrite previously defined php.ini values, but will append the new value | ||
499 | ; instead. | ||
500 | |||
501 | ; Note: path INI options can be relative and will be expanded with the prefix | ||
502 | ; (pool, global or /usr) | ||
503 | |||
504 | ; Default Value: nothing is defined by default except the values in php.ini and | ||
505 | ; specified at startup with the -d argument | ||
506 | ;php_admin_value[sendmail_path] = /usr/sbin/sendmail -t -i -f www@my.domain.com | ||
507 | ;php_flag[display_errors] = off | ||
508 | ;php_admin_value[error_log] = /var/log/fpm-php.www.log | ||
509 | ;php_admin_flag[log_errors] = on | ||
510 | ;php_admin_value[memory_limit] = 32M | ||
diff --git a/meta-oe/recipes-devtools/php/php_5.3.19.bb b/meta-oe/recipes-devtools/php/php_5.3.19.bb index e96b76078..27baa1d79 100644 --- a/meta-oe/recipes-devtools/php/php_5.3.19.bb +++ b/meta-oe/recipes-devtools/php/php_5.3.19.bb | |||
@@ -13,6 +13,8 @@ SRC_URI_append_pn-php += "file://iconv.patch \ | |||
13 | file://pear-makefile.patch \ | 13 | file://pear-makefile.patch \ |
14 | file://phar-makefile.patch \ | 14 | file://phar-makefile.patch \ |
15 | file://php_exec_native.patch \ | 15 | file://php_exec_native.patch \ |
16 | file://fix-fpm-cross-compile.patch \ | ||
17 | file://php-fpm.conf \ | ||
16 | " | 18 | " |
17 | 19 | ||
18 | SRC_URI[md5sum] = "e1d2a3ec7849d4b3032bd1abf1916aa4" | 20 | SRC_URI[md5sum] = "e1d2a3ec7849d4b3032bd1abf1916aa4" |