diff options
author | Lauren Post <lauren.post@freescale.com> | 2014-04-19 10:38:16 -0300 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-04-21 13:31:48 +0200 |
commit | 7f9e810cb66c16574efb7bc14275835fe53f35f9 (patch) | |
tree | a41365f1f382089ca1e1e52815e595d37a1bbee0 /meta-oe | |
parent | 3811927ec19f9995bc48277d70c296275fea0bd4 (diff) | |
download | meta-openembedded-7f9e810cb66c16574efb7bc14275835fe53f35f9.tar.gz |
glcompbench: Create 2012.08 version
glcompbench is a benchmark tool for GL(ES)2 based
compositing operations
Signed-off-by: Lauren Post <lauren.post@freescale.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-graphics/glcompbench/glcompbench/glbench-compile-fix.patch | 35 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb | 14 |
2 files changed, 49 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/glcompbench/glcompbench/glbench-compile-fix.patch b/meta-oe/recipes-graphics/glcompbench/glcompbench/glbench-compile-fix.patch new file mode 100644 index 000000000..374a6cf66 --- /dev/null +++ b/meta-oe/recipes-graphics/glcompbench/glcompbench/glbench-compile-fix.patch | |||
@@ -0,0 +1,35 @@ | |||
1 | From c4bc44c3abf69f26e4c2b7684f4da4670a51f993 Mon Sep 17 00:00:00 2001 | ||
2 | From: Prabhu Sundararaj <prabhu.sundararaj@freescale.com> | ||
3 | Date: Tue, 5 Nov 2013 11:03:04 -0600 | ||
4 | Subject: [PATCH] to make compilable | ||
5 | |||
6 | Upstream Status: Inappropriate [workaround] | ||
7 | |||
8 | Signed-off-by: Prabhu Sundararaj <prabhu.sundararaj@freescale.com> | ||
9 | --- | ||
10 | src/composite-test-simple-blur.cc | 2 ++ | ||
11 | 1 file changed, 2 insertions(+) | ||
12 | |||
13 | diff --git a/src/composite-test-simple-blur.cc b/src/composite-test-simple-blur.cc | ||
14 | index 170ad64..d7f77cf 100644 | ||
15 | --- a/src/composite-test-simple-blur.cc | ||
16 | +++ b/src/composite-test-simple-blur.cc | ||
17 | @@ -347,6 +347,7 @@ CompositeTestSimpleBlur::CompositeTestSimpleBlur() : | ||
18 | |||
19 | CompositeTestSimpleBlur::~CompositeTestSimpleBlur() | ||
20 | { | ||
21 | +#if 0 | ||
22 | for (BlurWindowMapType::iterator winIt = priv_->windowMap.begin(); | ||
23 | winIt != priv_->windowMap.end(); | ||
24 | winIt++) | ||
25 | @@ -354,6 +355,7 @@ CompositeTestSimpleBlur::~CompositeTestSimpleBlur() | ||
26 | RenderWindowBlur* ro = winIt->second; | ||
27 | delete ro; | ||
28 | } | ||
29 | +#endif | ||
30 | delete priv_; | ||
31 | } | ||
32 | |||
33 | -- | ||
34 | 1.8.1.2 | ||
35 | |||
diff --git a/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb b/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb new file mode 100644 index 000000000..51f57b934 --- /dev/null +++ b/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb | |||
@@ -0,0 +1,14 @@ | |||
1 | SUMMARY = "A benchmark for GL(ES)2 based compositing operations" | ||
2 | LICENSE = "GPLv3" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949" | ||
4 | |||
5 | DEPENDS = "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2 \ | ||
6 | virtual/libx11 libxcomposite pixman libxrender libpng12" | ||
7 | |||
8 | SRC_URI = "https://launchpad.net/glcompbench/trunk/${PV}/+download/${BPN}-${PV}.tar.gz \ | ||
9 | file://glbench-compile-fix.patch" | ||
10 | |||
11 | SRC_URI[md5sum] = "c939d9156fe940960098f38707fea827" | ||
12 | SRC_URI[sha256sum] = "b04b738cec06c6786ceafa86e4735fd8b971c078265754854ef356b0379542ee" | ||
13 | |||
14 | inherit pkgconfig waf | ||