diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2018-10-02 17:33:56 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-10-02 17:17:10 -0700 |
commit | 7e267304b78da6a0f0a959950428a3844364ef39 (patch) | |
tree | e2f16161349e0992c2da2fede060ccb8113ba1ef /meta-oe | |
parent | ab43d224790ba1489573167bdafdb4cc9c165203 (diff) | |
download | meta-openembedded-7e267304b78da6a0f0a959950428a3844364ef39.tar.gz |
android-tools: depends on openssl10 only for target builds
* openssl isn't used by TOOLS enabled for native and nativesdk builds:
TOOLS_class-native = "fastboot ext4_utils mkbootimg"
TOOLS_class-nativesdk = "fastboot ext4_utils mkbootimg"
it's used e.g. by adb which is enabled only for target
* with openssl10 it cannot be really used by anything, because
openssl.cnf from openssl10-native will conflict with openssl.cnf
installed to RSS by openssl-native, causing:
DEBUG: Executing python function sstate_task_prefunc
DEBUG: Python function sstate_task_prefunc finished
DEBUG: Executing python function extend_recipe_sysroot
NOTE: Direct dependencies are ['virtual:native:/OE/build/owpb/webos-ports/openembedded-core/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.44.3.bb:do_populate_sysroot',
'/OE/build/owpb/webos-ports/openembedded-core/meta/recipes-devtools/quilt/quilt-native_0.65.bb:do_populate_sysroot',
'/OE/build/owpb/webos-ports/openembedded-core/meta/recipes-devtools/gcc/gcc-cross_8.2.bb:do_populate_sysroot',
'/OE/build/owpb/webos-ports/openembedded-core/meta/recipes-devtools/gcc/gcc-runtime_8.2.bb:do_populate_sysroot',
'/OE/build/owpb/webos-ports/openembedded-core/meta/recipes-core/glibc/glibc_2.28.bb:do_populate_sysroot',
'virtual:native:/OE/build/owpb/webos-ports/meta-openembedded/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb:do_populate_sysroot',
'virtual:native:/OE/build/owpb/webos-ports/openembedded-core/meta/recipes-devtools/rpm/rpm_4.14.2.bb:do_populate_sysroot',
'virtual:native:/OE/build/owpb/webos-ports/openembedded-core/meta/recipes-devtools/dwarfsrcfiles/dwarfsrcfiles.bb:do_populate_sysroot',
'virtual:native:/OE/build/owpb/webos-ports/openembedded-core/meta/recipes-devtools/pseudo/pseudo_git.bb:do_populate_sysroot']
ERROR: Error executing a python function in exec_python_func() autogenerated:
The stack trace of python calls that resulted in this exception/failure was:
File: 'exec_python_func() autogenerated', lineno: 2, function: <module>
0001:
*** 0002:extend_recipe_sysroot(d)
0003:
File: '/OE/build/owpb/webos-ports/openembedded-core/meta/classes/staging.bbclass', lineno: 553, function: extend_recipe_sysroot
0549: dest = newmanifest[l]
0550: if l.endswith("/"):
0551: staging_copydir(l, targetdir, dest, seendirs)
0552: continue
*** 0553: staging_copyfile(l, targetdir, dest, postinsts, seendirs)
0554:
0555: bb.note("Installed into sysroot: %s" % str(msg_adding))
0556: bb.note("Skipping as already exists in sysroot: %s" % str(msg_exists))
0557:
File: '/OE/build/owpb/webos-ports/openembedded-core/meta/classes/staging.bbclass', lineno: 151, function: staging_copyfile
0147: os.symlink(linkto, dest)
0148: #bb.warn(c)
0149: else:
0150: try:
*** 0151: os.link(c, dest)
0152: except OSError as err:
0153: if err.errno == errno.EXDEV:
0154: bb.utils.copyfile(c, dest)
0155: else:
Exception: FileExistsError: [Errno 17] File exists: '/OE/build/owpb/webos-ports/tmp-glibc/sysroots-components/x86_64/openssl-native/etc/ssl/openssl.cnf' -> '/OE/build/owpb/webos-ports/tmp-glibc/work/tissot-webos-linux/android-system-image-tissot/20180914-22-r0/recipe-sysroot-native/etc/ssl/openssl.cnf'
DEBUG: Python function extend_recipe_sysroot finished
ERROR: Function failed: extend_recipe_sysroot
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb | 3 |
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb b/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb index 6972ad70a..adf372d8b 100644 --- a/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb +++ b/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb | |||
@@ -7,7 +7,8 @@ LIC_FILES_CHKSUM = " \ | |||
7 | file://${COMMON_LICENSE_DIR}/BSD-2-Clause;md5=8bef8e6712b1be5aa76af1ebde9d6378 \ | 7 | file://${COMMON_LICENSE_DIR}/BSD-2-Clause;md5=8bef8e6712b1be5aa76af1ebde9d6378 \ |
8 | file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9 \ | 8 | file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9 \ |
9 | " | 9 | " |
10 | DEPENDS = "libbsd libpcre openssl10 zlib libcap" | 10 | DEPENDS = "libbsd libpcre zlib libcap" |
11 | DEPENDS_append_class-target = " openssl10" | ||
11 | 12 | ||
12 | ANDROID_MIRROR = "android.googlesource.com" | 13 | ANDROID_MIRROR = "android.googlesource.com" |
13 | CORE_REPO = "${ANDROID_MIRROR}/platform/system/core" | 14 | CORE_REPO = "${ANDROID_MIRROR}/platform/system/core" |