summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorZheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>2019-11-08 18:08:44 +0800
committerKhem Raj <raj.khem@gmail.com>2019-11-08 09:03:54 -0800
commit75afdfd44d93aa35e6a1fba25cd5f43315e434e9 (patch)
tree020a3f8347f984b826ba1f7cb46974924ea14779 /meta-oe
parentb0b9cebc72a7f6e4451b64e54701709cee30fded (diff)
downloadmeta-openembedded-75afdfd44d93aa35e6a1fba25cd5f43315e434e9.tar.gz
syslog-ng: upgrade 3.19.1 -> 3.24.1
(1) Refresh three patches for new version. fix-config-libnet.patch syslog-ng.service-the-syslog-ng-service.patch 0001-syslog-ng-fix-segment-fault-during-service-start.patch Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/0001-syslog-ng-fix-segment-fault-during-service-start.patch27
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch44
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/syslog-ng.service-the-syslog-ng-service.patch24
-rw-r--r--meta-oe/recipes-support/syslog-ng/syslog-ng_3.24.1.bb (renamed from meta-oe/recipes-support/syslog-ng/syslog-ng_3.19.1.bb)4
4 files changed, 50 insertions, 49 deletions
diff --git a/meta-oe/recipes-support/syslog-ng/files/0001-syslog-ng-fix-segment-fault-during-service-start.patch b/meta-oe/recipes-support/syslog-ng/files/0001-syslog-ng-fix-segment-fault-during-service-start.patch
index 0fc40be4a..b5bfcd025 100644
--- a/meta-oe/recipes-support/syslog-ng/files/0001-syslog-ng-fix-segment-fault-during-service-start.patch
+++ b/meta-oe/recipes-support/syslog-ng/files/0001-syslog-ng-fix-segment-fault-during-service-start.patch
@@ -1,6 +1,3 @@
1From caeccb7bec45f65bc89efa8195b3853368328361 Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com>
3Date: Mon, 17 Sep 2018 12:49:36 +0800
4Subject: [PATCH] syslog-ng: fix segment fault during service start on arm64 1Subject: [PATCH] syslog-ng: fix segment fault during service start on arm64
5 2
6service start failed since segment fault on arch arm64, 3service start failed since segment fault on arch arm64,
@@ -17,12 +14,15 @@ https://github.com/buytenh/ivykis/issues/15
17Upstream-Status: Pending 14Upstream-Status: Pending
18 15
19Signed-off-by: Changqing Li <changqing.li@windriver.com> 16Signed-off-by: Changqing Li <changqing.li@windriver.com>
17
18Update for 3.24.1.
19Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
20--- 20---
21 lib/ivykis/src/pthr.h | 24 ++++++++++++------------ 21 lib/ivykis/src/pthr.h | 23 ++++++++++++-----------
22 1 file changed, 12 insertions(+), 12 deletions(-) 22 1 file changed, 12 insertions(+), 11 deletions(-)
23 23
24diff --git a/lib/ivykis/src/pthr.h b/lib/ivykis/src/pthr.h 24diff --git a/lib/ivykis/src/pthr.h b/lib/ivykis/src/pthr.h
25index a41eaf3..72c5190 100644 25index 29e4be7..5d29096 100644
26--- a/lib/ivykis/src/pthr.h 26--- a/lib/ivykis/src/pthr.h
27+++ b/lib/ivykis/src/pthr.h 27+++ b/lib/ivykis/src/pthr.h
28@@ -24,6 +24,16 @@ 28@@ -24,6 +24,16 @@
@@ -47,12 +47,12 @@ index a41eaf3..72c5190 100644
47 #ifdef HAVE_PRAGMA_WEAK 47 #ifdef HAVE_PRAGMA_WEAK
48 48
49-/* 49-/*
50- * On Linux, pthread_atfork() is defined in libpthread_nonshared.a, 50- * On Linux, pthread_atfork() is defined in libc_nonshared.a (for
51- * a static library, and we want to avoid "#pragma weak" for that 51- * glibc >= 2.28) or libpthread_nonshared.a (for glibc <= 2.27), and
52- * symbol because that causes it to be undefined even if you link 52- * we want to avoid "#pragma weak" for that symbol because that causes
53- * libpthread_nonshared.a in explicitly. 53- * it to be undefined even if you link lib*_nonshared.a in explicitly.
54- */ 54- */
55-#ifndef HAVE_LIBPTHREAD_NONSHARED 55-#if !defined(HAVE_LIBC_NONSHARED) && !defined(HAVE_LIBPTHREAD_NONSHARED)
56-#pragma weak pthread_atfork 56-#pragma weak pthread_atfork
57-#endif 57-#endif
58- 58-
@@ -60,16 +60,15 @@ index a41eaf3..72c5190 100644
60 #pragma weak pthread_create 60 #pragma weak pthread_create
61 #pragma weak pthread_detach 61 #pragma weak pthread_detach
62 #pragma weak pthread_getspecific 62 #pragma weak pthread_getspecific
63@@ -73,8 +74,7 @@ static inline int 63@@ -73,7 +74,7 @@ static inline int
64 pthr_atfork(void (*prepare)(void), void (*parent)(void), void (*child)(void)) 64 pthr_atfork(void (*prepare)(void), void (*parent)(void), void (*child)(void))
65 { 65 {
66 if (pthreads_available()) 66 if (pthreads_available())
67- return pthread_atfork(prepare, parent, child); 67- return pthread_atfork(prepare, parent, child);
68-
69+ return __register_atfork(prepare, parent, child, __dso_handle); 68+ return __register_atfork(prepare, parent, child, __dso_handle);
69
70 return ENOSYS; 70 return ENOSYS;
71 } 71 }
72
73-- 72--
742.7.4 732.7.4
75 74
diff --git a/meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch b/meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch
index 553f4a517..4ad0afa95 100644
--- a/meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch
+++ b/meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch
@@ -6,25 +6,28 @@ This would avoid a implicit auto-detecting result.
6 6
7Signed-off-by: Ming Liu <ming.liu@windriver.com> 7Signed-off-by: Ming Liu <ming.liu@windriver.com>
8Signed-off-by: Jackie Huang <jackie.huang@windriver.com> 8Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
9
10Update for 3.24.1.
11Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
9--- 12---
10 configure.ac | 27 +++++++++++++++++---------- 13 configure.ac | 28 ++++++++++++++++------------
11 1 files changed, 17 insertions(+), 10 deletions(-) 14 1 file changed, 16 insertions(+), 12 deletions(-)
12 15
13Index: syslog-ng-3.8.1/configure.ac 16diff --git a/configure.ac b/configure.ac
14=================================================================== 17index 00eb566..e7d5ac1 100644
15--- syslog-ng-3.8.1.orig/configure.ac 18--- a/configure.ac
16+++ syslog-ng-3.8.1/configure.ac 19+++ b/configure.ac
17@@ -104,6 +104,9 @@ AC_CONFIG_HEADERS(config.h) 20@@ -143,6 +143,9 @@ AC_CONFIG_HEADERS(config.h)
18 dnl *************************************************************************** 21 dnl ***************************************************************************
19 dnl Arguments 22 dnl Arguments
20 23
21+AC_ARG_ENABLE(libnet, 24+AC_ARG_ENABLE(libnet,
22+ [ --enable-libnet Enable libnet support.],, enable_libnet="no") 25+ [ --enable-libnet Enable libnet support.],, enable_libnet="no")
23+ 26+
24 AC_ARG_WITH(libnet, 27 AC_ARG_WITH(libnet,
25 [ --with-libnet=path use path to libnet-config script], 28 [ --with-libnet=path use path to libnet-config script],
26 , 29 ,
27@@ -893,22 +896,26 @@ dnl ************************************ 30@@ -1047,19 +1050,20 @@ dnl ***************************************************************************
28 dnl libnet headers/libraries 31 dnl libnet headers/libraries
29 dnl *************************************************************************** 32 dnl ***************************************************************************
30 AC_MSG_CHECKING(for LIBNET) 33 AC_MSG_CHECKING(for LIBNET)
@@ -39,7 +42,14 @@ Index: syslog-ng-3.8.1/configure.ac
39+ else 42+ else
40+ LIBNET_CONFIG="$with_libnet/libnet-config" 43+ LIBNET_CONFIG="$with_libnet/libnet-config"
41+ fi 44+ fi
42+ 45
46-if test -n "$LIBNET_CONFIG" -a -x "$LIBNET_CONFIG"; then
47- LIBNET_CFLAGS="`$LIBNET_CONFIG --defines`"
48- LIBNET_LIBS="`$LIBNET_CONFIG --libs`"
49- AC_MSG_RESULT(yes)
50-dnl libnet-config does not provide the _DEFAULT_SOURCE define, that can cause warning during build
51-dnl as upstream libnet-config does uses _DEFAULT_SOURCE this is just a fix till
52- LIBNET_CFLAGS="$LIBNET_CFLAGS -D_DEFAULT_SOURCE"
43+ if test -n "$LIBNET_CONFIG" -a -x "$LIBNET_CONFIG"; then 53+ if test -n "$LIBNET_CONFIG" -a -x "$LIBNET_CONFIG"; then
44+ LIBNET_CFLAGS="`$LIBNET_CONFIG --defines`" 54+ LIBNET_CFLAGS="`$LIBNET_CONFIG --defines`"
45+ LIBNET_LIBS="`$LIBNET_CONFIG --libs`" 55+ LIBNET_LIBS="`$LIBNET_CONFIG --libs`"
@@ -48,16 +58,8 @@ Index: syslog-ng-3.8.1/configure.ac
48+ AC_MSG_ERROR([Could not find libnet, and libnet support was explicitly enabled.]) 58+ AC_MSG_ERROR([Could not find libnet, and libnet support was explicitly enabled.])
49+ fi 59+ fi
50 60
51-if test -n "$LIBNET_CONFIG" -a -x "$LIBNET_CONFIG"; then
52- LIBNET_CFLAGS="`$LIBNET_CONFIG --defines`"
53- LIBNET_LIBS="`$LIBNET_CONFIG --libs`"
54- AC_MSG_RESULT(yes)
55 else 61 else
56 LIBNET_LIBS= 62 LIBNET_LIBS=
57 AC_MSG_RESULT(no) 63--
58 fi 642.7.4
59 65
60-
61 if test "x$enable_spoof_source" = "xauto"; then
62 AC_MSG_CHECKING(whether to enable spoof source support)
63 if test "x$LIBNET_LIBS" != "x"; then
diff --git a/meta-oe/recipes-support/syslog-ng/files/syslog-ng.service-the-syslog-ng-service.patch b/meta-oe/recipes-support/syslog-ng/files/syslog-ng.service-the-syslog-ng-service.patch
index 39c3f59ce..0e1d09492 100644
--- a/meta-oe/recipes-support/syslog-ng/files/syslog-ng.service-the-syslog-ng-service.patch
+++ b/meta-oe/recipes-support/syslog-ng/files/syslog-ng.service-the-syslog-ng-service.patch
@@ -1,16 +1,17 @@
1From 0be9c08dd3f825e92fa02d4a08d8aff743109e61 Mon Sep 17 00:00:00 2001 1Subject: [PATCH] syslog-ng.service: the syslog-ng service can not start
2From: Li xin <lixin.fnst@cn.fujitsu.com>
3Date: Wed, 17 Jun 2015 14:46:30 +0900
4Subject: [PATCH] syslog-ng.service: the syslog-ng service can not start
5 successfully,so modify it. 2 successfully,so modify it.
6 3
7Upstream-Status: pending 4Upstream-Status: pending
8 5
9Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> 6Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com>
10Updated-by: Andrej Valek <andrej.valek@siemens.com> 7Updated-by: Andrej Valek <andrej.valek@siemens.com>
8
9Update for 3.24.1
10Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
11--- 11---
12 contrib/systemd/syslog-ng.service | 5 ++--- 12 contrib/systemd/syslog-ng@.service | 4 ++--
13 1 file changed, 2 insertion(+), 3 deletions(-) 13 contrib/systemd/syslog-ng@default | 6 +++---
14 2 files changed, 5 insertions(+), 5 deletions(-)
14 15
15diff --git a/contrib/systemd/syslog-ng@.service b/contrib/systemd/syslog-ng@.service 16diff --git a/contrib/systemd/syslog-ng@.service b/contrib/systemd/syslog-ng@.service
16index a28640e..93aec94 100644 17index a28640e..93aec94 100644
@@ -28,19 +29,18 @@ index a28640e..93aec94 100644
28 StandardError=journal 29 StandardError=journal
29 Restart=on-failure 30 Restart=on-failure
30diff --git a/contrib/systemd/syslog-ng@default b/contrib/systemd/syslog-ng@default 31diff --git a/contrib/systemd/syslog-ng@default b/contrib/systemd/syslog-ng@default
31index 02da288..3a8215d 100644 32index 0ccc2b9..7f08c0e 100644
32--- a/contrib/systemd/syslog-ng@default 33--- a/contrib/systemd/syslog-ng@default
33+++ b/contrib/systemd/syslog-ng@default 34+++ b/contrib/systemd/syslog-ng@default
34@@ -1,5 +1,5 @@ 35@@ -1,5 +1,5 @@
35-CONFIG_FILE=/etc/syslog-ng.conf 36 CONFIG_FILE=/etc/syslog-ng/syslog-ng.conf
36-PERSIST_FILE=/var/lib/syslog-ng/syslog-ng.persist 37-PERSIST_FILE=/var/lib/syslog-ng/syslog-ng.persist
37-CONTROL_FILE=/var/lib/syslog-ng/syslog-ng.ctl 38-CONTROL_FILE=/var/run/syslog-ng.ctl
38-PID_FILE=/var/run/syslog-ng.pid 39-PID_FILE=/var/run/syslog-ng.pid
39+CONFIG_FILE=/etc/syslog-ng/syslog-ng.conf
40+PERSIST_FILE=@LOCALSTATEDIR@/lib/syslog-ng/syslog-ng.persist 40+PERSIST_FILE=@LOCALSTATEDIR@/lib/syslog-ng/syslog-ng.persist
41+CONTROL_FILE=@LOCALSTATEDIR@/lib/syslog-ng/syslog-ng.ctl 41+CONTROL_FILE=@LOCALSTATEDIR@/lib/syslog-ng/syslog-ng.ctl
42+PID_FILE=@LOCALSTATEDIR@/run/syslog-ng.pid 42+PID_FILE=@LOCALSTATEDIR@/run/syslog-ng.pid
43 OTHER_OPTIONS="--enable-core" 43 OTHER_OPTIONS="--enable-core"
44
45-- 44--
461.8.4.2 452.7.4
46
diff --git a/meta-oe/recipes-support/syslog-ng/syslog-ng_3.19.1.bb b/meta-oe/recipes-support/syslog-ng/syslog-ng_3.24.1.bb
index 852343c23..01ed76765 100644
--- a/meta-oe/recipes-support/syslog-ng/syslog-ng_3.19.1.bb
+++ b/meta-oe/recipes-support/syslog-ng/syslog-ng_3.24.1.bb
@@ -10,5 +10,5 @@ SRC_URI += " \
10 file://syslog-ng-tmp.conf \ 10 file://syslog-ng-tmp.conf \
11 " 11 "
12 12
13SRC_URI[md5sum] = "aa79bc13d9fd925aa5fb9516e87aacd3" 13SRC_URI[md5sum] = "ef9de066793f7358af7312b964ac0450"
14SRC_URI[sha256sum] = "5cf931a9d7bead0e6d9a2c65eee8f6005a005878f59aa280f3c4294257ed5178" 14SRC_URI[sha256sum] = "d4d0a0357b452be96b69d6f741129275530d8f0451e35adc408ad5635059fa3d"